summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/moc/moc-1.1.0.ebuild')
-rw-r--r--media-sound/moc/moc-1.1.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/media-sound/moc/moc-1.1.0.ebuild b/media-sound/moc/moc-1.1.0.ebuild
deleted file mode 100644
index 58fa6b3c5153..000000000000
--- a/media-sound/moc/moc-1.1.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/moc/moc-1.1.0.ebuild,v 1.13 2005/01/11 12:47:42 eradicator Exp $
-
-IUSE="oggvorbis mad oss"
-
-inherit eutils
-
-DESCRIPTION="Music On Console - ncurses interface for playing audio files"
-HOMEPAGE="http://moc.daper.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 sparc x86"
-
-DEPEND="media-libs/libao
- sys-libs/ncurses
- oggvorbis? ( media-libs/libvorbis )
- mad? ( media-libs/libmad sys-libs/zlib media-libs/libid3tag )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc3.patch
- epatch ${FILESDIR}/${P}-gcc34.patch
-}
-
-src_compile() {
- local myconf
- use oggvorbis || myconf="--without-ogg"
- use mad || myconf="${myconf} --without-mp3"
- use oss || myconf="${myconf} --without-oss"
-
- econf ${myconf} || die
- emake || die
-}
-
-src_install () {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README TODO
-}