summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nepenthes')
-rw-r--r--net-analyzer/nepenthes/ChangeLog10
-rw-r--r--net-analyzer/nepenthes/files/nepenthes-0.2.2-gcc4.patch26
-rw-r--r--net-analyzer/nepenthes/nepenthes-0.2.2.ebuild26
3 files changed, 50 insertions, 12 deletions
diff --git a/net-analyzer/nepenthes/ChangeLog b/net-analyzer/nepenthes/ChangeLog
index f9998c7028d7..61b807cf2684 100644
--- a/net-analyzer/nepenthes/ChangeLog
+++ b/net-analyzer/nepenthes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nepenthes
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/ChangeLog,v 1.17 2008/08/27 20:54:36 darkside Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/ChangeLog,v 1.18 2009/02/03 10:03:53 pva Exp $
+
+ 03 Feb 2009; Peter Volkov <pva@gentoo.org>
+ +files/nepenthes-0.2.2-gcc4.patch, nepenthes-0.2.2.ebuild:
+ Fixed build issue with newer compiler, bug #251437, thank Diego E.
+ 'Flameeyes' Pettenò for report and Michael Mair-Keimberger for making us
+ reopen and finally fix bug.
27 Aug 2008; Jeremy Olexa <darkside@gentoo.org> -nepenthes-0.2.0.ebuild:
remove old, bug #199168
diff --git a/net-analyzer/nepenthes/files/nepenthes-0.2.2-gcc4.patch b/net-analyzer/nepenthes/files/nepenthes-0.2.2-gcc4.patch
new file mode 100644
index 000000000000..bb4401754805
--- /dev/null
+++ b/net-analyzer/nepenthes/files/nepenthes-0.2.2-gcc4.patch
@@ -0,0 +1,26 @@
+=== modified file 'nepenthes-core/include/Config.hpp'
+--- nepenthes-core/include/Config.hpp 2009-02-03 09:39:19 +0000
++++ nepenthes-core/include/Config.hpp 2009-02-03 09:40:10 +0000
+@@ -32,6 +32,8 @@
+
+ #include <vector>
+ #include <map>
++#include <cstring>
++#include <stdlib.h>
+
+ // mmap()
+ #ifdef WIN32
+
+=== modified file 'nepenthes-core/include/Nepenthes.hpp'
+--- nepenthes-core/include/Nepenthes.hpp 2009-02-03 09:39:19 +0000
++++ nepenthes-core/include/Nepenthes.hpp 2009-02-03 09:40:12 +0000
+@@ -40,6 +40,8 @@
+
+ #include <stdint.h>
+ #include <string>
++#include <cstring>
++#include <cstdlib>
+
+ typedef unsigned char byte;
+
+
diff --git a/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild b/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
index b6202ac8882d..9c2f53a91dcb 100644
--- a/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
+++ b/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild,v 1.1 2008/05/14 02:41:32 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nepenthes/nepenthes-0.2.2.ebuild,v 1.2 2009/02/03 10:03:53 pva Exp $
-inherit eutils
+EAPI="2"
+inherit eutils autotools
DESCRIPTION="Nepenthes is a low interaction honeypot that captures worms by emulating known vulnerabilities"
HOMEPAGE="http://nepenthes.sourceforge.net"
@@ -26,11 +27,17 @@ pkg_setup() {
enewuser nepenthes -1 -1 /dev/null nepenthes
}
-src_compile() {
- local myconf="--sysconfdir=/etc --localstatedir=/var/lib/nepenthes --enable-capabilities"
- econf "${myconf}" || die
- sed -i 's|var/cache|/var/lib/cache|' "${S}"/modules/shellcode-signatures/shellcode-signatures.cpp
- emake || die "make failed"
+src_prepare() {
+ epatch ${FILESDIR}/${P}-gcc4.patch
+ sed 's|var/cache|/var/lib/cache|' -i modules/shellcode-signatures/shellcode-signatures.cpp
+ find . -name Makefile.am -exec sed 's: -Werror::' -i '{}' \;
+ eautoreconf
+}
+
+src_configure() {
+ econf --sysconfdir=/etc \
+ --localstatedir=/var/lib/nepenthes \
+ --enable-capabilities
}
src_install() {
@@ -47,10 +54,9 @@ src_install() {
-e 's|"etc|"/etc|' $i
done
- dodoc doc/README doc/README.VFS AUTHORS
+ dodoc doc/README.VFS AUTHORS
dosbin nepenthes-core/src/nepenthes || die "dosbin failed"
rm "${D}"/usr/bin/nepenthes
- rm "${D}"/usr/share/doc/README
rm "${D}"/usr/share/doc/README.VFS
rm "${D}"/usr/share/doc/logo-shaded.svg