summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog7
-rw-r--r--net-fs/samba/samba-4.1.14.ebuild10
2 files changed, 11 insertions, 6 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index c68d9ad956b2..6df0fe658162 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-fs/samba
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.701 2014/12/26 09:18:35 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.702 2015/01/03 17:28:06 mgorny Exp $
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org> samba-4.1.14.ebuild:
+ Make systemd library support optional, bug #512510.
26 Dec 2014; Agostino Sarubbo <ago@gentoo.org> samba-3.6.24.ebuild:
Stable for sparc, wrt bug #514676
diff --git a/net-fs/samba/samba-4.1.14.ebuild b/net-fs/samba/samba-4.1.14.ebuild
index fc27f347fe49..74d4208637d5 100644
--- a/net-fs/samba/samba-4.1.14.ebuild
+++ b/net-fs/samba/samba-4.1.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.14.ebuild,v 1.1 2014/12/02 09:34:05 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.14.ebuild,v 1.2 2015/01/03 17:28:06 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_{6,7} )
@@ -20,7 +20,7 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="acl addns ads aio avahi client cluster cups dmapi fam gnutls iprint
-ldap quota selinux syslog test winbind"
+ldap quota selinux syslog systemd test winbind"
# sys-apps/attr is an automagic dependency (see bug #489748)
# sys-libs/pam is an automagic dependency (see bug #489770)
@@ -49,7 +49,8 @@ CDEPEND="${PYTHON_DEPS}
fam? ( virtual/fam )
gnutls? ( dev-libs/libgcrypt:0
>=net-libs/gnutls-1.4.0 )
- ldap? ( net-nds/openldap )"
+ ldap? ( net-nds/openldap )
+ systemd? ( sys-apps/systemd:0= )"
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
@@ -122,6 +123,7 @@ src_configure() {
--with-pam_smbpass \
$(use_with quota quotas) \
$(use_with syslog) \
+ $(use_with systemd) \
$(use_with winbind)
"
use "ads" && myconf+=" --with-shared-modules=idmap_ad"