summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog8
-rw-r--r--net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r21
-rw-r--r--net-fs/nfs-utils/files/nfs-4170
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild91
4 files changed, 269 insertions, 1 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index 1086bdcc8ae9..323884b6fca0 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.38 2004/05/12 03:48:54 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.39 2004/06/08 19:04:04 vapier Exp $
+
+*nfs-utils-1.0.6-r2 (08 Jun 2004)
+
+ 08 Jun 2004; Mike Frysinger <vapier@gentoo.org> +files/nfs-4,
+ +nfs-utils-1.0.6-r2.ebuild:
+ Add support for NFSv4 #25106 by Michael Locher.
11 May 2004; Michael McCabe <randy@gentoo.org> nfs-utils-1.0.6-r1.ebuild:
Added s390 keywords
diff --git a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r2 b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r2
new file mode 100644
index 000000000000..319c3d94379e
--- /dev/null
+++ b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6-r2
@@ -0,0 +1 @@
+MD5 f17e9983457e1cf61c37f0be4493fce6 nfs-utils-1.0.6.tar.gz 265964
diff --git a/net-fs/nfs-utils/files/nfs-4 b/net-fs/nfs-utils/files/nfs-4
new file mode 100644
index 000000000000..d10b0b4b16c5
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-4
@@ -0,0 +1,170 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/nfs-4,v 1.1 2004/06/08 19:04:04 vapier Exp $
+
+#---------------------------------------------------------------------------
+# This script starts/stops the following
+# rpc.statd if necessary (also checked by init.d/nfsmount)
+# rpc.rquotad if exists (from quota package)
+# rpc.nfsd
+# rpc.mountd
+#---------------------------------------------------------------------------
+
+# NB: Config is in /etc/conf.d/nfs
+
+opts="start stop restart reload"
+
+# This variable is used for controlling whether or not to run exportfs -ua;
+# see stop() for more information
+restarting=yes
+
+# The binary locations
+exportfs=/usr/sbin/exportfs
+statd=/sbin/rpc.statd
+rquotad=/usr/sbin/rpc.rquotad
+nfsd=/usr/sbin/rpc.nfsd
+mountd=/usr/sbin/rpc.mountd
+
+depend() {
+ local myneed="net portmap"
+ if [ -x /sbin/idmapd ] ; then
+ if grep -q rpc_pipefs /proc/filesystems &>/dev/null; then
+ myneed="${myneed} idmapd"
+ fi
+ fi
+ need ${myneed}
+ after quota
+}
+
+start_statd() {
+ # Don't start rpc.statd if already started by init.d/nfsmount
+ killall -0 rpc.statd &>/dev/null && return 0
+ ebegin "Starting NFS statd"
+ start-stop-daemon --start --quiet --exec \
+ $statd -- $RPCSTATDOPTS 1>&2
+ eend $? "Error starting NFS statd"
+}
+
+stop_statd() {
+ # Don't stop rpc.statd if it's in use by init.d/nfsmount.
+ mount -t nfs | grep -q . && return 0
+ # Make sure it's actually running
+ killall -0 rpc.statd &>/dev/null || return 0
+ # Okay, all tests passed, stop rpc.statd
+ ebegin "Stopping NFS statd"
+ start-stop-daemon --stop --quiet --exec $statd 1>&2
+ eend $? "Error stopping NFS statd"
+}
+
+start() {
+ # This is the new "kernel 2.6 way" to handle the exports file
+ if grep -q nfsd /proc/filesystems &>/dev/null; then
+ if ! grep -q "nfsd /proc/fs/nfs" /proc/mounts &>/dev/null; then
+ ebegin "Mounting nfsd filesystem in /proc"
+ mount -t nfsd nfsd /proc/fs/nfs
+ eend $? "Error mounting nfsd filesystem in /proc"
+ fi
+ fi
+ # now that nfsd is mounted inside /proc, we can safely start mountd later
+
+ start_statd
+
+ # Exportfs likes to hang if networking isn't working.
+ # If that's the case, then try to kill it so the
+ # bootup process can continue.
+ if grep -q '^/' /etc/exports &>/dev/null; then
+ ebegin "Exporting NFS directories"
+ $exportfs -r 1>&2 &
+ pid=$!
+ ( sleep 30; kill -9 $pid &>/dev/null ) &
+ wait $pid
+ eend $? "Error exporting NFS directories"
+ fi
+
+ if [ -x $rquotad ]; then
+ ebegin "Starting NFS rquotad"
+ start-stop-daemon --start --quiet --exec \
+ $rquotad -- $RPCRQUOTADOPTS 1>&2
+ eend $? "Error starting NFS rquotad"
+ fi
+
+ ebegin "Starting NFS daemon"
+ start-stop-daemon --start --quiet --exec \
+ $nfsd -- $RPCNFSDCOUNT 1>&2
+ eend $? "Error starting NFS daemon"
+
+ # Start mountd
+ ebegin "Starting NFS mountd"
+ start-stop-daemon --start --quiet --exec \
+ $mountd -- $RPCMOUNTDOPTS 1>&2
+ eend $? "Error starting NFS mountd"
+}
+
+stop() {
+ # Don't check NFSSERVER variable since it might have changed,
+ # instead use --oknodo to smooth things over
+ ebegin "Stopping NFS mountd"
+ start-stop-daemon --stop --quiet --oknodo \
+ --exec $mountd 1>&2
+ eend $? "Error stopping NFS mountd"
+
+ # nfsd sets its process name to [nfsd] so don't look for $nfsd
+ ebegin "Stopping NFS daemon"
+ start-stop-daemon --stop --quiet --oknodo \
+ --name nfsd --user root --signal 2 1>&2
+ eend $? "Error stopping NFS daemon"
+
+ if [ -x $rquotad ]; then
+ ebegin "Stopping NFS rquotad"
+ start-stop-daemon --stop --quiet --oknodo \
+ --exec $rquotad 1>&2
+ eend $? "Error stopping NFS rquotad"
+ fi
+
+ # When restarting the NFS server, running "exportfs -ua" probably
+ # isn't what the user wants. Running it causes all entries listed
+ # in xtab to be removed from the kernel export tables, and the
+ # xtab file is cleared. This effectively shuts down all NFS
+ # activity, leaving all clients holding stale NFS filehandles,
+ # *even* when the NFS server has restarted.
+ #
+ # That's what you would want if you were shutting down the NFS
+ # server for good, or for a long period of time, but not when the
+ # NFS server will be running again in short order. In this case,
+ # then "exportfs -r" will reread the xtab, and all the current
+ # clients will be able to resume NFS activity, *without* needing
+ # to umount/(re)mount the filesystem.
+ if [ "$restarting" = no ]; then
+ ebegin "Unexporting NFS directories"
+ # Exportfs likes to hang if networking isn't working.
+ # If that's the case, then try to kill it so the
+ # shutdown process can continue.
+ $exportfs -ua 1>&2 &
+ pid=$!
+ ( sleep 30; kill -9 $pid &>/dev/null ) &
+ wait $pid
+ eend $? "Error unexporting NFS directories"
+ fi
+
+ stop_statd
+}
+
+reload() {
+ # Exportfs likes to hang if networking isn't working.
+ # If that's the case, then try to kill it so the
+ # bootup process can continue.
+ ebegin "Reloading /etc/exports"
+ $exportfs -r 1>&2 &
+ pid=$!
+ ( sleep 30; kill -9 $pid &>/dev/null ) &
+ wait $pid
+ eend $? "Error exporting NFS directories"
+}
+
+restart() {
+ # See long comment in stop() regarding "restarting" and exportfs -ua
+ restarting=yes
+ svc_stop
+ svc_start
+}
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild
new file mode 100644
index 000000000000..e66186d5be1d
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6-r2.ebuild,v 1.1 2004/06/08 19:04:04 vapier Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://nfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~arm ~hppa ~amd64 ~ppc64 ~s390"
+IUSE="tcpd"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}
+ >=net-nds/portmap-5b-r6
+ >=sys-apps/util-linux-2.11f"
+
+src_compile() {
+ use ppc64 && gnuconfig_update
+ econf \
+ --mandir=/usr/share/man \
+ --with-statedir=/var/lib/nfs \
+ --disable-rquotad \
+ --enable-nfsv3 \
+ || die "Configure failed"
+
+ if ! use tcpd; then
+ sed -i "s:\(-lwrap\|-DHAVE_TCP_WRAPPER\)::" config.mk
+ fi
+
+ # parallel make still fails
+ emake -j1 || die "Failed to compile"
+}
+
+src_install() {
+ make install install_prefix=${D} MANDIR=${D}/usr/share/man \
+ || die "Failed to install"
+
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ dodir /usr/lib/nfs
+ mv ${D}/var/lib/nfs/* ${D}/usr/lib/nfs
+ keepdir /var/lib/nfs
+ keepdir /var/lib/nfs/v4root
+
+ # Install some client-side binaries in /sbin
+ dodir /sbin
+ mv ${D}/usr/sbin/rpc.{lockd,statd} ${D}/sbin
+
+ dodoc ChangeLog README
+ docinto linux-nfs ; dodoc linux-nfs/*
+
+ insinto /etc ; doins ${FILESDIR}/exports
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nfs-4 nfs
+ newexe ${FILESDIR}/nfsmount nfsmount
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/nfs.confd nfs
+}
+
+pkg_postinst() {
+ # Install default xtab and friends if there's none existing.
+ # In src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. This fixes
+ # bug 30486
+ local f
+ for f in ${ROOT}/usr/lib/nfs/*; do
+ [[ -f ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from /usr/lib/nfs to /var/lib/nfs"
+ cp -a ${f} ${ROOT}/var/lib/nfs/
+ done
+
+ echo
+ einfo "NFS V2 and V3 servers now default to \"sync\" IO if ${P}"
+ einfo "(or later) is installed."
+ einfo "More info at ${HOMEPAGE} (see questions 5, 12, 13, and 14)."
+ echo
+ einfo "If you plan on using NFS V4 then you should emerge the idmapd"
+ einfo "package now."
+ echo
+ ewarn "PLEASE note: Since the latest NFS utils has changed the server"
+ ewarn "default to \"sync\" IO, then if no behavior is specified in the"
+ ewarn "export list, thus assuming the default behavior, a warning will"
+ ewarn "be generated at export time."
+ echo
+}