summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/d4x')
-rw-r--r--net-misc/d4x/ChangeLog55
-rw-r--r--net-misc/d4x/d4x-2.02.ebuild74
-rw-r--r--net-misc/d4x/d4x-2.03.ebuild90
-rw-r--r--net-misc/d4x/files/digest-d4x-2.021
4 files changed, 185 insertions, 35 deletions
diff --git a/net-misc/d4x/ChangeLog b/net-misc/d4x/ChangeLog
index e918f86fbe18..badd9df1500c 100644
--- a/net-misc/d4x/ChangeLog
+++ b/net-misc/d4x/ChangeLog
@@ -1,8 +1,53 @@
# ChangeLog for net-misc/d4x
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/d4x/ChangeLog,v 1.1 2002/08/31 22:59:34 blizzy Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-misc/d4x/ChangeLog,v 1.2 2002/09/01 08:14:22 azarah Exp $
-*d4x-2.03 (01 Sep 2002)
+ 1 Sep 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Move the whole shebang to net-misc/d4x, as it seems not all know
+ that it was named nt (cannot expect it really), and I think our
+ current nt-2.03 ebuild is much more complete than the newly added
+ one.
- 01 Sep 2002; Maik Schreiber <blizzy@gentoo.org> : Initial import.
- ebuild submitted by Christopher Sharp <csharp@freeshell.org>
+*nt-2.0.3 (1 Sep 2002)
+
+ 1 Sep 2002; Martin Schlemmer <azarah@gentoo.org> nt-2.03.ebuild :
+ New version.
+
+*nt-2.0.2 (23 Jul 2002)
+
+ 18 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> nt-2.02.ebuild :
+ New version that should fix GCC 3.1 compile problems. Ebuild
+ submitted by Daniel Mettler <mettlerd@icu.unizh.ch>.
+
+*nt-2.01 (7 Jun 2002)
+
+ 09 Jul 2002; phoen][x <phoenix@gentoo.org> nt-2.01.ebuild :
+ Added KEYWORDS, LICENSE.
+
+ 7 Jun 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Bump to latest version.
+
+*nt-2.0 (30 Apr 2002)
+
+ 09 Jul 2002; phoen][x <phoenix@gentoo.org> nt-2.0.ebuild :
+ Added KEYWORDS, LICENSE.
+
+ 3 Jun 2002: Preston A. Elder <prez@gentoo.org> files/nt-2.0-gcc31.patch :
+ Added patch to make compile with gcc 3.1
+
+*nt-2.0_rc2 (28 Apr 2002)
+
+ 09 Jul 2002; phoen][x <phoenix@gentoo.org> nt-2.0_rc2.ebuild :
+ Added KEYWORDS, LICENSE.
+
+*nt-1.30 (1 Feb 2002)
+
+ 09 Jul 2002; phoen][x <phoenix@gentoo.org> nt-1.30.ebuild :
+ Added KEYWORDS, LICENSE, SLOT.
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-misc/d4x/d4x-2.02.ebuild b/net-misc/d4x/d4x-2.02.ebuild
new file mode 100644
index 000000000000..cf6a26aa4e2a
--- /dev/null
+++ b/net-misc/d4x/d4x-2.02.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/d4x/d4x-2.02.ebuild,v 1.1 2002/09/01 08:14:22 azarah Exp $
+
+#name of tarball changed
+S="${WORKDIR}/${P}"
+DESCRIPTION="GTK based download manager for X."
+SRC_URI="http://www.krasu.ru/soft/chuchelo/files/${P}.tar.gz"
+HOMEPAGE="http://www.krasu.ru/soft/chuchelo/"
+
+KEYWORDS="x86 sparc sparc64"
+SLOT="0"
+LICENSE="nt"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-libs/glib-1.2.10
+ >=media-libs/gdk-pixbuf-0.2.5
+ esd? ( >=media-sound/esound-0.2.7 )"
+
+RDEPEND=${DEPEND}
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Use our own $CXXFLAGS
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:CXXFLAGS=\"-O2\":CXXFLAGS=\"${CXXFLAGS}\":g" \
+ configure.orig >configure
+}
+
+src_compile() {
+
+ myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+ use esd || myconf="${myconf} --disable-esd"
+ use oss || myconf="${myconf} --disable-oss"
+
+ ./configure --host=${HOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-release \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/bin
+ dodir /usr/share/d4x
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog* NEWS PLANS README TODO
+ cd ${S}/DOC
+ dodoc FAQ* LICENSE NAMES TROUBLES THANKS
+
+ cd ${S}
+ insinto /usr/share/pixmaps
+ doins *.png *.xpm
+
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/gnome/apps/Internet
+ newins nt.desktop d4x.desktop
+ fi
+}
+
diff --git a/net-misc/d4x/d4x-2.03.ebuild b/net-misc/d4x/d4x-2.03.ebuild
index a7c673f77733..4e3f4e8ee1d2 100644
--- a/net-misc/d4x/d4x-2.03.ebuild
+++ b/net-misc/d4x/d4x-2.03.ebuild
@@ -1,42 +1,72 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/d4x/d4x-2.03.ebuild,v 1.2 2002/09/01 08:14:22 azarah Exp $
-DESCRIPTION="Downloader for X, a download manager"
-HOMEPAGE="http://www.krasu.ru/soft/chuchelo/"
+S="${WORKDIR}/${P}"
+DESCRIPTION="GTK based download manager for X."
SRC_URI="http://www.krasu.ru/soft/chuchelo/files/${P}.tar.gz"
-LICENSE="Artistic"
+HOMEPAGE="http://www.krasu.ru/soft/chuchelo/"
+
+KEYWORDS="x86 sparc sparc64"
SLOT="0"
-KEYWORDS="x86"
+LICENSE="nt"
-RDEPEND="virtual/glibc
- >=sys-devel/gettext-0.10.39
- >=media-libs/gdk-pixbuf-0.18.0
- >=x11-libs/gtk+-2.0.5"
-DEPEND="${RDEPEND}
- >=sys-devel/automake-1.6
- >=sys-devel/autoconf-2.52"
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-libs/glib-1.2.10
+ >=media-libs/gdk-pixbuf-0.2.5
+ esd? ( >=media-sound/esound-0.2.7 )"
+RDEPEND=${DEPEND}
-S="${WORKDIR}/${P}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Use our own $CXXFLAGS
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:CXXFLAGS=\"-O2\":CXXFLAGS=\"${CXXFLAGS}\":g" \
+ configure.orig >configure
+}
src_compile() {
-# patch -p0 < ${FILESDIR}/d4x.patch
-# econf || die
-# patch -p0 < ${FILESDIR}/makefile.patch
-#
-# make || die
-# patch -p0 < ${FILESDIR}/makefile2.patch
-
- econf || die "configure problem"
- cd share
- mv Makefile Makefile.orig
- sed <Makefile.orig >Makefile \
- -e "s|datadir = /usr/share|datadir = ${D}/usr/share|"
- cd ..
- emake || die "compile problem"
+
+ myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+ use esd || myconf="${myconf} --disable-esd"
+ use oss || myconf="${myconf} --disable-oss"
+
+ ./configure --host=${HOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-release \
+ ${myconf} || die
+
+ emake || die
}
-src_install() {
- make DESTDIR=${D} install || die "install problem"
+src_install () {
- dodoc AUTHORS COPYING ChangeLog NEWS PLANS TODO
+ dodir /usr/bin
+ dodir /usr/share/d4x
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog* NEWS PLANS README TODO
+ cd ${S}/DOC
+ dodoc FAQ* LICENSE NAMES TROUBLES THANKS
+
+ cd ${S}
+ insinto /usr/share/pixmaps
+ doins *.png *.xpm
+
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/gnome/apps/Internet
+ newins nt.desktop d4x.desktop
+ fi
}
+
diff --git a/net-misc/d4x/files/digest-d4x-2.02 b/net-misc/d4x/files/digest-d4x-2.02
new file mode 100644
index 000000000000..b379f8e63cb3
--- /dev/null
+++ b/net-misc/d4x/files/digest-d4x-2.02
@@ -0,0 +1 @@
+MD5 54a134fe5edfb3558fe07ac76f08a901 d4x-2.02.tar.gz 1253235