summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/stellarium/ChangeLog10
-rw-r--r--sci-astronomy/stellarium/stellarium-0.10.1.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/sci-astronomy/stellarium/ChangeLog b/sci-astronomy/stellarium/ChangeLog
index 094594e19733..01810c957963 100644
--- a/sci-astronomy/stellarium/ChangeLog
+++ b/sci-astronomy/stellarium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/stellarium
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.46 2008/08/17 00:00:30 mr_bones_ Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.47 2009/02/06 23:07:11 mr_bones_ Exp $
+
+*stellarium-0.10.1 (06 Feb 2009)
+
+ 06 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +stellarium-0.10.1.ebuild:
+ version bump
17 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org>
stellarium-0.9.1-r1.ebuild:
diff --git a/sci-astronomy/stellarium/stellarium-0.10.1.ebuild b/sci-astronomy/stellarium/stellarium-0.10.1.ebuild
new file mode 100644
index 000000000000..095f48543b0a
--- /dev/null
+++ b/sci-astronomy/stellarium/stellarium-0.10.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.10.1.ebuild,v 1.1 2009/02/06 23:07:11 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils
+
+DESCRIPTION="Stellarium renders 3D photo-realistic skies in real time."
+HOMEPAGE="http://www.stellarium.org/"
+SRC_URI="mirror://sourceforge/stellarium/${P}.tar.gz"
+
+LICENSE="GPL-2 BitstreamVera"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libpng
+ media-libs/freetype:2
+ dev-libs/boost
+ media-libs/jpeg
+ || ( ( x11-libs/qt-core:4 x11-libs/qt-gui:4 x11-libs/qt-script:4 x11-libs/qt-opengl:4 ) >=x11-libs/qt-4.4.2:4[opengl] )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.7
+ nls? ( sys-devel/gettext )
+ x11-libs/libXt"
+
+src_configure() {
+ mycmakeargs=$(cmake-utils_use_enable nls NLS)
+ cmake-utils_src_configurein
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newicon doc/images/stellarium-logo.png ${PN}.png
+ make_desktop_entry ${PN} Stellarium ${PN} "Education;Science;Astronomy;"
+ dodoc AUTHORS ChangeLog README
+}