summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/balsa/ChangeLog7
-rw-r--r--sci-electronics/balsa/balsa-3.5.ebuild143
-rw-r--r--sci-electronics/balsa/files/digest-balsa-3.518
3 files changed, 167 insertions, 1 deletions
diff --git a/sci-electronics/balsa/ChangeLog b/sci-electronics/balsa/ChangeLog
index 08d87a799341..f2c8036ea8b9 100644
--- a/sci-electronics/balsa/ChangeLog
+++ b/sci-electronics/balsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/balsa
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/ChangeLog,v 1.8 2006/07/07 17:38:13 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/ChangeLog,v 1.9 2006/08/15 18:53:27 chrb Exp $
+
+*balsa-3.5 (15 Aug 2006)
+
+ 15 Aug 2006; Chris Bainbridge <chrb@gentoo.org> +balsa-3.5.ebuild:
+ Version bump.
07 Jul 2006; Denis Dupeyron <calchan@gentoo.org> balsa-3.4.ebuild,
balsa-3.4.3.ebuild:
diff --git a/sci-electronics/balsa/balsa-3.5.ebuild b/sci-electronics/balsa/balsa-3.5.ebuild
new file mode 100644
index 000000000000..d203ee42b0af
--- /dev/null
+++ b/sci-electronics/balsa/balsa-3.5.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/balsa/balsa-3.5.ebuild,v 1.1 2006/08/15 18:53:27 chrb Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="The Balsa asynchronous synthesis system"
+HOMEPAGE="http://www.cs.manchester.ac.uk/apt/projects/tools/balsa/"
+SRC_URI="ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/BalsaExamples${PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/BalsaManual${PV}.pdf
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/${P}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/${PN}-sim-verilog-${PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/${PN}-tech-example-${PV}.tar.gz
+ ftp://ftp.cs.man.ac.uk/pub/amulet/balsa/${PV}/${PN}-tech-xilinx-${PV}.tar.gz
+ "
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/libc
+ sys-devel/binutils
+ dev-libs/gmp
+ dev-lang/perl
+ x11-libs/gtk+
+ sci-electronics/iverilog
+ sci-electronics/gplcver"
+
+RDEPEND="${DEPEND}
+ dev-util/guile
+ media-gfx/graphviz
+ sci-electronics/gtkwave
+ sci-electronics/espresso-ab"
+
+BALSA_TECH_AMS="balsa-tech-ams-20030506.tar.gz"
+
+if [ -f ${DISTDIR}/${BALSA_TECH_AMS} ]; then
+ TECH_AMS=1
+fi
+
+src_unpack() {
+ unpack ${A}
+ if [ $TECH_AMS ]; then
+ unpack ${BALSA_TECH_AMS}
+ fi
+ sed -i -e "s:\(DEFAULT_INCLUDES = \)\(.*\):\1-I${S}/src/libs/ \2/:" ${WORKDIR}/balsa-sim-verilog-${PV}/libs/Makefile.in
+ sed -i -e 's/ $(bindir)/ $(DESTDIR)$(bindir)/' ${S}/bin/Makefile.in
+ sed -i -e 's/ $(balsatypesdir)/ $(DESTDIR)$(balsatypesdir)/' ${S}/share/balsa/types/Makefile.in
+ sed -i -e 's/ $(balsasimdir)/ $(DESTDIR)$(balsasimdir)/' ${S}/share/balsa/sim/Makefile.in
+}
+
+src_compile() {
+ # compile balsa
+ einfo "Compiling balsa"
+ ./configure --prefix=/usr/ || die "econf failed"
+ chmod +x bin/balsa-config
+ PATH=$PATH:${S}/bin
+ emake -j1 || die
+
+ # configure AMS035 tech
+ if [ $TECH_AMS ]; then
+ einfo "Compiling AMS035 tech"
+ cd ${WORKDIR}/balsa-tech-ams-20030506
+ econf || die "econf failed"
+ fi
+
+ # config Xilinx FPGA backend
+ einfo "Compiling Xilinx FPGA backend"
+ cd ${WORKDIR}/balsa-tech-xilinx-${PV}
+ econf || die "econf failed"
+
+ # config example tech
+ einfo "Compiling tech example"
+ cd ${WORKDIR}/balsa-tech-example-${PV}
+ econf || die "econf failed"
+
+ # config verilog simulator wrappers
+ einfo "Compiling verilog simulator wrappers"
+ cd ${WORKDIR}/balsa-sim-verilog-${PV}
+ ./configure --includedir=${S}/src/libs/balsasim \
+ --with-icarus-includes=/usr/include \
+ --with-icarus-libs=/usr/lib \
+ --with-cver-includes=/usr/include/cver_pli_incs || die
+}
+
+src_install() {
+ # install balsa
+ cd ${S}
+ einfo "Installing balsa"
+ make DESTDIR=${D} install || die
+
+ # install manual and examples
+ dodir /usr/share/doc/${P}/
+ cp -pPR ${WORKDIR}/BalsaExamples ${D}/usr/share/doc/${P}/
+ dodoc ${DISTDIR}/BalsaManual${PV}.pdf
+
+ if [ $TECH_AMS ]; then
+ einfo "Installing AMS035 tech"
+ cd ${WORKDIR}/balsa-tech-ams-20030506
+ make DESTDIR=${D} install || die "make install failed"
+ fi
+
+ einfo "Installing Xilinx FPGA tech"
+ cd ${WORKDIR}/balsa-tech-xilinx-${PV}
+ make DESTDIR=${D} install || die "make install failed"
+
+ einfo "Installing example tech"
+ cd ${WORKDIR}/balsa-tech-example-${PV}
+ make DESTDIR=${D} install || die "make install failed"
+
+ einfo "Installing verilog simulator wrappers"
+ cd ${WORKDIR}/balsa-sim-verilog-${PV}
+ DESTDIR=${D} make install || die "make verilog wrappers failed"
+
+ # fix paths
+ cd ${D}
+ einfo "Fixing paths"
+ find . -type f -exec sed -i -e "s:${D}::" {} \;
+ find . -name "sed*" -exec rm -f {} \;
+
+ # add some docs
+ cd ${S}
+ einfo "Installing docs"
+ dodoc AUTHORS COPYING NEWS README TODO
+ mv ${D}/usr/doc/* ${D}/usr/share/doc/${P}/
+ rmdir ${D}/usr/doc
+
+ # fix collisions
+ rm -f ${D}/usr/bin/libtool
+}
+
+pkg_postinst() {
+ if [ ! $TECH_AMS ]; then
+ elog "The AMS035 tech library was not installed."
+ elog "If you have the appropriate licenses request"
+ elog "the tech support files directly from balsa@cs.man.ac.uk"
+ elog "and add them to /usr/portage/distfiles before emerging."
+ else
+ elog "The AMS035 tech library was found and installed."
+ fi
+}
diff --git a/sci-electronics/balsa/files/digest-balsa-3.5 b/sci-electronics/balsa/files/digest-balsa-3.5
new file mode 100644
index 000000000000..e47fd756c0c0
--- /dev/null
+++ b/sci-electronics/balsa/files/digest-balsa-3.5
@@ -0,0 +1,18 @@
+MD5 eacb865bbb617dcecf9c8030deab129b BalsaExamples3.5.tar.gz 3129103
+RMD160 3de009c2e4eb01f85783aaa9ecf059b875a628d5 BalsaExamples3.5.tar.gz 3129103
+SHA256 314bc91b756a61fd2661c94419ae8a3b2c2a34d34d3f75fc38a7fb37745572aa BalsaExamples3.5.tar.gz 3129103
+MD5 507a38f29cb0bb44c78af5a1579e4f67 BalsaManual3.5.pdf 1270733
+RMD160 48382fefcb2b38d92635dfd0377eed438934bf2b BalsaManual3.5.pdf 1270733
+SHA256 847bc11d046d462a7c5b568792aa4d29db7291906acc9c206a40e7565c7de026 BalsaManual3.5.pdf 1270733
+MD5 954070134200eea172ccc5b5800a316a balsa-3.5.tar.gz 2548896
+RMD160 92521a798504f96573309af1cc156a87b43900e4 balsa-3.5.tar.gz 2548896
+SHA256 14dbe33521b007db5833cf6110363f9016cbdc085dcd54afe8657ddbe5a8920c balsa-3.5.tar.gz 2548896
+MD5 e27381066648bb3c7a22fd2f0d3765b2 balsa-sim-verilog-3.5.tar.gz 317550
+RMD160 1c68e85b112e0d2457b855f4ca9a38c3b64b9f00 balsa-sim-verilog-3.5.tar.gz 317550
+SHA256 b3cebcf482ac749e0d982b532b5fe1c5f0ec4316cab7e3eff7a8d3928768c529 balsa-sim-verilog-3.5.tar.gz 317550
+MD5 a906bd475c3d1b98becad2ded8715013 balsa-tech-example-3.5.tar.gz 133932
+RMD160 ba4db1c73acedca937b1f13cd75203e38d447952 balsa-tech-example-3.5.tar.gz 133932
+SHA256 b8d8020ffb91e9224e386adec825a9a3681a24932548257c0ad305f29f626d6c balsa-tech-example-3.5.tar.gz 133932
+MD5 ef1f7be2faf826f1877dfdf0c72ff0c3 balsa-tech-xilinx-3.5.tar.gz 169267
+RMD160 5e7ce5e7fe276686d2b46f301dadfe894eca1448 balsa-tech-xilinx-3.5.tar.gz 169267
+SHA256 75009f7d8c6a3bfd4b9e393d34a6e571f7f80d5d4d2bef6e2f8ea0a3a5bd17bc balsa-tech-xilinx-3.5.tar.gz 169267