summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/netcdf/ChangeLog8
-rw-r--r--sci-libs/netcdf/files/netcdf-3.6.3-as-needed.patch43
-rw-r--r--sci-libs/netcdf/netcdf-3.6.3.ebuild84
3 files changed, 134 insertions, 1 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 860bbe188b32..02e9ae833a20 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/netcdf
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.51 2009/01/15 13:15:06 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.52 2009/01/15 15:04:18 bicatali Exp $
+
+*netcdf-3.6.3 (15 Jan 2009)
+
+ 15 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/netcdf-3.6.3-as-needed.patch, +netcdf-3.6.3.ebuild:
+ Version bump
15 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
files/netcdf-3.6.2-gcc43.patch, -netcdf-3.6.1.ebuild,
diff --git a/sci-libs/netcdf/files/netcdf-3.6.3-as-needed.patch b/sci-libs/netcdf/files/netcdf-3.6.3-as-needed.patch
new file mode 100644
index 000000000000..944600824706
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-3.6.3-as-needed.patch
@@ -0,0 +1,43 @@
+diff -Nur netcdf-3.6.3.orig/cxx/Makefile.am netcdf-3.6.3/cxx/Makefile.am
+--- netcdf-3.6.3.orig/cxx/Makefile.am 2008-04-04 18:05:25.000000000 +0100
++++ netcdf-3.6.3/cxx/Makefile.am 2009-01-15 14:46:15.895277408 +0000
+@@ -105,6 +105,6 @@
+
+ # Library source.
+ libnetcdf_c___la_SOURCES = netcdf.cpp ncvalues.cpp
+-
++libnetcdf_c___la_LIBADD = $(top_builddir)/libsrc/libnetcdf.la
+ test: check
+
+diff -Nur netcdf-3.6.3.orig/fortran/Makefile.am netcdf-3.6.3/fortran/Makefile.am
+--- netcdf-3.6.3.orig/fortran/Makefile.am 2008-04-22 22:52:04.000000000 +0100
++++ netcdf-3.6.3/fortran/Makefile.am 2009-01-15 14:47:03.426443772 +0000
+@@ -60,6 +60,7 @@
+ # (it's generated by the configure script from nfconfig.in), or if
+ # netcdf.inc has changed.
+ libnetcdff_la_DEPENDENCIES = nfconfig.inc netcdf.inc
++libnetcdff_la_LIBADD = $(top_builddir)/libsrc/libnetcdf.la
+
+ # Is the user building netCDF-4?
+ if USE_NETCDF4
+@@ -92,7 +93,7 @@
+
+ # If F90 is built, include it's convenience library.
+ if BUILD_F90
+-libnetcdff_la_LIBADD = ../f90/libnetcdff90.la
++libnetcdff_la_LIBADD += ../f90/libnetcdff90.la
+ endif
+
+ # If we are building the dll (under MinGW) then set the correct flags.
+diff -Nur netcdf-3.6.3.orig/Makefile.am netcdf-3.6.3/Makefile.am
+--- netcdf-3.6.3.orig/Makefile.am 2008-06-27 14:15:13.000000000 +0100
++++ netcdf-3.6.3/Makefile.am 2009-01-15 14:48:04.594871206 +0000
+@@ -88,7 +88,7 @@
+ # $(DAPDIR) $(NCDAPDIR) $(LIBSRC4_DIR) \
+ # $(V2_TEST) $(NCGEN) $(NCDUMP) $(F77_TEST) ${CXX_DIR} $(CXX4) \
+ # $(NC_TEST_DIR) $(NC_TEST4) $(MAN) $(EXAMPLES) win32
+-SUBDIRS = $(F90_DIR) $(F77_DIR) $(LIBSRC_DIR) $(LIBSRC4_DIR) \
++SUBDIRS = $(LIBSRC_DIR) $(F90_DIR) $(F77_DIR) $(LIBSRC4_DIR) \
+ $(V2_TEST) $(NCGEN) $(NCDUMP) $(F77_TEST) ${CXX_DIR} $(CXX4) \
+ $(NC_TEST_DIR) $(NC_TEST4) $(MAN) $(EXAMPLES) win32
+
diff --git a/sci-libs/netcdf/netcdf-3.6.3.ebuild b/sci-libs/netcdf/netcdf-3.6.3.ebuild
new file mode 100644
index 000000000000..9f93d6d4fbda
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-3.6.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.3.ebuild,v 1.1 2009/01/15 15:04:18 bicatali Exp $
+
+EAPI=2
+inherit fortran eutils toolchain-funcs flag-o-matic autotools
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+IUSE="fortran debug doc"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+pkg_setup() {
+ if use fortran ; then
+ FORTRAN="gfortran ifc g77 pgf77 pgf90"
+ fortran_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.6.2-parallel-make.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug || append-cppflags -DNDEBUG
+ local myconf
+ if use fortran; then
+ case "${FORTRANC}" in
+ g77)
+ myconf="${myconf} --enable-f77 --disable-f90"
+ myconf="${myconf} F77=g77"
+ ;;
+ pgf77)
+ myconf="${myconf} --enable-f77 --disable-f90"
+ myconf="${myconf} F77=pgf77"
+ ;;
+ pgf90)
+ myconf="${myconf} --enable-f77 --enable-f90"
+ myconf="${myconf} FC=pgf90 F90=pgf90 F77=pgf90"
+ ;;
+ ifc|ifort)
+ myconf="${myconf} --enable-f77 --enable-f90"
+ myconf="${myconf} FC=ifort F90=ifort F77=ifort"
+ ;;
+ *)
+ myconf="${myconf} --enable-f77 --enable-f90"
+ myconf="${myconf} FC=gfortran F90=gfortran F77=gfortran"
+ export F90FLAGS="-i4 ${F90FLAGS}"
+ ;;
+ esac
+ # fortran 90 uses FCFLAGS
+ export FCFLAGS="${FFLAGS:--O2}"
+ else
+ myconf="${myconf} --disable-f77 --disable-f90"
+ fi
+ econf \
+ --enable-shared \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug flag-setting ) \
+ $(use_enable doc docs-install) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README RELEASE_NOTES VERSION || die "dodoc failed"
+ # keep only pdf,txt and html docs, info were already installed
+ if use doc; then
+ find "${D}usr/share/doc/${PF}" -name \*.ps -exec rm -f {} \;
+ find "${D}usr/share/doc/${PF}" -name \*.info -exec rm -f {} \;
+ find "${D}usr/share/doc/${PF}" -name \*.txt -exec ecompress {} \;
+ fi
+}