summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog5
-rw-r--r--sci-mathematics/octave/octave-3.2.0.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 61fc1ff0cd9c..00f6bfb5c3e5 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.77 2009/10/12 20:06:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.78 2009/11/04 11:05:01 markusle Exp $
+
+ 04 Nov 2009; Markus Dittrich <markusle@gentoo.org> octave-3.2.0.ebuild:
+ Added arpack to list of sparse matrix dependencies (#277171).
12 Oct 2009; Jeroen Roovers <jer@gentoo.org> octave-3.0.3.ebuild:
Stable for HPPA (bug #245707).
diff --git a/sci-mathematics/octave/octave-3.2.0.ebuild b/sci-mathematics/octave/octave-3.2.0.ebuild
index f73478e57a4e..2fdbfa2bc251 100644
--- a/sci-mathematics/octave/octave-3.2.0.ebuild
+++ b/sci-mathematics/octave/octave-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.0.ebuild,v 1.6 2009/09/09 02:59:39 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.0.ebuild,v 1.7 2009/11/04 11:05:01 markusle Exp $
EAPI="2"
inherit flag-o-matic fortran xemacs-elisp-common
@@ -26,6 +26,7 @@ RDEPEND="virtual/lapack
curl? ( net-misc/curl )
xemacs? ( app-editors/xemacs )
sparse? ( sci-libs/umfpack
+ sci-libs/arpack
sci-libs/colamd
sci-libs/camd
sci-libs/ccolamd
@@ -53,13 +54,13 @@ src_configure() {
econf \
--localstatedir=/var/state/octave \
--enable-shared \
- --without-arpack \
--with-blas="$(pkg-config --libs blas)" \
--with-lapack="$(pkg-config --libs lapack)" \
$(use_with hdf5) \
$(use_with curl) \
$(use_with zlib) \
$(use_with fftw) \
+ $(use_with sparse arpack) \
$(use_with sparse umfpack) \
$(use_with sparse colamd) \
$(use_with sparse ccolamd) \