summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/kodkodi/ChangeLog7
-rw-r--r--sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild19
2 files changed, 13 insertions, 13 deletions
diff --git a/sci-mathematics/kodkodi/ChangeLog b/sci-mathematics/kodkodi/ChangeLog
index b94e88f1eb44..c2909bc49f90 100644
--- a/sci-mathematics/kodkodi/ChangeLog
+++ b/sci-mathematics/kodkodi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/kodkodi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kodkodi/ChangeLog,v 1.2 2013/05/24 05:48:44 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kodkodi/ChangeLog,v 1.3 2013/08/17 02:59:08 gienah Exp $
+
+ 17 Aug 2013; Mark Wright <gienah@gentoo.org> kodkodi-1.5.2.ebuild:
+ Fix: Class files not found via DEPEND in package.env - by adding antlr-3 to
+ JAVA_GENTOO_CLASSPATH. Try to fix bug #458462 - it merges ok with
+ JAVA_PKG_STRICT="true" in my tests.
24 May 2013; Mark Wright <gienah@gentoo.org> metadata.xml:
fix bug 466776 - typo in email address
diff --git a/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild b/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild
index 1296bc738a9c..f3ff084bb930 100644
--- a/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild
+++ b/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild,v 1.1 2012/12/05 10:44:14 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kodkodi/kodkodi-1.5.2.ebuild,v 1.2 2013/08/17 02:59:08 gienah Exp $
EAPI="5"
@@ -17,13 +17,12 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="isabelle examples"
-COMMON_DEP=""
+COMMON_DEP="dev-java/antlr:3
+ =sci-mathematics/kodkod-1.5*:="
RDEPEND="${COMMON_DEP}
- =dev-java/antlr-3*:3
isabelle? (
>=sci-mathematics/isabelle-2011-r1:=
)
- =sci-mathematics/kodkod-1.5*:=
>=virtual/jre-1.6"
DEPEND="${COMMON_DEP}
>=virtual/jdk-1.6
@@ -31,20 +30,16 @@ DEPEND="${COMMON_DEP}
S="${WORKDIR}/${P}"
-java_prepare() {
- find \( -name 'kodkod*.jar' -o -name 'sat4j*.jar' \) -exec rm -v {} + || die
-}
+JAVA_GENTOO_CLASSPATH="kodkod,antlr-3"
-src_prepare() {
+java_prepare() {
sed -e 's@exec "$ISABELLE_TOOL" java $KODKODI_JAVA_OPT@java@' \
-i "${S}/bin/kodkodi" || die "Could not patch bin/kodkodi"
+ rm -f jar/*.jar || die "Could not rm jar files"
}
src_compile() {
JAVA_SRC_DIR="src"
- JAVA_GENTOO_CLASSPATH="kodkod"
- JAVA_CLASSPATH_EXTRA="$(java-config --classpath=antlr:3)"
-
TARGETDIR="/usr/share/${P}"
KODKOD_LIBDIR="/usr/"$(get_libdir)"/kodkod"