summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-5.97.ebuild8
-rw-r--r--sys-apps/coreutils/coreutils-6.1.ebuild4
3 files changed, 12 insertions, 7 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index a9e107abbf3d..c3c728ca1745 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.176 2006/09/04 18:45:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.177 2006/09/04 20:26:33 flameeyes Exp $
+
+ 04 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> coreutils-5.97.ebuild,
+ coreutils-6.1.ebuild:
+ Backport the kernel_linux fix to 5.97 and drop keyword from 6.1 as it
+ doesn't build right now.
04 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> coreutils-6.1.ebuild:
Remove kernel_linux conditional for acl and attr, acl can be use.masked for
diff --git a/sys-apps/coreutils/coreutils-5.97.ebuild b/sys-apps/coreutils/coreutils-5.97.ebuild
index ddd1209f9651..0b891c99d9ad 100644
--- a/sys-apps/coreutils/coreutils-5.97.ebuild
+++ b/sys-apps/coreutils/coreutils-5.97.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.97.ebuild,v 1.2 2006/07/06 19:19:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.97.ebuild,v 1.3 2006/09/04 20:26:33 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs autotools
@@ -19,7 +19,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~spar
IUSE="acl nls selinux static"
RDEPEND="selinux? ( sys-libs/libselinux )
- acl? ( kernel_linux? ( sys-apps/acl sys-apps/attr ) )
+ acl? ( sys-apps/acl sys-apps/attr )
nls? ( sys-devel/gettext )
>=sys-libs/ncurses-5.3-r5"
DEPEND="${RDEPEND}
@@ -125,8 +125,8 @@ src_install() {
# remove files provided by other packages
rm "${D}"/bin/{kill,uptime} # procps
- rm "${D}"/bin/{groups,su} # shadow
- rm "${D}"/bin/hostname # net-tools
+ rm "${D}"/bin/{groups,su} # shadow
+ rm "${D}"/bin/hostname # net-tools
rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
# provide by the man-pages package
rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
diff --git a/sys-apps/coreutils/coreutils-6.1.ebuild b/sys-apps/coreutils/coreutils-6.1.ebuild
index ed4593734a04..ee041136e09e 100644
--- a/sys-apps/coreutils/coreutils-6.1.ebuild
+++ b/sys-apps/coreutils/coreutils-6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.1.ebuild,v 1.4 2006/09/04 18:45:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.1.ebuild,v 1.5 2006/09/04 20:26:33 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs autotools
@@ -15,7 +15,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="acl nls selinux static"
RDEPEND="selinux? ( sys-libs/libselinux )