summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/ChangeLog7
-rw-r--r--sys-apps/dmidecode/dmidecode-2.11.ebuild17
2 files changed, 18 insertions, 6 deletions
diff --git a/sys-apps/dmidecode/ChangeLog b/sys-apps/dmidecode/ChangeLog
index 297e78c17403..4bc3a6da6cb7 100644
--- a/sys-apps/dmidecode/ChangeLog
+++ b/sys-apps/dmidecode/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/dmidecode
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.31 2011/03/22 21:51:22 polynomial-c Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.32 2012/01/01 10:10:32 grobian Exp $
+
+ 01 Jan 2012; Fabian Groffen <grobian@gentoo.org> dmidecode-2.11.ebuild:
+ Fix for Prefix, keyword ~x86-solaris and add usage instructions
22 Mar 2011; Lars Wendler <polynomial-c@gentoo.org> dmidecode-2.11.ebuild:
non-maintainer commit: Fixed download URL. Thanks to Fabio Coatti who
diff --git a/sys-apps/dmidecode/dmidecode-2.11.ebuild b/sys-apps/dmidecode/dmidecode-2.11.ebuild
index 4588be1998c1..0b5ea2f42fd9 100644
--- a/sys-apps/dmidecode/dmidecode-2.11.ebuild
+++ b/sys-apps/dmidecode/dmidecode-2.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.11.ebuild,v 1.3 2011/03/23 17:28:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.11.ebuild,v 1.4 2012/01/01 10:10:32 grobian Exp $
-EAPI="2"
+EAPI="3"
inherit flag-o-matic toolchain-funcs
@@ -12,12 +12,12 @@ SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+KEYWORDS="-* ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~x86-solaris"
IUSE=""
src_prepare() {
sed -i \
- -e '/^prefix/s:/usr/local:/usr:' \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
-e "/^docdir/s:dmidecode:${PF}:" \
-e '/^PROGRAMS !=/d' \
Makefile || die
@@ -35,3 +35,12 @@ src_install() {
emake install DESTDIR="${D}" || die
prepalldocs
}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}