summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fbset')
-rw-r--r--sys-apps/fbset/ChangeLog6
-rw-r--r--sys-apps/fbset/fbset-2.1.ebuild11
-rw-r--r--sys-apps/fbset/files/fbset-2.1-build.patch21
3 files changed, 30 insertions, 8 deletions
diff --git a/sys-apps/fbset/ChangeLog b/sys-apps/fbset/ChangeLog
index b019c87bdad7..ce096c346c02 100644
--- a/sys-apps/fbset/ChangeLog
+++ b/sys-apps/fbset/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/fbset
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fbset/ChangeLog,v 1.16 2012/01/31 16:12:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fbset/ChangeLog,v 1.17 2012/07/10 08:50:50 flameeyes Exp $
+
+ 10 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/fbset-2.1-build.patch, fbset-2.1.ebuild:
+ Fix parallel build properly, solves bug #421203.
31 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> fbset-2.1.ebuild:
Missing sys-devel/flex DEPEND wrt #376949, Comment #2 by Matt Sealey
diff --git a/sys-apps/fbset/fbset-2.1.ebuild b/sys-apps/fbset/fbset-2.1.ebuild
index efe3e610c96b..a3d5ff2a34c2 100644
--- a/sys-apps/fbset/fbset-2.1.ebuild
+++ b/sys-apps/fbset/fbset-2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fbset/fbset-2.1.ebuild,v 1.34 2012/01/31 16:12:39 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fbset/fbset-2.1.ebuild,v 1.35 2012/07/10 08:50:50 flameeyes Exp $
-inherit toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic eutils
DESCRIPTION="A utility to set the framebuffer videomode"
HOMEPAGE="http://users.telenet.be/geertu/Linux/fbdev/"
@@ -20,15 +20,12 @@ RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i \
- -e "/^CC =/s:gcc:$(tc-getCC):" \
- -e "/^CC =/s:-O2:${CFLAGS}:" \
- -e 's/^modes.tab.c/modes.tab.h modes.tab.c/' \
- Makefile || die "sed Makefile failed"
+ epatch "${FILESDIR}/${P}-build.patch"
}
src_compile() {
use static && append-ldflags -static
+ tc-export CC
emake || die "emake failed"
}
diff --git a/sys-apps/fbset/files/fbset-2.1-build.patch b/sys-apps/fbset/files/fbset-2.1-build.patch
new file mode 100644
index 000000000000..94a323bb39ac
--- /dev/null
+++ b/sys-apps/fbset/files/fbset-2.1-build.patch
@@ -0,0 +1,21 @@
+Index: fbset-2.1/Makefile
+===================================================================
+--- fbset-2.1.orig/Makefile
++++ fbset-2.1/Makefile
+@@ -2,7 +2,6 @@
+ # Linux Frame Buffer Device Configuration
+ #
+
+-CC = gcc -Wall -O2 -I.
+ BISON = bison -d
+ FLEX = flex
+ INSTALL = install
+@@ -20,6 +19,8 @@ lex.yy.o: lex.yy.c fbset.h modes.tab.h
+ lex.yy.c: modes.l
+ $(FLEX) modes.l
+
++modes.tab.h: modes.tab.c
++
+ modes.tab.c: modes.y
+ $(BISON) modes.y
+