summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog6
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.8.ebuild11
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 7809733bc5ac..948c56116ee0 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.51 2010/03/14 18:09:44 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.52 2010/06/14 21:44:05 arfrever Exp $
+
+ 14 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ mpich2-1.0.8.ebuild:
+ Delete call to deprecated python_version() (bug #316937).
14 Mar 2010; Justin Bronder <jsbronder@gentoo.org> mpich2-1.2.1_p1.ebuild:
Add hydra pm, #309353
diff --git a/sys-cluster/mpich2/mpich2-1.0.8.ebuild b/sys-cluster/mpich2/mpich2-1.0.8.ebuild
index 894016159931..e28116a1d0a4 100644
--- a/sys-cluster/mpich2/mpich2-1.0.8.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.8.ebuild,v 1.13 2009/12/31 17:12:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.8.ebuild,v 1.14 2010/06/14 21:44:05 arfrever Exp $
EAPI=1
inherit python eutils fortran autotools
@@ -49,7 +49,6 @@ pkg_setup() {
fi
MPD_CONF_FILE_DIR=/etc/${PN}
- python_version
}
src_unpack() {
@@ -201,7 +200,7 @@ src_install() {
sed -i "s,@MPD_CONF_FILE_DIR@,${MPD_CONF_FILE_DIR}," \
"${T}"/${PN}.envd
- ln -s ../$(get_libdir)/python${PYVER}/site-packages/mpich2/mpdgdbdrv.py \
+ ln -s ../$(get_libdir)/python$(python_get_version)/site-packages/mpich2/mpdgdbdrv.py \
"${D}"/usr/bin/mpdgdbdrv.py
newenvd "${FILESDIR}"/${PN}.envd 25mpich2
}
@@ -211,7 +210,7 @@ pkg_postinst() {
chown root:root "${ROOT}"${MPD_CONF_FILE_DIR}/mpd.conf
chmod 600 "${ROOT}"${MPD_CONF_FILE_DIR}/mpd.conf
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+ python_mod_optimize $(python_get_sitedir)/${PN}
elog ""
elog "MPE2 has been removed from this ebuild and now stands alone"
elog "as sys-cluster/mpe2."
@@ -219,5 +218,5 @@ pkg_postinst() {
}
pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+ python_mod_cleanup $(python_get_sitedir)/${PN}
}