summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libtool/ChangeLog9
-rw-r--r--sys-devel/libtool/files/2.2.6a/libtool-2.2.6a-tests-locale.patch12
-rw-r--r--sys-devel/libtool/libtool-2.2.6a.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 46ce8ebe96fb..8ce66d1ac866 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/libtool
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.144 2009/09/13 14:46:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.145 2009/09/13 15:41:49 flameeyes Exp $
+
+ 13 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ libtool-2.2.6a.ebuild, +files/2.2.6a/libtool-2.2.6a-tests-locale.patch:
+ Add backport from upstream to skip over localisation test (#37) when
+ German locale is unavailable; this also fixes the other test failure (#73)
+ since that was just a recursion over the rest of the tests. Solves the
+ blocking issues from bug #257399.
13 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org> libtool-9999.ebuild:
Fix dependencies from current GIT.
diff --git a/sys-devel/libtool/files/2.2.6a/libtool-2.2.6a-tests-locale.patch b/sys-devel/libtool/files/2.2.6a/libtool-2.2.6a-tests-locale.patch
new file mode 100644
index 000000000000..15730d911076
--- /dev/null
+++ b/sys-devel/libtool/files/2.2.6a/libtool-2.2.6a-tests-locale.patch
@@ -0,0 +1,12 @@
+Index: libtool-2.2.6/tests/localization.at
+===================================================================
+--- libtool-2.2.6.orig/tests/localization.at
++++ libtool-2.2.6/tests/localization.at
+@@ -47,6 +47,7 @@ mv -f stdout expected-stdout
+ mv -f stderr expected-stderr
+ AT_CHECK([$LIBTOOL --mode=compile --tag=CC $CC $CPPFLAGS $CFLAGS -c a.c || exit 1],
+ [1], [stdout], [stderr])
++AT_CHECK([grep LC_ALL stdout stderr && exit 77], [1])
+ AT_CHECK([diff expected-stderr stderr])
+ LTBASE=`$ECHO "$LIBTOOL" | sed 's,^.*/,,'`
+ AT_CHECK([grep -v "^$LTBASE: compile" stdout | diff expected-stdout -])
diff --git a/sys-devel/libtool/libtool-2.2.6a.ebuild b/sys-devel/libtool/libtool-2.2.6a.ebuild
index 9e7449c7ecf8..d67cad7a92e2 100644
--- a/sys-devel/libtool/libtool-2.2.6a.ebuild
+++ b/sys-devel/libtool/libtool-2.2.6a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.6a.ebuild,v 1.6 2009/09/13 14:38:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.6a.ebuild,v 1.7 2009/09/13 15:41:49 flameeyes Exp $
LIBTOOLIZE="true" #225559
inherit eutils autotools
@@ -27,6 +27,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PV}/${P}-gnuinfo.patch #249168
+ epatch "${FILESDIR}"/${PV}/${P}-tests-locale.patch #249168
if ! use vanilla ; then
epunt_cxx