summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog8
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.2506.ebuild (renamed from sys-fs/ntfs3g/ntfs3g-1.1120.ebuild)26
2 files changed, 16 insertions, 18 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 706d29c07be3..510e3ce859d8 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.64 2008/04/17 18:17:53 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.65 2008/05/07 02:02:14 chutzpah Exp $
+
+*ntfs3g-1.2506 (07 May 2008)
+
+ 07 May 2008; Patrick McLean <chutzpah@gentoo.org> +ntfs3g-1.2506.ebuild:
+ Version bump. Bug #220561. Dropped NEWS file from installation as it's
+ just a pointer to the web site. Drop version 1.1120.
17 Apr 2008; nixnut <nixnut@gentoo.org> ntfs3g-1.2310.ebuild:
Stable on ppc wrt bug 217890
diff --git a/sys-fs/ntfs3g/ntfs3g-1.1120.ebuild b/sys-fs/ntfs3g/ntfs3g-1.2506.ebuild
index 267da9697eb0..b200646a20f6 100644
--- a/sys-fs/ntfs3g/ntfs3g-1.1120.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-1.2506.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.1120.ebuild,v 1.5 2008/03/22 16:52:20 maekke Exp $
-
-inherit multilib toolchain-funcs
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.2506.ebuild,v 1.1 2008/05/07 02:02:14 chutzpah Exp $
MY_PN="${PN/3g/-3g}"
MY_P="${MY_PN}-${PV}"
@@ -13,35 +11,29 @@ SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug suid"
-RDEPEND=">=sys-fs/fuse-2.6.3"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+RDEPEND=""
+DEPEND=""
S="${WORKDIR}/${MY_P}"
src_compile() {
econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-ldscript \
--disable-ldconfig \
- --libdir=/$(get_libdir) \
$(use_enable debug)
-
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
+ prepalldocs
+ dodoc AUTHORS ChangeLog CREDITS
- dodir /usr/$(get_libdir)/
- mv "${D}"/$(get_libdir)/*.{,l}a "${D}"/usr/$(get_libdir)/
-
- dodoc AUTHORS ChangeLog CREDITS NEWS README
-
- gen_usr_ldscript libntfs-3g.so
-
- use suid && fperms u+s /bin/${MY_PN}
+ use suid && fperms u+s "/bin/${MY_PN}"
}
pkg_postinst() {