summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog7
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.8.0-r1.ebuild47
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.8.2-r1.ebuild43
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.8.2.ebuild47
4 files changed, 6 insertions, 138 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index f43e074f78fb..cd5f6bad4c51 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.793 2013/03/17 11:37:13 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.794 2013/03/18 11:11:35 blueness Exp $
+
+ 18 Mar 2013; Anthony G. Basile <blueness@gentoo.org>
+ -hardened-sources-3.8.0-r1.ebuild, -hardened-sources-3.8.2-r1.ebuild,
+ -hardened-sources-3.8.2.ebuild:
+ Remove <3.8.3 for bug #462172
*hardened-sources-3.8.3 (17 Mar 2013)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.8.0-r1.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.8.0-r1.ebuild
deleted file mode 100644
index 53158ae5e6e2..000000000000
--- a/sys-kernel/hardened-sources/hardened-sources-3.8.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.8.0-r1.ebuild,v 1.3 2013/03/10 02:57:48 blueness Exp $
-
-EAPI="5"
-
-ETYPE="sources"
-K_WANT_GENPATCHES="base"
-K_GENPATCHES_VER="1"
-K_DEBLOB_AVAILABLE="1"
-
-inherit kernel-2
-detect_version
-
-HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
-HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
-SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
-
-UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
-UNIPATCH_EXCLUDE="2900_dev-root-proc-mount-fix.patch 4200_fbcondecor-0.9.6.patch"
-
-DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
-HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
-IUSE="deblob"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND=">=sys-devel/gcc-4.5"
-
-pkg_postinst() {
- kernel-2_pkg_postinst
-
- local GRADM_COMPAT="sys-apps/gradm-2.9.1*"
-
- ewarn
- ewarn "Because some options require >=gcc-4.5, users with more than"
- ewarn "one version of gcc installed should use gcc-config to select"
- ewarn "a compatible version."
- ewarn
- ewarn "Users of grsecurity's RBAC system must ensure they are using"
- ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
- ewarn "It is strongly recommended that the following command is issued"
- ewarn "prior to booting a ${PF} kernel for the first time:"
- ewarn
- ewarn "emerge -na =${GRADM_COMPAT}"
- ewarn
-}
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.8.2-r1.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.8.2-r1.ebuild
deleted file mode 100644
index e2b254958d84..000000000000
--- a/sys-kernel/hardened-sources/hardened-sources-3.8.2-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.8.2-r1.ebuild,v 1.1 2013/03/10 03:09:53 blueness Exp $
-
-EAPI="4"
-
-ETYPE="sources"
-K_WANT_GENPATCHES="base"
-K_GENPATCHES_VER="3"
-K_DEBLOB_AVAILABLE="1"
-
-inherit kernel-2
-detect_version
-
-HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
-HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
-SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
-
-UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
-UNIPATCH_EXCLUDE="2900_dev-root-proc-mount-fix.patch 4200_fbcondecor-0.9.6.patch"
-
-DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
-HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
-IUSE="deblob"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND=">=sys-devel/gcc-4.5"
-
-pkg_postinst() {
- kernel-2_pkg_postinst
-
- local GRADM_COMPAT="sys-apps/gradm-2.9.1*"
-
- ewarn
- ewarn "Users of grsecurity's RBAC system must ensure they are using"
- ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
- ewarn "It is strongly recommended that the following command is issued"
- ewarn "prior to booting a ${PF} kernel for the first time:"
- ewarn
- ewarn "emerge -na =${GRADM_COMPAT}"
- ewarn
-}
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.8.2.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.8.2.ebuild
deleted file mode 100644
index ff5ec5083e65..000000000000
--- a/sys-kernel/hardened-sources/hardened-sources-3.8.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.8.2.ebuild,v 1.3 2013/03/10 02:57:48 blueness Exp $
-
-EAPI="5"
-
-ETYPE="sources"
-K_WANT_GENPATCHES="base"
-K_GENPATCHES_VER="3"
-K_DEBLOB_AVAILABLE="1"
-
-inherit kernel-2
-detect_version
-
-HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
-HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
-SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
-
-UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
-UNIPATCH_EXCLUDE="2900_dev-root-proc-mount-fix.patch 4200_fbcondecor-0.9.6.patch"
-
-DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
-HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
-IUSE="deblob"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND=">=sys-devel/gcc-4.5"
-
-pkg_postinst() {
- kernel-2_pkg_postinst
-
- local GRADM_COMPAT="sys-apps/gradm-2.9.1*"
-
- ewarn
- ewarn "Because some options require >=gcc-4.5, users with more than"
- ewarn "one version of gcc installed should use gcc-config to select"
- ewarn "a compatible version."
- ewarn
- ewarn "Users of grsecurity's RBAC system must ensure they are using"
- ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
- ewarn "It is strongly recommended that the following command is issued"
- ewarn "prior to booting a ${PF} kernel for the first time:"
- ewarn
- ewarn "emerge -na =${GRADM_COMPAT}"
- ewarn
-}