summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
index 51374716a4a5..64413309355f 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.8 2005/01/17 23:19:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.9 2005/01/20 15:50:50 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -606,6 +606,15 @@ src_compile() {
make PARALLELMFLAGS="${MAKEOPTS}" || die
}
+src_test() {
+ # This is wrong, but glibc's tests fail bad when screwing
+ # around with sandbox, so lets just punt it
+ unset LD_PRELOAD
+
+ cd ${WORKDIR}/build
+ make check || die "make check failed :("
+}
+
src_install() {
setup_flags