summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/viewvc/ChangeLog8
-rw-r--r--www-apps/viewvc/viewvc-1.1.6.ebuild111
2 files changed, 118 insertions, 1 deletions
diff --git a/www-apps/viewvc/ChangeLog b/www-apps/viewvc/ChangeLog
index a947234938ec..3f52508db19e 100644
--- a/www-apps/viewvc/ChangeLog
+++ b/www-apps/viewvc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/viewvc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.53 2010/04/15 20:47:32 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.54 2010/06/03 20:46:34 arfrever Exp $
+
+*viewvc-1.1.6 (03 Jun 2010)
+
+ 03 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -viewvc-1.1.3.ebuild, -viewvc-1.1.4.ebuild, +viewvc-1.1.6.ebuild:
+ Version bump.
15 Apr 2010; Markus Meier <maekke@gentoo.org> viewvc-1.1.5.ebuild:
amd64 stable, bug #312165
diff --git a/www-apps/viewvc/viewvc-1.1.6.ebuild b/www-apps/viewvc/viewvc-1.1.6.ebuild
new file mode 100644
index 000000000000..8c687d110970
--- /dev/null
+++ b/www-apps/viewvc/viewvc-1.1.6.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.1.6.ebuild,v 1.1 2010/06/03 20:46:34 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit confutils eutils python webapp
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
+HOMEPAGE="http://viewvc.org/"
+DOWNLOAD_NUMBER="47623"
+SRC_URI="http://viewvc.tigris.org/files/documents/3330/${DOWNLOAD_NUMBER}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cvs cvsgraph mod_python mysql pygments +subversion"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="
+ cvs? (
+ dev-vcs/rcs
+ )
+
+ subversion? (
+ >=dev-util/subversion-1.3.1[python]
+ )
+
+ mod_python? ( www-apache/mod_python )
+ !mod_python? ( virtual/httpd-cgi )
+
+ cvsgraph? ( >=dev-util/cvsgraph-1.5.0 )
+ mysql? ( >=dev-python/mysql-python-0.9.0 )
+ pygments? ( dev-python/pygments )
+"
+RESTRICT_PYTHON_ABIS="3.*"
+
+pkg_setup() {
+ python_pkg_setup
+ webapp_pkg_setup
+
+ confutils_require_any cvs subversion
+}
+
+src_prepare() {
+ find bin/ -type f -print0 | xargs -0 sed -i \
+ -e "s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"$(python_get_sitedir -f)/${PN}\"|g" \
+ -e "s|\(^CONF_PATHNAME\)\(.*\$\)|\1 = \"../conf/viewvc.conf\"|g"
+
+ sed -i -e "s|\(self\.options\.template_dir\)\(.*\$\)|\1 = \"${MY_APPDIR}/templates\"|" \
+ lib/config.py
+
+ sed -i -e "s|^template_dir.*|#&|" conf/viewvc.conf.dist
+ mv conf/viewvc.conf{.dist,}
+ mv conf/cvsgraph.conf{.dist,}
+ mv conf/mimetypes.conf{.dist,}
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGES COMMITTERS INSTALL README
+
+ installation() {
+ insinto "$(python_get_sitedir)/${PN}"
+ doins -r lib/*
+ }
+ python_execute_function installation
+
+ insinto "${MY_APPDIR}"
+ doins -r templates/
+ doins -r templates-contrib/
+
+ if use mysql; then
+ exeinto "${MY_HOSTROOTDIR}/bin"
+ doexe bin/{*dbadmin,make-database,loginfo-handler}
+ fi
+
+ insinto "${MY_HOSTROOTDIR}/conf"
+ doins conf/{viewvc,cvsgraph,mimetypes}.conf
+
+ if use mod_python; then
+ insinto "${MY_HTDOCSDIR}"
+ doins bin/mod_python/viewvc.py
+ doins bin/mod_python/handler.py
+ doins bin/mod_python/.htaccess
+ use mysql && doins bin/mod_python/query.py
+ else
+ exeinto "${MY_CGIBINDIR}"
+ doexe bin/cgi/viewvc.cgi
+ use mysql && doexe bin/cgi/query.cgi
+ fi
+
+ webapp_configfile "${MY_HOSTROOTDIR}/conf/"{viewvc,cvsgraph}.conf
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ python_mod_optimize viewvc
+ webapp_pkg_postinst
+ elog "Now read INSTALL in /usr/share/doc/${PF} to configure ${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup viewvc
+}