summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-33.0.ebuild')
-rw-r--r--www-client/firefox/firefox-33.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/www-client/firefox/firefox-33.0.ebuild b/www-client/firefox/firefox-33.0.ebuild
index 72d9d3d7f2e8..67a0f8cedf5a 100644
--- a/www-client/firefox/firefox-33.0.ebuild
+++ b/www-client/firefox/firefox-33.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-33.0.ebuild,v 1.1 2014/10/14 18:17:47 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-33.0.ebuild,v 1.2 2014/10/16 21:12:28 axs Exp $
EAPI="5"
VIRTUALX_REQUIRED="pgo"
@@ -147,6 +147,9 @@ src_prepare() {
EPATCH_EXCLUDE="8000_gcc49_mozbug999496_ff31.patch" \
epatch "${WORKDIR}/firefox"
+ epatch "${FILESDIR}"/${P}-jemalloc-configure.patch
+ epatch "${FILESDIR}"/${PN}-32.0-hppa-js-configure.patch # bug 524556
+
# Allow user to apply any additional patches without modifing ebuild
epatch_user
@@ -182,6 +185,10 @@ src_prepare() {
# Must run autoconf in js/src
cd "${S}"/js/src || die
eautoconf
+
+ # Need to update jemalloc's configure
+ cd "${S}"/memory/jemalloc/src || die
+ WANT_AUTOCONF= eautoconf
}
src_configure() {