summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xclock/ChangeLog8
-rw-r--r--x11-apps/xclock/files/digest-xclock-1.0.01
-rw-r--r--x11-apps/xclock/xclock-1.0.0.ebuild26
-rw-r--r--x11-apps/xcmsdb/ChangeLog8
-rw-r--r--x11-apps/xcmsdb/files/digest-xcmsdb-1.0.01
-rw-r--r--x11-apps/xcmsdb/xcmsdb-1.0.0.ebuild13
-rw-r--r--x11-apps/xconsole/ChangeLog8
-rw-r--r--x11-apps/xconsole/files/digest-xconsole-1.0.01
-rw-r--r--x11-apps/xconsole/xconsole-1.0.0.ebuild22
-rw-r--r--x11-apps/xcursorgen/ChangeLog8
-rw-r--r--x11-apps/xcursorgen/files/digest-xcursorgen-1.0.01
-rw-r--r--x11-apps/xcursorgen/xcursorgen-1.0.0.ebuild15
-rw-r--r--x11-apps/xdbedizzy/ChangeLog8
-rw-r--r--x11-apps/xdbedizzy/files/digest-xdbedizzy-1.0.01
-rw-r--r--x11-apps/xdbedizzy/xdbedizzy-1.0.0.ebuild22
-rw-r--r--x11-apps/xditview/ChangeLog8
-rw-r--r--x11-apps/xditview/files/digest-xditview-1.0.01
-rw-r--r--x11-apps/xditview/xditview-1.0.0.ebuild22
-rw-r--r--x11-apps/xdm/ChangeLog7
-rw-r--r--x11-apps/xdm/files/digest-xdm-1.0.01
-rw-r--r--x11-apps/xdm/xdm-1.0.0.ebuild38
-rw-r--r--x11-apps/xdpyinfo/ChangeLog8
-rw-r--r--x11-apps/xdpyinfo/files/digest-xdpyinfo-1.0.01
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.0.0.ebuild33
-rw-r--r--x11-apps/xdriinfo/ChangeLog8
-rw-r--r--x11-apps/xdriinfo/Manifest4
-rw-r--r--x11-apps/xdriinfo/files/digest-xdriinfo-1.0.01
-rw-r--r--x11-apps/xdriinfo/xdriinfo-1.0.0.ebuild14
28 files changed, 279 insertions, 10 deletions
diff --git a/x11-apps/xclock/ChangeLog b/x11-apps/xclock/ChangeLog
index f442bfcf3980..c159c8a5a4f2 100644
--- a/x11-apps/xclock/ChangeLog
+++ b/x11-apps/xclock/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xclock
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xclock/ChangeLog,v 1.9 2005/12/09 06:42:28 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xclock/ChangeLog,v 1.10 2005/12/18 19:26:50 joshuabaergen Exp $
+
+*xclock-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xclock-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-xclock-0.99.0.ebuild, -xclock-0.99.1.ebuild:
diff --git a/x11-apps/xclock/files/digest-xclock-1.0.0 b/x11-apps/xclock/files/digest-xclock-1.0.0
new file mode 100644
index 000000000000..e2411bba4f10
--- /dev/null
+++ b/x11-apps/xclock/files/digest-xclock-1.0.0
@@ -0,0 +1 @@
+MD5 ca776b4f0a2b5a93e3a1bc7250cdf348 xclock-1.0.0.tar.bz2 99560
diff --git a/x11-apps/xclock/xclock-1.0.0.ebuild b/x11-apps/xclock/xclock-1.0.0.ebuild
new file mode 100644
index 000000000000..799da9f76279
--- /dev/null
+++ b/x11-apps/xclock/xclock-1.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xclock/xclock-1.0.0.ebuild,v 1.1 2005/12/18 19:26:50 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xclock application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
diff --git a/x11-apps/xcmsdb/ChangeLog b/x11-apps/xcmsdb/ChangeLog
index 01bc400a5e9c..e37429e5a8fc 100644
--- a/x11-apps/xcmsdb/ChangeLog
+++ b/x11-apps/xcmsdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xcmsdb
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcmsdb/ChangeLog,v 1.6 2005/12/09 06:43:03 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcmsdb/ChangeLog,v 1.7 2005/12/18 19:27:18 joshuabaergen Exp $
+
+*xcmsdb-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xcmsdb-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-xcmsdb-0.99.0.ebuild, -xcmsdb-0.99.1.ebuild:
diff --git a/x11-apps/xcmsdb/files/digest-xcmsdb-1.0.0 b/x11-apps/xcmsdb/files/digest-xcmsdb-1.0.0
new file mode 100644
index 000000000000..cf32555eb533
--- /dev/null
+++ b/x11-apps/xcmsdb/files/digest-xcmsdb-1.0.0
@@ -0,0 +1 @@
+MD5 834e1e1a58acaca0bbf249aaf75efb3e xcmsdb-1.0.0.tar.bz2 96071
diff --git a/x11-apps/xcmsdb/xcmsdb-1.0.0.ebuild b/x11-apps/xcmsdb/xcmsdb-1.0.0.ebuild
new file mode 100644
index 000000000000..a1d90e6ad458
--- /dev/null
+++ b/x11-apps/xcmsdb/xcmsdb-1.0.0.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcmsdb/xcmsdb-1.0.0.ebuild,v 1.1 2005/12/18 19:27:18 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xcmsdb application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xconsole/ChangeLog b/x11-apps/xconsole/ChangeLog
index f1643e0796f8..eec87fcb6397 100644
--- a/x11-apps/xconsole/ChangeLog
+++ b/x11-apps/xconsole/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xconsole
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xconsole/ChangeLog,v 1.8 2005/12/09 06:43:32 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xconsole/ChangeLog,v 1.9 2005/12/18 19:27:51 joshuabaergen Exp $
+
+*xconsole-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xconsole-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-xconsole-0.99.0.ebuild, -xconsole-0.99.1.ebuild, -xconsole-0.99.2.ebuild:
diff --git a/x11-apps/xconsole/files/digest-xconsole-1.0.0 b/x11-apps/xconsole/files/digest-xconsole-1.0.0
new file mode 100644
index 000000000000..3ee9467325eb
--- /dev/null
+++ b/x11-apps/xconsole/files/digest-xconsole-1.0.0
@@ -0,0 +1 @@
+MD5 d3775bded53c2f612746074d88116a45 xconsole-1.0.0.tar.bz2 81906
diff --git a/x11-apps/xconsole/xconsole-1.0.0.ebuild b/x11-apps/xconsole/xconsole-1.0.0.ebuild
new file mode 100644
index 000000000000..11cd8b68af19
--- /dev/null
+++ b/x11-apps/xconsole/xconsole-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xconsole/xconsole-1.0.0.ebuild,v 1.1 2005/12/18 19:27:51 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xconsole application"
+KEYWORDS="~amd64 ~mips ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
diff --git a/x11-apps/xcursorgen/ChangeLog b/x11-apps/xcursorgen/ChangeLog
index 849fca04318b..c387c232ce58 100644
--- a/x11-apps/xcursorgen/ChangeLog
+++ b/x11-apps/xcursorgen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xcursorgen
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcursorgen/ChangeLog,v 1.10 2005/12/09 06:43:59 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcursorgen/ChangeLog,v 1.11 2005/12/18 19:28:19 joshuabaergen Exp $
+
+*xcursorgen-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xcursorgen-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-xcursorgen-0.99.0.ebuild, -xcursorgen-0.99.1.ebuild:
diff --git a/x11-apps/xcursorgen/files/digest-xcursorgen-1.0.0 b/x11-apps/xcursorgen/files/digest-xcursorgen-1.0.0
new file mode 100644
index 000000000000..4aef1321aa19
--- /dev/null
+++ b/x11-apps/xcursorgen/files/digest-xcursorgen-1.0.0
@@ -0,0 +1 @@
+MD5 82a359feb077ae88e525ffffe6a6ffdc xcursorgen-1.0.0.tar.bz2 77954
diff --git a/x11-apps/xcursorgen/xcursorgen-1.0.0.ebuild b/x11-apps/xcursorgen/xcursorgen-1.0.0.ebuild
new file mode 100644
index 000000000000..c950d87bac64
--- /dev/null
+++ b/x11-apps/xcursorgen/xcursorgen-1.0.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xcursorgen/xcursorgen-1.0.0.ebuild,v 1.1 2005/12/18 19:28:19 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xcursorgen application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXcursor
+ =media-libs/libpng-1.2*"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xdbedizzy/ChangeLog b/x11-apps/xdbedizzy/ChangeLog
index 09c7edb96f3e..8e0807b88662 100644
--- a/x11-apps/xdbedizzy/ChangeLog
+++ b/x11-apps/xdbedizzy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdbedizzy
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdbedizzy/ChangeLog,v 1.7 2005/12/09 06:44:24 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdbedizzy/ChangeLog,v 1.8 2005/12/18 19:28:53 joshuabaergen Exp $
+
+*xdbedizzy-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xdbedizzy-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-xdbedizzy-0.99.0.ebuild, -xdbedizzy-0.99.1.ebuild,
diff --git a/x11-apps/xdbedizzy/files/digest-xdbedizzy-1.0.0 b/x11-apps/xdbedizzy/files/digest-xdbedizzy-1.0.0
new file mode 100644
index 000000000000..314a88d6c431
--- /dev/null
+++ b/x11-apps/xdbedizzy/files/digest-xdbedizzy-1.0.0
@@ -0,0 +1 @@
+MD5 81a9ba68d662abdda748236bd20a710a xdbedizzy-1.0.0.tar.bz2 82782
diff --git a/x11-apps/xdbedizzy/xdbedizzy-1.0.0.ebuild b/x11-apps/xdbedizzy/xdbedizzy-1.0.0.ebuild
new file mode 100644
index 000000000000..7be336df4dc6
--- /dev/null
+++ b/x11-apps/xdbedizzy/xdbedizzy-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdbedizzy/xdbedizzy-1.0.0.ebuild,v 1.1 2005/12/18 19:28:53 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xdbedizzy application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+
+# xprint support isn't optional, despite what configure says.
+#IUSE="xprint"
+RDEPEND="x11-libs/libXext
+ x11-libs/libXprintUtil
+ x11-libs/libXp"
+# xprint? ( x11-libs/libXprintUtil
+# x11-libs/libXp )"
+DEPEND="${RDEPEND}"
+
+#CONFIGURE_OPTIONS="$(use_enable xprint)"
diff --git a/x11-apps/xditview/ChangeLog b/x11-apps/xditview/ChangeLog
index 93c3ef4db0a9..e2dd465fb5d8 100644
--- a/x11-apps/xditview/ChangeLog
+++ b/x11-apps/xditview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xditview
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xditview/ChangeLog,v 1.6 2005/12/09 06:44:49 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xditview/ChangeLog,v 1.7 2005/12/18 19:29:26 joshuabaergen Exp $
+
+*xditview-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xditview-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-xditview-0.99.0.ebuild, -xditview-0.99.1.ebuild:
diff --git a/x11-apps/xditview/files/digest-xditview-1.0.0 b/x11-apps/xditview/files/digest-xditview-1.0.0
new file mode 100644
index 000000000000..2ab5a540a93b
--- /dev/null
+++ b/x11-apps/xditview/files/digest-xditview-1.0.0
@@ -0,0 +1 @@
+MD5 245a4505f7ae0ed1ccd761b01136cb19 xditview-1.0.0.tar.bz2 102599
diff --git a/x11-apps/xditview/xditview-1.0.0.ebuild b/x11-apps/xditview/xditview-1.0.0.ebuild
new file mode 100644
index 000000000000..498b8c85d942
--- /dev/null
+++ b/x11-apps/xditview/xditview-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xditview/xditview-1.0.0.ebuild,v 1.1 2005/12/18 19:29:26 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xditview application"
+KEYWORDS="~arm ~mips ~s390 ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index fc7e68228dd7..7055958ef990 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.30 2005/12/09 15:25:24 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.31 2005/12/18 19:29:54 joshuabaergen Exp $
+
+*xdm-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org> +xdm-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-files/gentoo_locations-0.99.3.patch, -files/gentoo_locations.patch:
diff --git a/x11-apps/xdm/files/digest-xdm-1.0.0 b/x11-apps/xdm/files/digest-xdm-1.0.0
new file mode 100644
index 000000000000..ef2de6361459
--- /dev/null
+++ b/x11-apps/xdm/files/digest-xdm-1.0.0
@@ -0,0 +1 @@
+MD5 8b680eaf629f98638df1bf1919acc6ab xdm-1.0.0.tar.bz2 377686
diff --git a/x11-apps/xdm/xdm-1.0.0.ebuild b/x11-apps/xdm/xdm-1.0.0.ebuild
new file mode 100644
index 000000000000..8e392d40e018
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.0.0.ebuild,v 1.1 2005/12/18 19:29:54 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DESCRIPTION="X.Org xdm application"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="xprint ipv6 pam"
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-0.99.1_pre20050905-r1
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-xdmconfigdir=/etc/X11/xdm"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ newpamd ${FILESDIR}/xdm.pamd xdm
+}
diff --git a/x11-apps/xdpyinfo/ChangeLog b/x11-apps/xdpyinfo/ChangeLog
index b0f4b8fc6064..3d0b0bbff626 100644
--- a/x11-apps/xdpyinfo/ChangeLog
+++ b/x11-apps/xdpyinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdpyinfo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.10 2005/12/09 15:26:16 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.11 2005/12/18 19:30:37 joshuabaergen Exp $
+
+*xdpyinfo-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xdpyinfo-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-files/xineramaproto.patch:
diff --git a/x11-apps/xdpyinfo/files/digest-xdpyinfo-1.0.0 b/x11-apps/xdpyinfo/files/digest-xdpyinfo-1.0.0
new file mode 100644
index 000000000000..9002086bbd91
--- /dev/null
+++ b/x11-apps/xdpyinfo/files/digest-xdpyinfo-1.0.0
@@ -0,0 +1 @@
+MD5 ff5f7ec5b0e5121ecff11e73052fea19 xdpyinfo-1.0.0.tar.bz2 87095
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.0.0.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.0.0.ebuild
new file mode 100644
index 000000000000..a6f0953d8347
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/xdpyinfo-1.0.0.ebuild,v 1.1 2005/12/18 19:30:37 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xdpyinfo application"
+KEYWORDS="~amd64 ~arm ~mips ~s390 ~sparc ~x86"
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86misc
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXinerama
+ x11-libs/libdmx
+ x11-libs/libXp"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/kbproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86miscproto
+ x11-proto/inputproto
+ x11-proto/renderproto
+ x11-proto/xineramaproto
+ x11-proto/dmxproto
+ x11-proto/printproto"
diff --git a/x11-apps/xdriinfo/ChangeLog b/x11-apps/xdriinfo/ChangeLog
index cd87c4940a4b..5d00e6f7267f 100644
--- a/x11-apps/xdriinfo/ChangeLog
+++ b/x11-apps/xdriinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdriinfo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/ChangeLog,v 1.6 2005/12/09 06:46:06 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/ChangeLog,v 1.7 2005/12/18 19:31:24 joshuabaergen Exp $
+
+*xdriinfo-1.0.0 (18 Dec 2005)
+
+ 18 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xdriinfo-1.0.0.ebuild:
+ Bump for 7.0RC4.
09 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
-xdriinfo-0.99.1.ebuild:
diff --git a/x11-apps/xdriinfo/Manifest b/x11-apps/xdriinfo/Manifest
index cf738deca0ff..df3ee1ff449f 100644
--- a/x11-apps/xdriinfo/Manifest
+++ b/x11-apps/xdriinfo/Manifest
@@ -1,4 +1,6 @@
-MD5 de1434f3588d007560d920b881625ed0 ChangeLog 963
+MD5 97bdce8b21dfd8a66c856c08cd09cebb ChangeLog 1097
MD5 c91427ea0a5d82e0ec41f22776849390 files/digest-xdriinfo-0.99.2 67
+MD5 4967c270ba007e48c43e172d8c5c9052 files/digest-xdriinfo-1.0.0 66
MD5 a37bab73e2f24b213932c30997d3d360 metadata.xml 156
MD5 a6af58349423970bdf9f8ffb14a80fcb xdriinfo-0.99.2.ebuild 435
+MD5 a6af58349423970bdf9f8ffb14a80fcb xdriinfo-1.0.0.ebuild 435
diff --git a/x11-apps/xdriinfo/files/digest-xdriinfo-1.0.0 b/x11-apps/xdriinfo/files/digest-xdriinfo-1.0.0
new file mode 100644
index 000000000000..c35baa71e01b
--- /dev/null
+++ b/x11-apps/xdriinfo/files/digest-xdriinfo-1.0.0
@@ -0,0 +1 @@
+MD5 5ca3fc5073dd52875dcfb456cebe69db xdriinfo-1.0.0.tar.bz2 77241
diff --git a/x11-apps/xdriinfo/xdriinfo-1.0.0.ebuild b/x11-apps/xdriinfo/xdriinfo-1.0.0.ebuild
new file mode 100644
index 000000000000..7ecdf663491b
--- /dev/null
+++ b/x11-apps/xdriinfo/xdriinfo-1.0.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdriinfo/xdriinfo-1.0.0.ebuild,v 1.1 2005/12/18 19:31:24 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xdriinfo application"
+KEYWORDS="~x86"
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/glproto"