summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xlockmore')
-rw-r--r--x11-misc/xlockmore/ChangeLog9
-rw-r--r--x11-misc/xlockmore/files/digest-xlockmore-5.253
-rw-r--r--x11-misc/xlockmore/xlockmore-5.25.ebuild64
3 files changed, 74 insertions, 2 deletions
diff --git a/x11-misc/xlockmore/ChangeLog b/x11-misc/xlockmore/ChangeLog
index 575b6839acd0..89feeab51af8 100644
--- a/x11-misc/xlockmore/ChangeLog
+++ b/x11-misc/xlockmore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xlockmore
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.63 2007/05/06 15:04:38 dertobi123 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.64 2008/01/12 02:57:08 drac Exp $
+
+*xlockmore-5.25 (12 Jan 2008)
+
+ 12 Jan 2008; Samuli Suominen <drac@gentoo.org> +xlockmore-5.25.ebuild:
+ Version bump.
06 May 2007; Tobias Scherbaum <dertobi123@gentoo.org>
xlockmore-5.23-r1.ebuild:
diff --git a/x11-misc/xlockmore/files/digest-xlockmore-5.25 b/x11-misc/xlockmore/files/digest-xlockmore-5.25
new file mode 100644
index 000000000000..61fb92c18db2
--- /dev/null
+++ b/x11-misc/xlockmore/files/digest-xlockmore-5.25
@@ -0,0 +1,3 @@
+MD5 2d25b656e11b90f2e2d4244883d639fb xlockmore-5.25.tar.bz2 1792781
+RMD160 f73aa838ac0ec53a3ba0f2e4957b7955e4e964d3 xlockmore-5.25.tar.bz2 1792781
+SHA256 ad06f3bd82cfc96e67f239814fcba5b4de4250cf9a1ca9af57be1149acc3f904 xlockmore-5.25.tar.bz2 1792781
diff --git a/x11-misc/xlockmore/xlockmore-5.25.ebuild b/x11-misc/xlockmore/xlockmore-5.25.ebuild
new file mode 100644
index 000000000000..542fe53c06da
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.25.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/xlockmore-5.25.ebuild,v 1.1 2008/01/12 02:57:08 drac Exp $
+
+inherit flag-o-matic pam
+
+DESCRIPTION="Just another screensaver application for X"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+SRC_URI="http://ftp.tux.org/pub/tux/bagleyd/${PN}/${P}/${P}.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug nas esd motif opengl truetype gtk pam xlockrc unicode"
+
+RDEPEND="opengl? ( media-libs/mesa )
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm
+ media-libs/freetype
+ pam? ( virtual/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( x11-libs/openmotif )
+ gtk? ( >=x11-libs/gtk+-2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xineramaproto"
+
+src_compile() {
+ econf --enable-appdefaultdir=/usr/share/X11/app-defaults \
+ --enable-vtlock --without-ftgl --without-gltt \
+ $(use_enable crypt) \
+ $(use_with opengl) \
+ $(use_with opengl mesa) \
+ $(use_enable xlockrc) \
+ $(use_enable unicode use-mb) \
+ $(use_enable pam) \
+ $(use_with truetype ttf) \
+ $(use_with gtk gtk2) \
+ $(use_with motif) \
+ $(use_with esd esound) \
+ $(use_with nas) \
+ $(use_with debug editres)
+
+ # suid-with-lazy-bindings problem
+ append-flags $(bindnow-flags)
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ einstall xapploaddir="${D}/usr/share/X11/app-defaults" \
+ mandir="${D}/usr/share/man/man1" || die "einstall failed."
+
+ pamd_mimic_system xlock auth
+ use pam && chmod 755 "${D}"/usr/bin/xlock
+
+ dohtml docs/*.html
+ rm docs/*.html
+ dodoc README docs/*
+}