summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bbcd/ChangeLog8
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1-r1.ebuild7
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1.ebuild22
-rw-r--r--x11-misc/bbcd/files/bbcd-0.3.1-gcc4.3.patch11
4 files changed, 21 insertions, 27 deletions
diff --git a/x11-misc/bbcd/ChangeLog b/x11-misc/bbcd/ChangeLog
index 84396e1b18f5..126f393f1e99 100644
--- a/x11-misc/bbcd/ChangeLog
+++ b/x11-misc/bbcd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/bbcd
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/ChangeLog,v 1.12 2007/02/21 23:30:10 jokey Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/ChangeLog,v 1.13 2008/09/17 16:26:16 coldwind Exp $
+
+ 17 Sep 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +files/bbcd-0.3.1-gcc4.3.patch, -bbcd-0.3.1.ebuild, bbcd-0.3.1-r1.ebuild:
+ Add patch for gcc 4.3. Remove old version. Add ~amd64 keyword.
21 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild b/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
index 8ae0aa115369..47a5f960b290 100644
--- a/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
+++ b/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild,v 1.8 2006/12/07 02:21:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild,v 1.9 2008/09/17 16:26:16 coldwind Exp $
inherit eutils
@@ -9,7 +9,7 @@ HOMEPAGE="http://tranber1.free.fr/bbcd.html"
SRC_URI="http://tranber1.free.fr/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="ppc x86 ~x86-fbsd"
+KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
IUSE=""
DEPEND="virtual/blackbox
@@ -19,6 +19,7 @@ src_unpack() {
unpack ${A}
epatch "${FILESDIR}"/${P}_${PV}a.diff
epatch "${FILESDIR}"/${P}-gcc3.3.patch
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
}
src_install () {
diff --git a/x11-misc/bbcd/bbcd-0.3.1.ebuild b/x11-misc/bbcd/bbcd-0.3.1.ebuild
deleted file mode 100644
index f6e7bc1cd86c..000000000000
--- a/x11-misc/bbcd/bbcd-0.3.1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1.ebuild,v 1.7 2005/08/06 16:47:54 swegener Exp $
-
-DESCRIPTION="Basic CD Player for blackbox wm"
-HOMEPAGE="http://tranber1.free.fr/bbcd.html"
-SRC_URI="http://tranber1.free.fr/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc"
-IUSE=""
-
-DEPEND="virtual/blackbox
- media-libs/libcdaudio"
-
-src_install () {
- make \
- DESTDIR="${D}" \
- install || die
- rm -rf "${D}"/usr/doc
- dodoc AUTHORS BUGS ChangeLog NEWS README
-}
diff --git a/x11-misc/bbcd/files/bbcd-0.3.1-gcc4.3.patch b/x11-misc/bbcd/files/bbcd-0.3.1-gcc4.3.patch
new file mode 100644
index 000000000000..90c2d4ab8d8e
--- /dev/null
+++ b/x11-misc/bbcd/files/bbcd-0.3.1-gcc4.3.patch
@@ -0,0 +1,11 @@
+Add header to be compatible with gcc-4.3 and glibc-2.8.
+--- bbcd-0.3.1/Image.cc
++++ bbcd-0.3.1/Image.cc
+@@ -29,6 +29,7 @@
+ //# include <stdio.h>
+ //#endif // HAVE_STDIO_H
+ #include <iostream>
++#include <cstring>
+
+ #include <algorithm>
+ using std::max;