From 455f186c66a99ff934a8611e30480dc10425cf9f Mon Sep 17 00:00:00 2001
From: Fabio Erculiani <lxnay@gentoo.org>
Date: Fri, 5 Nov 2010 16:27:30 +0000
Subject: add 2.6.36 Linux kernel support

(Portage version: 2.2_rc91/cvs/Linux x86_64)
---
 app-emulation/vmware-modules/ChangeLog                       |  7 ++++++-
 .../vmware-modules/files/1.0.0.26-ioctl-2.6.36.patch         | 12 ++++++++++++
 .../vmware-modules/vmware-modules-1.0.0.25-r1.ebuild         |  4 ++--
 app-emulation/vmware-modules/vmware-modules-1.0.0.26.ebuild  |  7 ++++---
 4 files changed, 24 insertions(+), 6 deletions(-)
 create mode 100644 app-emulation/vmware-modules/files/1.0.0.26-ioctl-2.6.36.patch

(limited to 'app-emulation/vmware-modules')

diff --git a/app-emulation/vmware-modules/ChangeLog b/app-emulation/vmware-modules/ChangeLog
index afe7cb2c7cba..de886ac4bf4c 100644
--- a/app-emulation/vmware-modules/ChangeLog
+++ b/app-emulation/vmware-modules/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for app-emulation/vmware-modules
 # Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.58 2010/08/04 19:01:30 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/ChangeLog,v 1.59 2010/11/05 16:27:29 lxnay Exp $
+
+  05 Nov 2010; Fabio Erculiani <lxnay@gentoo.org>
+  vmware-modules-1.0.0.25-r1.ebuild, vmware-modules-1.0.0.26.ebuild,
+  +files/1.0.0.26-ioctl-2.6.36.patch:
+  add 2.6.36 Linux kernel support
 
   04 Aug 2010; Vadim Kuznetsov <vadimk@gentoo.org>
   +files/1.0.0.24-sk_sleep.patch, vmware-modules-1.0.0.24-r1.ebuild,
diff --git a/app-emulation/vmware-modules/files/1.0.0.26-ioctl-2.6.36.patch b/app-emulation/vmware-modules/files/1.0.0.26-ioctl-2.6.36.patch
new file mode 100644
index 000000000000..1b9cf18e5c3a
--- /dev/null
+++ b/app-emulation/vmware-modules/files/1.0.0.26-ioctl-2.6.36.patch
@@ -0,0 +1,12 @@
+--- a/vmmon-only/linux/driver.c
++++ b/vmmon-only/linux/driver.c
+@@ -143,6 +143,9 @@
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 24)
+ #define VMW_NOPAGE_2624
+ #endif
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 36)
++#define VMW_HAVE_UNLOCKED_IOCTL
++#endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0) && \
+     (defined(CONFIG_SMP) || defined(CONFIG_PREEMPT))
+ #  define kernel_locked_by_current() kernel_locked()
diff --git a/app-emulation/vmware-modules/vmware-modules-1.0.0.25-r1.ebuild b/app-emulation/vmware-modules/vmware-modules-1.0.0.25-r1.ebuild
index 5e8e0a994d8f..0100dce8868c 100644
--- a/app-emulation/vmware-modules/vmware-modules-1.0.0.25-r1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-1.0.0.25-r1.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-1.0.0.25-r1.ebuild,v 1.4 2010/08/04 19:01:30 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-1.0.0.25-r1.ebuild,v 1.5 2010/11/05 16:27:29 lxnay Exp $
 
 EAPI="2"
 
@@ -62,7 +62,7 @@ src_prepare() {
 	epatch "${FILESDIR}/${PV}-autoconf-generated.patch"
 	epatch "${FILESDIR}/apic.patch"
 	#kernel_is 2 6 35 && epatch "${FILESDIR}/iommu_map.patch"
-	kernel_is 2 6 35 && epatch "${FILESDIR}/${PV}-sk_sleep.patch"
+	kernel_is ge 2 6 35 && epatch "${FILESDIR}/${PV}-sk_sleep.patch"
 
 }
 
diff --git a/app-emulation/vmware-modules/vmware-modules-1.0.0.26.ebuild b/app-emulation/vmware-modules/vmware-modules-1.0.0.26.ebuild
index 0435c38030f3..abbaa5d9e287 100644
--- a/app-emulation/vmware-modules/vmware-modules-1.0.0.26.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-1.0.0.26.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-1.0.0.26.ebuild,v 1.3 2010/08/04 19:01:30 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-1.0.0.26.ebuild,v 1.4 2010/11/05 16:27:29 lxnay Exp $
 
 EAPI="2"
 
@@ -59,8 +59,9 @@ src_prepare() {
 	epatch "${FILESDIR}/${PV}-makefile-kernel-dir.patch"
 	epatch "${FILESDIR}/${PV}-makefile-include.patch"
 	epatch "${FILESDIR}/apic.patch"
-	kernel_is 2 6 35 && epatch "${FILESDIR}/${PV}-iommu_map.patch"
-	kernel_is 2 6 35 && epatch "${FILESDIR}/${PV}-sk_sleep.patch"
+	kernel_is ge 2 6 35 && epatch "${FILESDIR}/${PV}-iommu_map.patch"
+	kernel_is ge 2 6 35 && epatch "${FILESDIR}/${PV}-sk_sleep.patch"
+	kernel_is ge 2 6 36 && epatch "${FILESDIR}/${PV}-ioctl-2.6.36.patch"
 }
 
 src_install() {
-- 
cgit v1.2.3-65-gdbad