From b981c96d83b368f9a1805b28ab7f357844844666 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Mon, 31 Dec 2012 06:53:38 +0000
Subject: Move boost to DEPEND for all versions since it is not linked against,
 and move myhlopts setup out of pkg_setup and into src_compile since it is
 only used with src_* funcs.

(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
---
 app-text/highlight/highlight-3.3.ebuild | 32 ++++++++++++++++----------------
 1 file changed, 16 insertions(+), 16 deletions(-)

(limited to 'app-text/highlight/highlight-3.3.ebuild')

diff --git a/app-text/highlight/highlight-3.3.ebuild b/app-text/highlight/highlight-3.3.ebuild
index 5e6508ba3a2d..40136917281e 100644
--- a/app-text/highlight/highlight-3.3.ebuild
+++ b/app-text/highlight/highlight-3.3.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.3.ebuild,v 1.8 2012/01/22 15:30:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.3.ebuild,v 1.9 2012/12/31 06:53:38 vapier Exp $
 
 EAPI=4
 
@@ -15,13 +15,22 @@ SLOT="0"
 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
 IUSE="examples qt4"
 
-DEPEND="dev-lang/lua
-	dev-libs/boost
-	qt4? ( x11-libs/qt-gui:4
-		x11-libs/qt-core:4 )"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-lang/lua
+	qt4? (
+		x11-libs/qt-gui:4
+		x11-libs/qt-core:4
+	)"
+DEPEND="${RDEPEND}
+	dev-libs/boost"
 
-pkg_setup() {
+src_prepare() {
+	epatch "${FILESDIR}"/${P}-parallel-make.patch
+
+	sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+		src/core/datadir.cpp || die
+}
+
+src_compile() {
 	myhlopts=(
 		"CXX=$(tc-getCXX)"
 		"AR=$(tc-getAR)"
@@ -32,16 +41,7 @@ pkg_setup() {
 		"doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
 		"conf_dir=${EPREFIX}/etc/highlight/"
 	)
-}
 
-src_prepare() {
-	epatch "${FILESDIR}"/${P}-parallel-make.patch
-
-	sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
-		src/core/datadir.cpp || die
-}
-
-src_compile() {
 	emake -f makefile "${myhlopts[@]}"
 	if use qt4 ; then
 		cd src/gui-qt
-- 
cgit v1.2.3-65-gdbad