From 416327e8e3a20b5c95aa00ff0008cc4630535b3b Mon Sep 17 00:00:00 2001
From: Julian Ospald <hasufell@gentoo.org>
Date: Mon, 18 Nov 2013 20:34:12 +0000
Subject: version bump

(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
---
 games-emulation/gambatte/ChangeLog                 |  8 +-
 .../gambatte/gambatte-0.5.0_p20131102.ebuild       | 98 ++++++++++++++++++++++
 2 files changed, 105 insertions(+), 1 deletion(-)
 create mode 100644 games-emulation/gambatte/gambatte-0.5.0_p20131102.ebuild

(limited to 'games-emulation')

diff --git a/games-emulation/gambatte/ChangeLog b/games-emulation/gambatte/ChangeLog
index c1cb46db3f42..63df019f4d7b 100644
--- a/games-emulation/gambatte/ChangeLog
+++ b/games-emulation/gambatte/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for games-emulation/gambatte
 # Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gambatte/ChangeLog,v 1.4 2013/11/16 05:16:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gambatte/ChangeLog,v 1.5 2013/11/18 20:34:12 hasufell Exp $
+
+*gambatte-0.5.0_p20131102 (18 Nov 2013)
+
+  18 Nov 2013; Julian Ospald <hasufell@gentoo.org>
+  +gambatte-0.5.0_p20131102.ebuild:
+  version bump
 
   16 Nov 2013; Michael Sterrett <mr_bones_@gentoo.org>
   -gambatte-0.5.0_p20130310.ebuild, -gambatte-0.5.0_p20130413.ebuild:
diff --git a/games-emulation/gambatte/gambatte-0.5.0_p20131102.ebuild b/games-emulation/gambatte/gambatte-0.5.0_p20131102.ebuild
new file mode 100644
index 000000000000..3d0e079a096a
--- /dev/null
+++ b/games-emulation/gambatte/gambatte-0.5.0_p20131102.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gambatte/gambatte-0.5.0_p20131102.ebuild,v 1.1 2013/11/18 20:34:11 hasufell Exp $
+
+EAPI=5
+
+inherit scons-utils qt4-r2 games
+
+DESCRIPTION="An accuracy-focused Gameboy / Gameboy Color emulator"
+HOMEPAGE="http://sourceforge.net/projects/gambatte"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4 +sdl"
+REQUIRED_USE="|| ( qt4 sdl )"
+
+RDEPEND="
+	sys-libs/zlib
+	qt4? (
+		dev-qt/qtcore:4
+		dev-qt/qtgui:4
+		dev-qt/qtopengl:4
+		media-libs/alsa-lib
+		x11-libs/libX11
+		x11-libs/libXext
+		x11-libs/libXrandr
+		x11-libs/libXv
+	)
+	sdl? ( media-libs/libsdl[X,audio,joystick,video] )"
+DEPEND="${RDEPEND}
+	app-arch/xz-utils"
+
+fix_scons() {
+	local i
+	for i; do
+		cat >> $i << END
+import os
+import SCons.Util
+
+if os.environ.has_key('AR'):
+	env['AR'] = os.environ['AR']
+if os.environ.has_key('RANLIB'):
+	env['RANLIB'] = os.environ['RANLIB']
+if os.environ.has_key('CC'):
+	env['CC'] = os.environ['CC']
+if os.environ.has_key('CFLAGS'):
+	env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
+if os.environ.has_key('CXX'):
+	env['CXX'] = os.environ['CXX']
+if os.environ.has_key('CXXFLAGS'):
+	env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
+if os.environ.has_key('CPPFLAGS'):
+	env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CPPFLAGS'])
+if os.environ.has_key('LDFLAGS'):
+	env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+END
+	done
+}
+
+src_prepare() {
+	# Fix zlib/minizip build error
+	sed -i \
+		-e '1i#define OF(x) x' \
+		libgambatte/src/file/unzip/{unzip,ioapi}.h \
+		|| die "sed iompi.h failed"
+
+	fix_scons {gambatte_sdl,libgambatte}/SConstruct
+}
+
+src_compile() {
+	# build core library
+	cd "${S}"/libgambatte || die
+	escons
+
+	# build sdl frontend
+	if use sdl; then
+		cd "${S}"/gambatte_sdl || die
+		escons
+	fi
+
+	# build qt frontend
+	if use qt4; then
+		cd "${S}"/gambatte_qt || die
+		eqmake4 ${PN}_qt.pro
+		emake
+	fi
+}
+
+src_install() {
+	use sdl && dogamesbin gambatte_sdl/gambatte_sdl
+	use qt4 && dogamesbin gambatte_qt/bin/gambatte_qt
+
+	nonfatal dodoc README changelog
+
+	prepgamesdirs
+}
-- 
cgit v1.2.3-65-gdbad