From 5260859778d7d9fe7e44634455608586b621ab5b Mon Sep 17 00:00:00 2001
From: Tim Harder <radhermit@gentoo.org>
Date: Mon, 17 Mar 2014 03:44:46 +0000
Subject: Version bump.

(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
---
 www-client/dwb/ChangeLog                           |  10 +-
 www-client/dwb/dwb-2014.03.07.ebuild               |  52 +++++++
 www-client/dwb/dwb-9999.ebuild                     |   6 +-
 .../dwb/files/dwb-2014.03.07-verbose-build.patch   | 159 +++++++++++++++++++++
 4 files changed, 222 insertions(+), 5 deletions(-)
 create mode 100644 www-client/dwb/dwb-2014.03.07.ebuild
 create mode 100644 www-client/dwb/files/dwb-2014.03.07-verbose-build.patch

(limited to 'www-client/dwb')

diff --git a/www-client/dwb/ChangeLog b/www-client/dwb/ChangeLog
index 6bebc91975c5..ac74a410356c 100644
--- a/www-client/dwb/ChangeLog
+++ b/www-client/dwb/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for www-client/dwb
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/ChangeLog,v 1.20 2013/05/10 04:32:58 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/ChangeLog,v 1.21 2014/03/17 03:44:45 radhermit Exp $
+
+*dwb-2014.03.07 (17 Mar 2014)
+
+  17 Mar 2014; Tim Harder <radhermit@gentoo.org> +dwb-2014.03.07.ebuild,
+  dwb-9999.ebuild, +files/dwb-2014.03.07-verbose-build.patch:
+  Version bump.
 
   10 May 2013; Tim Harder <radhermit@gentoo.org> dwb-9999.ebuild:
   Drop workaround for uclibc build that's been fixed upstream.
diff --git a/www-client/dwb/dwb-2014.03.07.ebuild b/www-client/dwb/dwb-2014.03.07.ebuild
new file mode 100644
index 000000000000..77249a252fb6
--- /dev/null
+++ b/www-client/dwb/dwb-2014.03.07.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-2014.03.07.ebuild,v 1.1 2014/03/17 03:44:46 radhermit Exp $
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
+HOMEPAGE="http://portix.bitbucket.org/dwb/"
+SRC_URI="mirror://bitbucket/portix/dwb/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples gtk3"
+
+RDEPEND=">=net-libs/libsoup-2.32:2.4
+	dev-libs/json-c
+	net-libs/gnutls
+	!gtk3? (
+		>=net-libs/webkit-gtk-1.8.0:2
+		x11-libs/gtk+:2
+	)
+	gtk3? (
+		>=net-libs/webkit-gtk-1.8.0:3
+		x11-libs/gtk+:3
+	)"
+DEPEND="${RDEPEND}
+	virtual/pkgconfig"
+
+src_prepare() {
+	epatch "${FILESDIR}"/${P}-verbose-build.patch
+
+	sed -i '/^CFLAGS += -\(pipe\|g\|O2\)/d' config.mk || die
+}
+
+src_compile() {
+	local myconf
+	use gtk3 && myconf+=" GTK=3"
+
+	emake CC="$(tc-getCC)" ${myconf}
+}
+
+src_install() {
+	default
+
+	if use examples ; then
+		dodoc -r examples
+		docompress -x /usr/share/doc/${PF}/examples
+	fi
+}
diff --git a/www-client/dwb/dwb-9999.ebuild b/www-client/dwb/dwb-9999.ebuild
index 3661a57d03f4..ee9adb7eba3e 100644
--- a/www-client/dwb/dwb-9999.ebuild
+++ b/www-client/dwb/dwb-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-9999.ebuild,v 1.8 2013/05/10 04:32:58 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-9999.ebuild,v 1.9 2014/03/17 03:44:45 radhermit Exp $
 
 EAPI=5
 
-inherit git-2 toolchain-funcs
+inherit git-r3 toolchain-funcs
 
 EGIT_REPO_URI="https://bitbucket.org/portix/dwb.git"
 
diff --git a/www-client/dwb/files/dwb-2014.03.07-verbose-build.patch b/www-client/dwb/files/dwb-2014.03.07-verbose-build.patch
new file mode 100644
index 000000000000..5d16a683ad36
--- /dev/null
+++ b/www-client/dwb/files/dwb-2014.03.07-verbose-build.patch
@@ -0,0 +1,159 @@
+--- dwb-2014.03.07/dwbem/Makefile
++++ dwb-2014.03.07/dwbem/Makefile
+@@ -27,12 +27,10 @@
+ all: $(TARGET)
+ 
+ $(TARGET): $(OBJ)
+-	@echo $(CC) -o $@
+-	@$(CC) $(OBJ) -o $@ $(LDFLAGS)
++	$(CC) $(OBJ) -o $@ $(LDFLAGS)
+ 
+ %.o: %.c
+-	@echo $(CC) $< 
+-	@$(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
++	$(CC) $(CFLAGS) -c $< -o $@ $(CPPFLAGS)
+ 
+ clean: 
+ 	rm -f $(TARGET) $(OBJ)
+--- dwb-2014.03.07/dwbremote/Makefile
++++ dwb-2014.03.07/dwbremote/Makefile
+@@ -27,12 +27,10 @@
+ all: $(TARGET)
+ 
+ $(TARGET): $(SHARED_OBJ) main.o
+-	@echo $(CC) -o $@
+-	@$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++	$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+ 
+ %.o: %.c 
+-	@echo $(CC) $< 
+-	@$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
++	$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
+ 
+ debug: 
+ 	make CFLAGS="$(DCFLAGS)"
+--- dwb-2014.03.07/exar/Makefile
++++ dwb-2014.03.07/exar/Makefile
+@@ -14,12 +14,10 @@
+ all: $(SHARED_OBJ)
+ 
+ $(TARGET): $(OBJ)
+-	@echo $(CC) -o $@
+-	@$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS)
++	$(CC) $(OBJ) -o $@ $(CFLAGS) $(CPPFLAGS)
+ 
+ %.o: %.c 
+-	@echo $(CC) $< 
+-	@$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
++	$(CC) -c $< -o $@ $(CFLAGS) $(CPPFLAGS)
+ 
+ debug: 
+ 	make CFLAGS="$(DCFLAGS)"
+--- dwb-2014.03.07/Makefile
++++ dwb-2014.03.07/Makefile
+@@ -14,18 +14,18 @@
+ $(TARGET): $(SUBDIRS:%=%.subdir-make)
+ 
+ %.subdir-make: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+-	@$(MAKE) $(MFLAGS) -C $*
++	$(MAKE) $(MFLAGS) -C $*
+ 
+ #$(SRCDIR)/%: $(SUBDIR_BUILD_FIRST:%=%.subdir-buildfirst)
+ 
+ %.subdir-buildfirst: 
+-	@$(MAKE) $(MFLAGS) -C $*
++	$(MAKE) $(MFLAGS) -C $*
+ 
+ clean:  $(SUBDIRS:%=%.subdir-clean) $(SUBDIR_BUILD_FIRST:%=%.subdir-cleanfirst) $(SUBDIR_BUILD_LIB:%=%.subdir-cleanlib)
+ 	-$(RM) -r sandbox
+ 
+ %.subdir-clean %.subdir-cleanfirst %.subdir-cleanlib:
+-	@$(MAKE) $(MFLAGS) clean -C $*
++	$(MAKE) $(MFLAGS) clean -C $*
+ 
+ 
+ install: $(TARGET) install-man install-data
+--- dwb-2014.03.07/scripts/lib/Makefile
++++ dwb-2014.03.07/scripts/lib/Makefile
+@@ -1,6 +1,6 @@
+ # See COPYING for copyright and license details
+ TARGETS := $(patsubst %.js.in, %.js, $(wildcard *.js.in)) 
+-CFLAGS := -std=c99 -Wall -Wextra -pedantic -Werror -O2
++CFLAGS += -std=c99 -Wall -Wextra -pedantic
+ 
+ all: $(TARGETS)
+ 
+@@ -9,7 +9,7 @@
+ 	@./minify $< $@
+ 
+ minify: minify.c
+-	$(CC) $< -o $@ ${CFLAGS} ${CPPFLAGS}
++	$(CC) $< -o $@ ${CFLAGS} ${CPPFLAGS} ${LDFLAGS}
+ 
+ clean:  
+ 	$(RM) $(TARGETS)
+--- dwb-2014.03.07/src/Makefile
++++ dwb-2014.03.07/src/Makefile
+@@ -26,30 +26,25 @@
+ all: $(TARGET)
+ 
+ $(TARGET): $(OBJ) 
+-	@echo $(CC) -o $@
+-	@$(CC) $(OBJ) -o $(TARGET) $(LDFLAGS) 
++	$(CC) $(OBJ) -o $(TARGET) $(LDFLAGS) 
+ 
+ -include $(OBJ:.o=.d)
+ -include $(DOBJ:.do=.dd)
+ 
+ %.o: %.c %.h config.h dwb.h
+-	@echo $(CC) $<
+-	@$(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS) 
++	$(CC) -c -o $@ $< $(CFLAGS) $(CPPFLAGS) 
+ 
+ debug: $(DTARGET)
+ 
+ deps.d: %.c %.h
+-	@echo "$(CC) -MM $@"
+-	@$(CC) $(CFLAGS) -MM $< -o $@
++	$(CC) $(CFLAGS) -MM $< -o $@
+ 
+ 
+ %.do: %.c %.h config.h
+-	@echo "${CC} $<"
+-	@$(CC) -c -o $@ $< $(DCFLAGS) 
++	$(CC) -c -o $@ $< $(DCFLAGS) 
+ 
+ $(DTARGET): $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o
+-	@echo "$(CC) $@"
+-	@$(CC) $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o -o $(DTARGET) $(LDFLAGS) 
++	$(CC) $(DOBJ) ../exar/exar.o ../dwbremote/dwbremote.o -o $(DTARGET) $(LDFLAGS) 
+ 
+ dependencies: $(DEPS)
+ 
+--- dwb-2014.03.07/src/util/Makefile
++++ dwb-2014.03.07/src/util/Makefile
+@@ -30,20 +30,16 @@
+ all: $(OUTFILES)
+ 
+ $(TLDS_H): $(TLDS_IN) $(MKTLDS)
+-	@echo gen $(notdir $@)
+-	@./$(MKTLDS) < $(TLDS_IN) > $@
++	./$(MKTLDS) < $(TLDS_IN) > $@
+ 
+ $(MKTLDS): $(MKTLDS_SRC)
+-	@echo $(CC) $< 
+-	@$(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
++	$(CC) -o $@ $< $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+ 
+ $(HSTS_PRELOAD): $(HSTS) $(TRANSPORT_SECURITY_CERTS) $(TRANSPORT_SECURITY_JSON)
+-	@echo gen $(notdir $@)
+-	@./$(HSTS) > $@
++	./$(HSTS) > $@
+ 
+ $(HSTS): $(HSTS).c
+-	@echo $(CC) $< 
+-	@$(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
++	$(CC) $(CFLAGS) $(CPPFLAGS) -o $(HSTS) $(HSTS).c $(LDFLAGS)
+ 
+ clean: 
+ 	$(RM) $(OUTFILES) $(GEN_TOOLS)
-- 
cgit v1.2.3-65-gdbad