From e19959c46c78d9fc6c44108104dd14ac1abcbd44 Mon Sep 17 00:00:00 2001
From: Aron Griffis <agriffis@gentoo.org>
Date: Thu, 15 Jul 2004 01:12:44 +0000
Subject: don't dep on arch for gnuconfig_update, don't assign
 S=${WORKDIR}/${P}, trim trailing whitespace

---
 x11-wm/fvwm/fvwm-2.4.18.ebuild    |  5 ++---
 x11-wm/fvwm/fvwm-2.5.10-r3.ebuild | 12 +++++-------
 x11-wm/fvwm/fvwm-2.5.10-r4.ebuild | 12 +++++-------
 x11-wm/fvwm/fvwm-2.5.10-r5.ebuild | 11 +++++------
 x11-wm/fvwm/fvwm-2.5.10-r6.ebuild | 11 +++++------
 x11-wm/fvwm/fvwm-2.5.7-r5.ebuild  |  7 +++----
 x11-wm/fvwm/fvwm-2.5.8-r6.ebuild  | 28 +++++++++++++---------------
 7 files changed, 38 insertions(+), 48 deletions(-)

(limited to 'x11-wm/fvwm')

diff --git a/x11-wm/fvwm/fvwm-2.4.18.ebuild b/x11-wm/fvwm/fvwm-2.4.18.ebuild
index f9e9410c01ee..7f19d831d5c5 100644
--- a/x11-wm/fvwm/fvwm-2.4.18.ebuild
+++ b/x11-wm/fvwm/fvwm-2.4.18.ebuild
@@ -1,12 +1,11 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.4.18.ebuild,v 1.4 2004/06/24 23:41:22 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.4.18.ebuild,v 1.5 2004/07/15 01:12:44 agriffis Exp $
 
 inherit gnuconfig
 
 IUSE="readline ncurses gtk stroke gnome rplay xinerama cjk imlib"
 
-S=${WORKDIR}/${P}
 DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
 SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2"
 HOMEPAGE="http://www.fvwm.org/"
@@ -32,7 +31,7 @@ DEPEND="${RDEPEND}
 
 src_unpack() {
 	unpack ${A}
-	use alpha && gnuconfig_update
+	gnuconfig_update
 
 	# CFLAGS containing comma will break this, so change it for !
 	sed -i 's#\x27s,xCFLAGSx,$(CFLAGS),\x27#\x27s!xCFLAGSx!$(CFLAGS)!\x27#' ${S}/utils/Makefile.am
diff --git a/x11-wm/fvwm/fvwm-2.5.10-r3.ebuild b/x11-wm/fvwm/fvwm-2.5.10-r3.ebuild
index 926f07a0ed96..e5739195b2be 100644
--- a/x11-wm/fvwm/fvwm-2.5.10-r3.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.10-r3.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.10-r3.ebuild,v 1.8 2004/07/07 02:08:02 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.10-r3.ebuild,v 1.9 2004/07/15 01:12:44 agriffis Exp $
 
 inherit eutils flag-o-matic
 
@@ -41,13 +41,11 @@ DEPEND="${RDEPEND}
 	>=sys-apps/sed-4
 	dev-util/pkgconfig"
 
-S=${WORKDIR}/${P}
-
 src_unpack() {
 	unpack ${A}
 
-	# this patch enables fast translucent menus in fvwm..yummy! this is a 
-	# minor tweak of a patch posted to fvwm-user mailing list by Olivier 
+	# this patch enables fast translucent menus in fvwm..yummy! this is a
+	# minor tweak of a patch posted to fvwm-user mailing list by Olivier
 	# Chapuis in <20030827135125.GA6370@snoopy.folie>.
 	cd ${S}; epatch ${FILESDIR}/fvwm-2.5.9-translucent-menus.diff.gz
 
@@ -251,8 +249,8 @@ src_install() {
 		rm -rf ${D}/usr/bin/fvwm-perllib ${D}/usr/share/man/man1/fvwm-perllib.1
 	fi
 
-	# neat utility for testing fvwm behaviour on applications setting various 
-	# hints, creates a simple black window with configurable hints set. 
+	# neat utility for testing fvwm behaviour on applications setting various
+	# hints, creates a simple black window with configurable hints set.
 	if use debug; then
 		dobin ${S}/tests/hints/hints_test
 		newdoc ${S}/tests/hints/README README.hints
diff --git a/x11-wm/fvwm/fvwm-2.5.10-r4.ebuild b/x11-wm/fvwm/fvwm-2.5.10-r4.ebuild
index 0ea02841ba14..bea82a14c124 100644
--- a/x11-wm/fvwm/fvwm-2.5.10-r4.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.10-r4.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.10-r4.ebuild,v 1.3 2004/06/28 23:45:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.10-r4.ebuild,v 1.4 2004/07/15 01:12:44 agriffis Exp $
 
 inherit eutils flag-o-matic
 
@@ -41,13 +41,11 @@ DEPEND="${RDEPEND}
 	>=sys-apps/sed-4
 	dev-util/pkgconfig"
 
-S=${WORKDIR}/${P}
-
 src_unpack() {
 	unpack ${A}
 
-	# this patch enables fast translucent menus in fvwm..yummy! this is a 
-	# minor tweak of a patch posted to fvwm-user mailing list by Olivier 
+	# this patch enables fast translucent menus in fvwm..yummy! this is a
+	# minor tweak of a patch posted to fvwm-user mailing list by Olivier
 	# Chapuis in <20030827135125.GA6370@snoopy.folie>.
 	cd ${S}; epatch ${FILESDIR}/fvwm-2.5.9-translucent-menus.diff.gz
 
@@ -257,8 +255,8 @@ src_install() {
 		rm -rf ${D}/usr/bin/fvwm-perllib ${D}/usr/share/man/man1/fvwm-perllib.1
 	fi
 
-	# neat utility for testing fvwm behaviour on applications setting various 
-	# hints, creates a simple black window with configurable hints set. 
+	# neat utility for testing fvwm behaviour on applications setting various
+	# hints, creates a simple black window with configurable hints set.
 	if use debug; then
 		dobin ${S}/tests/hints/hints_test
 		newdoc ${S}/tests/hints/README README.hints
diff --git a/x11-wm/fvwm/fvwm-2.5.10-r5.ebuild b/x11-wm/fvwm/fvwm-2.5.10-r5.ebuild
index 211ade8bb74a..353b02fb3dda 100644
--- a/x11-wm/fvwm/fvwm-2.5.10-r5.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.10-r5.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.10-r5.ebuild,v 1.4 2004/06/28 23:45:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.10-r5.ebuild,v 1.5 2004/07/15 01:12:44 agriffis Exp $
 
 inherit eutils flag-o-matic
 
@@ -41,14 +41,13 @@ DEPEND="${RDEPEND}
 	>=sys-apps/sed-4
 	dev-util/pkgconfig"
 
-S=${WORKDIR}/${P}
 SFT=${WORKDIR}/FvwmTabs-v3.1
 
 src_unpack() {
 	unpack ${A}
 
-	# this patch enables fast translucent menus in fvwm..yummy! this is a 
-	# minor tweak of a patch posted to fvwm-user mailing list by Olivier 
+	# this patch enables fast translucent menus in fvwm..yummy! this is a
+	# minor tweak of a patch posted to fvwm-user mailing list by Olivier
 	# Chapuis in <20030827135125.GA6370@snoopy.folie>.
 	cd ${S}; epatch ${FILESDIR}/fvwm-2.5.9-translucent-menus.diff.gz
 
@@ -268,8 +267,8 @@ src_install() {
 		rm -rf ${D}/usr/bin/fvwm-perllib ${D}/usr/share/man/man1/fvwm-perllib.1
 	fi
 
-	# neat utility for testing fvwm behaviour on applications setting various 
-	# hints, creates a simple black window with configurable hints set. 
+	# neat utility for testing fvwm behaviour on applications setting various
+	# hints, creates a simple black window with configurable hints set.
 	if use debug; then
 		dobin ${S}/tests/hints/hints_test
 		newdoc ${S}/tests/hints/README README.hints
diff --git a/x11-wm/fvwm/fvwm-2.5.10-r6.ebuild b/x11-wm/fvwm/fvwm-2.5.10-r6.ebuild
index 26625095549d..83adc8eaaabb 100644
--- a/x11-wm/fvwm/fvwm-2.5.10-r6.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.10-r6.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.10-r6.ebuild,v 1.2 2004/07/10 11:17:10 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.10-r6.ebuild,v 1.3 2004/07/15 01:12:44 agriffis Exp $
 
 inherit eutils flag-o-matic
 
@@ -39,14 +39,13 @@ RDEPEND="readline? ( >=sys-libs/readline-4.1
 # XXX:	netpbm is used by FvwmScript-ScreenDump, worth a dependency?
 DEPEND="${RDEPEND} dev-util/pkgconfig"
 
-S=${WORKDIR}/${P}
 SFT=${WORKDIR}/FvwmTabs-v3.1
 
 src_unpack() {
 	unpack ${A}
 
-	# this patch enables fast translucent menus in fvwm..yummy! this is a 
-	# minor tweak of a patch posted to fvwm-user mailing list by Olivier 
+	# this patch enables fast translucent menus in fvwm..yummy! this is a
+	# minor tweak of a patch posted to fvwm-user mailing list by Olivier
 	# Chapuis in <20030827135125.GA6370@snoopy.folie>.
 	cd ${S}; epatch ${FILESDIR}/fvwm-2.5.9-translucent-menus.diff.gz
 
@@ -269,8 +268,8 @@ src_install() {
 		rm -rf ${D}/usr/bin/fvwm-perllib ${D}/usr/share/man/man1/fvwm-perllib.1
 	fi
 
-	# neat utility for testing fvwm behaviour on applications setting various 
-	# hints, creates a simple black window with configurable hints set. 
+	# neat utility for testing fvwm behaviour on applications setting various
+	# hints, creates a simple black window with configurable hints set.
 	if use debug; then
 		dobin ${S}/tests/hints/hints_test
 		newdoc ${S}/tests/hints/README README.hints
diff --git a/x11-wm/fvwm/fvwm-2.5.7-r5.ebuild b/x11-wm/fvwm/fvwm-2.5.7-r5.ebuild
index 2528d73a3e3a..1e5ead319d4e 100644
--- a/x11-wm/fvwm/fvwm-2.5.7-r5.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.7-r5.ebuild
@@ -1,12 +1,11 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.7-r5.ebuild,v 1.6 2004/06/28 23:45:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.7-r5.ebuild,v 1.7 2004/07/15 01:12:44 agriffis Exp $
 
 inherit gnuconfig
 
 IUSE="bidi cjk debug gnome gtk gtk2 imlib ncurses nls nosm noxpm perl png readline rplay stroke tcltk truetype xinerama"
 
-S=${WORKDIR}/${P}
 DESCRIPTION="An extremely powerful ICCCM-compliant multiple virtual desktop window manager"
 SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2
 		perl? ( mirror://gentoo/FvwmTabs-2.3.tar.gz )"
@@ -39,7 +38,7 @@ RDEPEND="readline? ( >=sys-libs/readline-4.1
 		virtual/x11"
 # XXX:	gtk2 perl bindings require dev-perl/gtk2-perl, worth a dependency?
 # XXX:	gtk perl bindings require dev-perl/gtk-perl, worth a dependency?
-# XXX:	netpbm is used by FvwmScript-ScreenDump...im assuming anyone with 
+# XXX:	netpbm is used by FvwmScript-ScreenDump...im assuming anyone with
 # 	`use noxpm` will not want them.
 DEPEND="${RDEPEND}
 	>=sys-apps/sed-4
@@ -50,7 +49,7 @@ DEPEND="${RDEPEND}
 src_unpack() {
 	unpack ${A}
 
-	use alpha && gnuconfig_update
+	gnuconfig_update
 
 	# CFLAGS containing comma (eg -mfpmath=sse,387) will break this, so change it for !
 	sed -i 's#\x27s,xCFLAGSx,$(CFLAGS),\x27#\x27s!xCFLAGSx!$(CFLAGS)!\x27#' ${S}/utils/Makefile.am
diff --git a/x11-wm/fvwm/fvwm-2.5.8-r6.ebuild b/x11-wm/fvwm/fvwm-2.5.8-r6.ebuild
index ce1b8d35056f..128de60de778 100644
--- a/x11-wm/fvwm/fvwm-2.5.8-r6.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.8-r6.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8-r6.ebuild,v 1.6 2004/06/28 23:45:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8-r6.ebuild,v 1.7 2004/07/15 01:12:44 agriffis Exp $
 
 inherit eutils flag-o-matic
 
@@ -39,19 +39,17 @@ RDEPEND="readline? ( >=sys-libs/readline-4.1
 		virtual/x11"
 # XXX:	gtk2 perl bindings require dev-perl/gtk2-perl, worth a dependency?
 # XXX:	gtk perl bindings require dev-perl/gtk-perl, worth a dependency?
-# XXX:	netpbm is used by FvwmScript-ScreenDump...im assuming anyone with 
+# XXX:	netpbm is used by FvwmScript-ScreenDump...im assuming anyone with
 # 	`use noxpm` will not want them.
 DEPEND="${RDEPEND}
 	>=sys-apps/sed-4
 	dev-util/pkgconfig"
 
-S=${WORKDIR}/${P}
-
 src_unpack() {
 	unpack ${A}
 
-	# this patch enables fast translucent menus in fvwm..yummy! this is a 
-	# minor tweak of a patch posted to fvwm-user mailing list by Olivier 
+	# this patch enables fast translucent menus in fvwm..yummy! this is a
+	# minor tweak of a patch posted to fvwm-user mailing list by Olivier
 	# Chapuis in <20030827135125.GA6370@snoopy.folie>.
 	cd ${S}; epatch ${FILESDIR}/fvwm-translucent-menus.diff.gz
 
@@ -60,10 +58,10 @@ src_unpack() {
 	# never got around to it.
 	cd ${S}; epatch ${FILESDIR}/disable-debug-statements.diff
 
-	# FvwmTabs uses /tmp/.fvwmtabs.state for storing state files by default, 
-	# this probably isnt a good idea security wise, allowing someone to do 
-	# damage with symlinks. It will also break if multiple users try using 
-	# the same location simultaneously...probably should use File::Temp, but 
+	# FvwmTabs uses /tmp/.fvwmtabs.state for storing state files by default,
+	# this probably isnt a good idea security wise, allowing someone to do
+	# damage with symlinks. It will also break if multiple users try using
+	# the same location simultaneously...probably should use File::Temp, but
 	# moving it into ~/.fvwmtabs.state will do for now.
 	if use perl; then
 		cd ${WORKDIR}; epatch ${FILESDIR}/fvwmtabs-insecure-tmp-handling.diff
@@ -76,9 +74,9 @@ src_unpack() {
 		eend $?
 	fi
 
-	# this patch from cvs, regarding a message sent to the fvwm-workers 
-	# mailing list in <20031111234845.A12314@deepblue.milkyway.com.au>, 
-	# perllib applications were getting destroyed before the ON_EXIT 
+	# this patch from cvs, regarding a message sent to the fvwm-workers
+	# mailing list in <20031111234845.A12314@deepblue.milkyway.com.au>,
+	# perllib applications were getting destroyed before the ON_EXIT
 	# handler could be invoked.
 	cd ${S}; epatch ${FILESDIR}/fvwm-2.5.8-perllib-disconnect.diff
 
@@ -279,8 +277,8 @@ src_install() {
 		rm -rf ${D}/usr/bin/fvwm-perllib ${D}/usr/share/man/man1/fvwm-perllib.1
 	fi
 
-	# neat utility for testing fvwm behaviour on applications setting various 
-	# hints, creates a simple black window with configurable hints set. 
+	# neat utility for testing fvwm behaviour on applications setting various
+	# hints, creates a simple black window with configurable hints set.
 	if use debug; then
 		dobin ${S}/tests/hints/hints_test
 		newdoc ${S}/tests/hints/README README.hints
-- 
cgit v1.2.3-65-gdbad