summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/swift/swift-1.7.4.ebuild')
-rw-r--r--sys-cluster/swift/swift-1.7.4.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-cluster/swift/swift-1.7.4.ebuild b/sys-cluster/swift/swift-1.7.4.ebuild
index a50cbc9..21ee191 100644
--- a/sys-cluster/swift/swift-1.7.4.ebuild
+++ b/sys-cluster/swift/swift-1.7.4.ebuild
@@ -71,6 +71,10 @@ python_install() {
if use proxy; then
newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
newins "etc/proxy-server.conf-sample" "proxy-server.conf"
+ if use memcache; then
+ sed '/depend/a\
+ need memcached' "/etc/swift/proxy-server.conf"
+ fi
fi
if use account; then
newinitd "${FILESDIR}/swift-account.initd" "swift-account"
@@ -85,9 +89,6 @@ python_install() {
newins "etc/object-server.conf-sample" "object-server.conf"
newins "etc/object-expirer.conf-sample" "object-expirer.conf"
fi
- if use memcache; then
- sed blah
- fi
fowners swift:swift "/etc/swift" || die "fowners failed"
}