summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/stardict-mueller7/stardict-mueller7-1.2.ebuild')
-rw-r--r--app-dicts/stardict-mueller7/stardict-mueller7-1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-dicts/stardict-mueller7/stardict-mueller7-1.2.ebuild b/app-dicts/stardict-mueller7/stardict-mueller7-1.2.ebuild
new file mode 100644
index 0000000..d8f1889
--- /dev/null
+++ b/app-dicts/stardict-mueller7/stardict-mueller7-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Stardict Mueller English to Russian Dictionary"
+HOMEPAGE="http://mueller-dic.chat.ru/"
+SRC_URI="http://mueller-dic.chat.ru/Mueller7accentGPL.tgz"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-dicts/makedict
+ gzip? ( app-text/dictd
+ app-arch/gzip )"
+
+S=${WORKDIR}/usr/local/share/dict
+
+src_compile() {
+ makedict -i mueller7 -o stardict Mueller7accentGPL.koi
+ use gzip && dictzip stardict-Mueller7GPL-2.4.2/Mueller7GPL.dict
+ use gzip && gzip stardict-Mueller7GPL-2.4.2/Mueller7GPL.idx
+}
+
+src_install() {
+ mkdir -p "${D}"/usr/share/stardict/dic
+ cp -r stardict-Mueller7GPL-2.4.2 "${D}"/usr/share/stardict/dic
+ chmod 555 "${D}"/usr/share/stardict/dic/stardict-Mueller7GPL-2.4.2
+ chown -R root:0 "${D}"/usr/share/stardict/dic
+}