aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2010-05-25 02:23:32 +0000
committerBenjamin Peterson <benjamin@python.org>2010-05-25 02:23:32 +0000
commit66556b0fb7a5078eee0af22fef58f349152c3101 (patch)
treebb31ceb18fe6b9797f936a4a4015c31230888dc8
parentset svn:eol-style (diff)
downloadcpython-66556b0fb7a5078eee0af22fef58f349152c3101.tar.gz
cpython-66556b0fb7a5078eee0af22fef58f349152c3101.tar.bz2
cpython-66556b0fb7a5078eee0af22fef58f349152c3101.zip
correct default docs
-rwxr-xr-xconfigure12
-rw-r--r--configure.in2
2 files changed, 7 insertions, 7 deletions
diff --git a/configure b/configure
index fdc353d272d..116c02abea8 100755
--- a/configure
+++ b/configure
@@ -1,5 +1,5 @@
#! /bin/sh
-# From configure.in Revision: 81004 .
+# From configure.in Revision: 81077 .
# Guess values for system-dependent variables and create Makefiles.
# Generated by GNU Autoconf 2.65 for python 2.7.
#
@@ -1388,7 +1388,7 @@ Optional Features:
--enable-big-digits[=BITS]
use big digits for Python longs [[BITS=30]]
--enable-unicode[=ucs[24]]
- Enable Unicode strings (default is yes)
+ Enable Unicode strings (default is ucs2)
Optional Packages:
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
@@ -1934,11 +1934,11 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
$ac_includes_default
- enum { N = $2 / 2 - 1 };
int
main ()
{
-static int test_array [1 - 2 * !(0 < ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1))];
+static int test_array [1 - 2 * !(enum { N = $2 / 2 - 1 };
+ 0 < ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1))];
test_array [0] = 0
;
@@ -1949,11 +1949,11 @@ if ac_fn_c_try_compile "$LINENO"; then :
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
$ac_includes_default
- enum { N = $2 / 2 - 1 };
int
main ()
{
-static int test_array [1 - 2 * !(($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)
+static int test_array [1 - 2 * !(enum { N = $2 / 2 - 1 };
+ ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)
< ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 2))];
test_array [0] = 0
diff --git a/configure.in b/configure.in
index adf054d03a2..98395d22410 100644
--- a/configure.in
+++ b/configure.in
@@ -3714,7 +3714,7 @@ fi
AC_MSG_CHECKING(what type to use for unicode)
dnl quadrigraphs "@<:@" and "@:>@" produce "[" and "]" in the output
AC_ARG_ENABLE(unicode,
- AS_HELP_STRING([--enable-unicode@<:@=ucs@<:@24@:>@@:>@], [Enable Unicode strings (default is yes)]),
+ AS_HELP_STRING([--enable-unicode@<:@=ucs@<:@24@:>@@:>@], [Enable Unicode strings (default is ucs2)]),
[],
[enable_unicode=yes])