summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2021-05-02 04:48:29 -0400
committerGitHub <noreply@github.com>2021-05-02 04:48:29 -0400
commit0cb33da1cc9cebb9b2d67d446feb1cfd36fe7f55 (patch)
treebce5eb56ba2ad215b3bf57422b4c08de8f9c3e1e /configure.ac
parentbpo-43908: Mark ssl, hash, and hmac types as immutable (GH-25792) (diff)
downloadcpython-0cb33da1cc9cebb9b2d67d446feb1cfd36fe7f55.tar.gz
cpython-0cb33da1cc9cebb9b2d67d446feb1cfd36fe7f55.tar.bz2
cpython-0cb33da1cc9cebb9b2d67d446feb1cfd36fe7f55.zip
bpo-44009: Provide "python3.x-intel64" for Apple Silicon Macs (GH-25804)
This allows reliably forcing macOS universal2 framework builds to run under Rosetta 2 Intel-64 emulation on Apple Silicon Macs if needed for testing or when universal2 wheels are not yet available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 221996a1de5..0ea9ecf6d6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,12 +220,14 @@ then
fi
AC_SUBST(LIPO_32BIT_FLAGS)
+AC_SUBST(LIPO_INTEL64_FLAGS)
AC_MSG_CHECKING(for --with-universal-archs)
AC_ARG_WITH(universal-archs,
AS_HELP_STRING([--with-universal-archs=ARCH],
- [specify the kind of universal binary that should be created. this option is
- only valid when --enable-universalsdk is set; options are:
- ("universal2", "32-bit", "64-bit", "3-way", "intel", "intel-32", "intel-64", or "all")
+ [specify the kind of macOS universal binary that should be created.
+ This option is only valid when --enable-universalsdk is set; options are:
+ ("universal2", "intel-64", "intel-32", "intel", "32-bit",
+ "64-bit", "3-way", or "all")
see Mac/README.rst]),
[
UNIVERSAL_ARCHS="$withval"
@@ -1874,6 +1876,7 @@ yes)
AC_MSG_RESULT($CC)
fi
+ LIPO_INTEL64_FLAGS=""
if test "${enable_universalsdk}"
then
case "$UNIVERSAL_ARCHS" in
@@ -1895,8 +1898,9 @@ yes)
universal2)
UNIVERSAL_ARCH_FLAGS="-arch arm64 -arch x86_64"
LIPO_32BIT_FLAGS=""
+ LIPO_INTEL64_FLAGS="-extract x86_64"
ARCH_RUN_32BIT="true"
- ;;
+ ;;
intel)
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch x86_64"
LIPO_32BIT_FLAGS="-extract i386"