aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-08-29 22:58:50 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-08-05 22:54:25 +0300
commitb51bd4a5bc55428bac6aa7ea9021ef080caa6f1f (patch)
tree9d61a9e554454a401de7c03a9e5019b81fe69d14
parentDisable ldconfig during install (diff)
downloadglibc-b51bd4a5bc55428bac6aa7ea9021ef080caa6f1f.tar.gz
glibc-b51bd4a5bc55428bac6aa7ea9021ef080caa6f1f.tar.bz2
glibc-b51bd4a5bc55428bac6aa7ea9021ef080caa6f1f.zip
Revert " * sysdeps/posix/getaddrinfo.c (gaih_inet): Only use gethostbyname4_r"
This reverts commit 8479f23aa1d5e5477a37f46823856bdafaedfa46. See for the background https://sourceware.org/bugzilla/show_bug.cgi?id=16826 https://bugs.gentoo.org/show_bug.cgi?id=600632 This makes tst-nss-files-hosts-multi fail. Disable it.
-rw-r--r--nss/Makefile1
-rw-r--r--sysdeps/posix/getaddrinfo.c9
2 files changed, 2 insertions, 8 deletions
diff --git a/nss/Makefile b/nss/Makefile
index 20c412c3e1..0be1325553 100644
--- a/nss/Makefile
+++ b/nss/Makefile
@@ -70,7 +70,6 @@ tests-container = \
# Tests which need libdl
ifeq (yes,$(build-shared))
tests += tst-nss-files-hosts-erange
-tests += tst-nss-files-hosts-multi
tests += tst-nss-files-hosts-getent
tests += tst-nss-files-alias-leak
tests += tst-nss-files-alias-truncated
diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
index ed04e564f9..ce9e0d342d 100644
--- a/sysdeps/posix/getaddrinfo.c
+++ b/sysdeps/posix/getaddrinfo.c
@@ -739,13 +739,8 @@ gaih_inet (const char *name, const struct gaih_service *service,
while (!no_more)
{
no_data = 0;
- nss_gethostbyname4_r *fct4 = NULL;
-
- /* gethostbyname4_r sends out parallel A and AAAA queries and
- is thus only suitable for PF_UNSPEC. */
- if (req->ai_family == PF_UNSPEC)
- fct4 = __nss_lookup_function (nip, "gethostbyname4_r");
-
+ nss_gethostbyname4_r *fct4
+ = __nss_lookup_function (nip, "gethostbyname4_r");
if (fct4 != NULL)
{
while (1)