aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Stellard <tstellar@redhat.com>2023-08-29 15:49:55 -0700
committerMichał Górny <mgorny@gentoo.org>2023-10-23 14:56:34 +0200
commitac9028d428b639d9002aa9d7d81c9a3842e2c44d (patch)
treee34f97de7ea18e9a9046a4f530bc5a72673830d7
parent[lld] Pass random.randint stop parameter as int. (diff)
downloadllvm-project-ac9028d428b639d9002aa9d7d81c9a3842e2c44d.tar.gz
llvm-project-ac9028d428b639d9002aa9d7d81c9a3842e2c44d.tar.bz2
llvm-project-ac9028d428b639d9002aa9d7d81c9a3842e2c44d.zip
compiler-rt: Fix FLOAT16 feature detectiongentoo-16.0.6-r2
CMAKE_TRY_COMPILE_TARGET_TYPE defaults to EXECUTABLE, which causes any feature detection code snippet without a main function to fail, so we need to make sure it gets explicitly set to STATIC_LIBRARY. Taken from https://github.com/llvm/llvm-project/pull/69842. Gentoo-Component: compiler-rt
-rw-r--r--compiler-rt/lib/builtins/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/compiler-rt/lib/builtins/CMakeLists.txt b/compiler-rt/lib/builtins/CMakeLists.txt
index 2fc70522895f..3cd193e2f5f8 100644
--- a/compiler-rt/lib/builtins/CMakeLists.txt
+++ b/compiler-rt/lib/builtins/CMakeLists.txt
@@ -12,7 +12,6 @@ if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
"at least 3.20.0 now to avoid issues in the future!")
endif()
- set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
project(CompilerRTBuiltins C ASM)
set(COMPILER_RT_STANDALONE_BUILD TRUE)
set(COMPILER_RT_BUILTINS_STANDALONE_BUILD TRUE)
@@ -57,6 +56,8 @@ if (COMPILER_RT_STANDALONE_BUILD)
ON)
endif()
+set(CMAKE_TRY_COMPILE_TARGET_TYPE STATIC_LIBRARY)
+
include(builtin-config-ix)
include(CMakePushCheckState)