summaryrefslogtreecommitdiff
path: root/polly
diff options
context:
space:
mode:
authorserge-sans-paille <sguelton@redhat.com>2020-04-18 08:14:52 +0200
committerserge-sans-paille <sguelton@redhat.com>2020-04-28 09:44:10 +0200
commite849e7a700907441ee82ace9d0a9555ae7eb9811 (patch)
tree9b2c09155f60c3528a66c433b270c627ad2221a6 /polly
parent[SystemZ] Fix test case. (diff)
downloadllvm-project-e849e7a700907441ee82ace9d0a9555ae7eb9811.tar.gz
llvm-project-e849e7a700907441ee82ace9d0a9555ae7eb9811.tar.bz2
llvm-project-e849e7a700907441ee82ace9d0a9555ae7eb9811.zip
Use components instead of libraries in Polly linkage step
As a side effect, this tests (and fix a bug) in the compiler extension handling of components. Differential Revision: https://reviews.llvm.org/D78358
Diffstat (limited to 'polly')
-rw-r--r--polly/lib/CMakeLists.txt71
1 files changed, 32 insertions, 39 deletions
diff --git a/polly/lib/CMakeLists.txt b/polly/lib/CMakeLists.txt
index e754a3103a12..2b9a77b93926 100644
--- a/polly/lib/CMakeLists.txt
+++ b/polly/lib/CMakeLists.txt
@@ -21,6 +21,34 @@ if (MSVC_IDE OR XCODE)
file(GLOB_RECURSE POLLY_HEADER_FILES "${POLLY_SOURCE_DIR}/include/polly/*.h")
endif ()
+set(POLLY_COMPONENTS
+ Support
+ Core
+ ScalarOpts
+ InstCombine
+ TransformUtils
+ Analysis
+ ipo
+ MC
+ Passes
+ Linker
+ IRReader
+ Analysis
+ # The libraries below are required for darwin: http://PR26392
+ BitReader
+ MCParser
+ Object
+ ProfileData
+ Target
+ Vectorize
+)
+
+# Polly-ACC requires the NVPTX backend to work. Ask LLVM about its libraries.
+if (GPU_CODEGEN)
+ # This call emits an error if they NVPTX backend is not enable.
+ list(APPEND POLLY_COMPONENTS NVPTX)
+endif ()
+
# Use an object-library to add the same files to multiple libs without requiring
# the sources them to be recompiled for each of them.
add_llvm_pass_plugin(Polly
@@ -71,6 +99,9 @@ add_llvm_pass_plugin(Polly
Transform/RewriteByReferenceParameters.cpp
Transform/ScopInliner.cpp
${POLLY_HEADER_FILES}
+
+ LINK_COMPONENTS
+ ${POLLY_COMPONENTS}
)
set_target_properties(obj.Polly PROPERTIES FOLDER "Polly")
set_target_properties(Polly PROPERTIES FOLDER "Polly")
@@ -99,45 +130,7 @@ if (GPU_CODEGEN)
target_link_libraries(Polly PUBLIC PollyPPCG)
endif ()
-
-# Polly-ACC requires the NVPTX backend to work. Ask LLVM about its libraries.
-set(nvptx_libs)
-if (GPU_CODEGEN)
- # This call emits an error if they NVPTX backend is not enable.
- llvm_map_components_to_libnames(nvptx_libs NVPTX)
-endif ()
-
-if (LLVM_LINK_LLVM_DYLIB AND NOT LLVM_POLLY_LINK_INTO_TOOLS)
- # The shlib/dylib contains all the LLVM components
- # (including NVPTX is enabled) already. Adding them to target_link_libraries
- # would cause them being twice in the address space
- # (their LLVM*.a/so and their copies in libLLVM.so)
- # which results in errors when the two instances try to register the same
- # command-line switches.
- target_link_libraries(Polly PUBLIC LLVM)
-else ()
- target_link_libraries(Polly PUBLIC
- LLVMSupport
- LLVMCore
- LLVMScalarOpts
- LLVMInstCombine
- LLVMTransformUtils
- LLVMAnalysis
- LLVMipo
- LLVMMC
- LLVMPasses
- LLVMLinker
- LLVMIRReader
- ${nvptx_libs}
- # The libraries below are required for darwin: http://PR26392
- LLVMBitReader
- LLVMMCParser
- LLVMObject
- LLVMProfileData
- LLVMTarget
- LLVMVectorize
- )
-
+if (NOT LLVM_LINK_LLVM_DYLIB AND NOT LLVM_POLLY_LINK_INTO_TOOLS)
# Polly-ACC requires the NVPTX target to be present in the executable it is linked to
set_property(TARGET bugpoint APPEND PROPERTY LINK_LIBRARIES LLVMTarget)
endif ()