aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorW. Trevor King <wking@tremily.us>2013-12-15 20:49:38 -0800
committerMatt Turner <mattst88@gentoo.org>2020-10-29 16:13:21 -0400
commit4c1595dae95a6a3bd9e29c8b09ca7f979ea344b6 (patch)
treec51d0b7681b98f30ebc873feb1282a3ca879422b
parentBuild ISO with Joliet directory information (diff)
downloadcatalyst-4c1595dae95a6a3bd9e29c8b09ca7f979ea344b6.tar.gz
catalyst-4c1595dae95a6a3bd9e29c8b09ca7f979ea344b6.tar.bz2
catalyst-4c1595dae95a6a3bd9e29c8b09ca7f979ea344b6.zip
Makefile: Cleanup doc/subarches.generated.xml
Since its addition in fa940f7 (Migrate man page to Asciidoc, generate list of subarches, add Makefile including "dist" target, 2011-06-24), doc/make_subarch_table_guidexml.py has also generated an XML version of the supported subarches. Add the XML file to DOC_SIDE_EFFECTS so it gets removed by `make clean`. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index c937df15..b359e8b7 100644
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,7 @@ MAN_PAGES = $(patsubst doc/%.txt,files/%,$(MAN_PAGE_SOURCES))
MAN_PAGE_INCLUDES = doc/subarches.generated.txt doc/targets.generated.txt
DOC_SOURCES = $(filter-out $(MAN_PAGE_SOURCES) $(MAN_PAGE_INCLUDES),$(wildcard doc/*.txt))
DOCS = $(patsubst doc/%.txt,files/%.html,$(DOC_SOURCES))
-DOC_SIDE_EFFECTS = files/docbook-xsl.css
+DOC_SIDE_EFFECTS = files/docbook-xsl.css doc/subarches.generated.xml
EXTRA_DIST = $(MAN_PAGES) $(DOCS) $(DOC_SIDE_EFFECTS)
GENERATED_FILES = $(MAN_PAGES) $(MAN_PAGE_INCLUDES) $(DOCS) $(DOC_SIDE_EFFECTS)
@@ -27,7 +27,7 @@ $(MAN_PAGES): files/%: doc/%.txt doc/asciidoc.conf Makefile catalyst | files
files/catalyst.1: doc/subarches.generated.txt | files
files/catalyst-spec.5: doc/subarches.generated.txt doc/targets.generated.txt | files
-doc/subarches.generated.txt: $(wildcard arch/*.toml) doc/make_subarch_table_guidexml.py
+doc/subarches.generated.txt doc/subarches.generated.xml: $(wildcard arch/*.toml) doc/make_subarch_table_guidexml.py
./doc/make_subarch_table_guidexml.py
doc/targets.generated.txt: doc/make_target_table.py $(wildcard catalyst/targets/*.py)