summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-29 10:27:10 +0100
committerSam James <sam@gentoo.org>2022-04-17 12:53:05 +0100
commit085bde903b9e684c3c1160e4df912bea9a660997 (patch)
treec4f5e6e9f2422e869ca5bc0b944520d451001282 /configure.ac
parentImport Ghostscript 9.55 (diff)
downloadghostscript-gpl-patches-085bde903b9e684c3c1160e4df912bea9a660997.tar.gz
ghostscript-gpl-patches-085bde903b9e684c3c1160e4df912bea9a660997.tar.bz2
ghostscript-gpl-patches-085bde903b9e684c3c1160e4df912bea9a660997.zip
Import Ghostscript 9.56.0ghostscript-9.56
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac118
1 files changed, 27 insertions, 91 deletions
diff --git a/configure.ac b/configure.ac
index 36b51f57..e955b2f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,21 +49,6 @@ ARCH_AUTOCONF_HEADER=arch-config/arch_autoconf.h
ARCH_AUTOCONF_HEADER_PROTO=arch/arch_autoconf.h.in
dnl --------------------------------------------------
-dnl List of non-threadsafe devices
-dnl defined at the top of the file for ease of access
-dnl --------------------------------------------------
-
-NTS_DEVS='opvp oprp'
-NTS_DEVS="$NTS_DEVS uniprint"
-NTS_DEVS="$NTS_DEVS x11 x11alpha"
-NTS_DEVS="$NTS_DEVS pcl3 hpdjplus hpdjportable hpdj310 hpdj320 hpdj340 hpdj400 hpdj500 hpdj500c hpdj510 hpdj520 hpdj540 hpdj550c hpdj560c hpdj600 hpdj660c hpdj670c hpdj680c hpdj690c hpdj850c hpdj855c hpdj870c hpdj890c hpdj1120c"
-
-# We use this to store a list of devices we have excluded
-# and emit a warning on completion.
-NTS_EXCLUDES=""
-
-
-dnl --------------------------------------------------
dnl Local utilities
dnl --------------------------------------------------
@@ -285,21 +270,21 @@ CFLAGS_LARGEFILE=""
case $host in
*-linux*|*-gnu)
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
CC_OPT_FLAGS_TO_TRY="-O2 -DNDEBUG"
CC_DBG_FLAGS_TO_TRY="-gdwarf-2 -g3 -O0"
CC_VISIBILITY_FLAGS_TO_TRY="-fvisibility=hidden"
fi
;;
*bsd*)
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
CC_OPT_FLAGS_TO_TRY="-O2 -DNDEBUG"
CC_DBG_FLAGS_TO_TRY="-gdwarf-2 -g3 -O0"
CC_VISIBILITY_FLAGS_TO_TRY="-fvisibility=hidden"
fi
;;
*-darwin*)
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
CC_OPT_FLAGS_TO_TRY="-O2 -DNDEBUG"
CC_DBG_FLAGS_TO_TRY="-gdwarf-2 -g3 -O0"
CC_VISIBILITY_FLAGS_TO_TRY="-fvisibility=hidden"
@@ -307,7 +292,7 @@ case $host in
SET_DT_SONAME=""
;;
*-mingw*|*-msys*)
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
CC_OPT_FLAGS_TO_TRY="-O2 -DNDEBUG"
CC_DBG_FLAGS_TO_TRY="-gdwarf-2 -g3 -O0"
CC_VISIBILITY_FLAGS_TO_TRY="-fvisibility=hidden"
@@ -321,7 +306,7 @@ case $host in
if test $GCC = no; then
SET_DT_SONAME="-h "
fi
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
CC_OPT_FLAGS_TO_TRY="-O2 -DNDEBUG"
CC_DBG_FLAGS_TO_TRY="-gdwarf-2 -g3 -O0"
CC_VISIBILITY_FLAGS_TO_TRY="-fvisibility=hidden"
@@ -330,7 +315,7 @@ case $host in
fi
;;
*-aix*)
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
CC_OPT_FLAGS_TO_TRY="-O2 -DNDEBUG"
CC_DBG_FLAGS_TO_TRY="-gdwarf-2 -g3 -O0"
SET_DT_SONAME="so"
@@ -342,7 +327,7 @@ esac
AC_SUBST(SET_DT_SONAME)
-if test $GCC = yes; then
+if test x"$GCC" = x"yes"; then
cflags_to_try="-Wall -Wstrict-prototypes -Wundef \
-Wmissing-declarations -Wmissing-prototypes -Wwrite-strings \
-fno-strict-aliasing -Werror=declaration-after-statement \
@@ -563,15 +548,6 @@ CFLAGS=$save_cflags
dnl --------------------------------------------------
-dnl Enable thread safe build
-dnl --------------------------------------------------
-AC_ARG_ENABLE([threadsafe], AS_HELP_STRING([--enable-threadsafe],
- [enable a thread safe build - NOTE: this will exclude non-threadsafe devices]))
-if test x$enable_threadsafe = xyes ; then
- CFLAGS="-DGS_THREADSAFE"
-fi
-
-dnl --------------------------------------------------
dnl Check for headers
dnl --------------------------------------------------
@@ -1476,14 +1452,14 @@ else
# Building on PPC with gcc, disable libpng's PPC specific
# optimizations: we don't include the source file for it
# and it only applies to reading, which we don't use.
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
CFLAGS="$CFLAGS -DPNG_POWERPC_VSX_OPT=0"
fi
;;
*arm64*|*aarch64*)
# Building on arm64 with gcc, disable libpng's neon
# optimizations.
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
CFLAGS="$CFLAGS -DPNG_ARM_NEON_OPT=0"
fi
;;
@@ -1787,6 +1763,7 @@ CUPSDATA=""
CUPSVERSION="0"
CUPSPDFTORASTER="0"
CUPS_DIR=""
+LIB_CUPS_DIR="src"
cups_hard_fail=0
@@ -1866,6 +1843,13 @@ if ( test -f $srcdir/cups/gdevcups.c ); then
CUPSDEV="$CUPSDEV pwgraster"
fi
+ # appleraster support arrived in cups 2.2.2, so with
+ # API version 2.2 we do not necessarily have it, but
+ # 2.3 has it for sure
+ if test "$CUPSAPIVERSION" ">" "2.2" ; then
+ CUPSDEV="$CUPSDEV appleraster urf"
+ fi
+
CUPSVERSION="`$CUPSCONFIG --version`"
LCUPSINCLUDE="include \$(GLSRCDIR)/lcups.mak"
@@ -1892,6 +1876,7 @@ if ( test -f $srcdir/cups/gdevcups.c ); then
LCUPSINCLUDE="include \$(GLSRCDIR)/lcups.mak"
LCUPSIINCLUDE="include \$(GLSRCDIR)/lcupsi.mak"
CUPSDEV="cups pwgraster"
+ LIB_CUPS_DIR=$CUPS_DIR
fi
fi
fi
@@ -1906,6 +1891,7 @@ AC_SUBST(CUPSSERVERROOT)
AC_SUBST(CUPSDATA)
AC_SUBST(CUPSINSTALL)
AC_SUBST(CUPS_DIR)
+AC_SUBST(LIB_CUPS_DIR)
AC_SUBST(SHARELCUPS)
AC_SUBST(SHARELCUPSI)
@@ -2094,7 +2080,7 @@ AC_CHECK_FUNCS([fseeko], [CFLAGS_OPJ_HAVE_FSEEKO="-DOPJ_HAVE_FSEEKO=1"], [CFLAGS
JPX_SSE_CFLAGS=""
if test "x$HAVE_SSE2" = "x" ; then
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
JPX_SSE_CFLAGS="-U__SSE__"
fi
fi
@@ -2632,7 +2618,7 @@ JPEG_DEVS='jpeg jpeggray jpegcmyk'
PCX_DEVS='pcxmono pcxgray pcx16 pcx256 pcx24b pcxcmyk'
PBM_DEVS='pbm pbmraw pgm pgmraw pgnm pgnmraw pnm pnmraw ppm ppmraw pkm pkmraw pksm pksmraw pam pamcmyk4 pamcmyk32 plan plang planm planc plank'
-PS_DEVS='psdf psdcmyk psdrgb psdcmyk16 psdrgb16 pdfwrite ps2write eps2write bbox txtwrite inkcov ink_cov psdcmykog fpng pdfimage8 pdfimage24 pdfimage32 PCLm'
+PS_DEVS='psdf psdcmyk psdrgb psdcmyk16 psdrgb16 psdcmyktags psdcmyktags16 pdfwrite ps2write eps2write bbox txtwrite inkcov ink_cov psdcmykog fpng pdfimage8 pdfimage24 pdfimage32 PCLm PCLm8'
# Handle --with-extract-dir=EXTRACT_DIR - build extract library and docxwrite
# device.
@@ -2805,51 +2791,6 @@ while test -n "$drivers"; do
esac
done
-if test x$enable_threadsafe = xyes; then
-
- for ntsdev in $NTS_DEVS ; do
- NTS_EXCLUDES="$(echo \"$P_DEVS0{[@]:0}\" | grep -o $ntsdev) $NTS_EXCLUDES"
- P_DEVS0=`echo $P_DEVS0 | sed "s/\b$ntsdev\b//g"`
- done
-
- for ntsdev in $NTS_DEVS ; do
- NTS_EXCLUDES="$(echo \"$F_DEVS0{[@]:0}\" | grep -o $ntsdev) $NTS_EXCLUDES"
- F_DEVS0=`echo $F_DEVS0 | sed "s/\b$ntsdev\b//g"`
- done
-
- for ntsdev in $NTS_DEVS ; do
- NTS_EXCLUDES="$(echo \"$CUPS_DEVS0{[@]:0}\" | grep -o $ntsdev) $NTS_EXCLUDES"
- CUPS_DEVS0=`echo $CUPS_DEVS0 | sed "s/\b$ntsdev\b//g"`
- done
-
- for ntsdev in $NTS_DEVS ; do
- NTS_EXCLUDES="$(echo \"$XPS_DEVS0{[@]:0}\" | grep -o $ntsdev) $NTS_EXCLUDES"
- XPS_DEVS0=`echo $XPS_DEVS0 | sed "s/\b$ntsdev\b//g"`
- done
-
- for ntsdev in $NTS_DEVS ; do
- NTS_EXCLUDES="$(echo \"$IJS_DEVS0{[@]:0}\" | grep -o $ntsdev) $NTS_EXCLUDES"
- IJS_DEVS0=`echo $IJS_DEVS0 | sed "s/\b$ntsdev\b//g"`
- done
-
- for ntsdev in $NTS_DEVS ; do
- NTS_EXCLUDES="$(echo \"$PNG_DEVS0{[@]:0}\" | grep -o $ntsdev) $NTS_EXCLUDES"
- PNG_DEVS0=`echo $PNG_DEVS0 | sed "s/\b$ntsdev\b//g"`
- done
-
- for ntsdev in $NTS_DEVS ; do
- NTS_EXCLUDES="$(echo \"$X11_DEVS0{[@]:0}\" | grep -o $ntsdev) $NTS_EXCLUDES"
- X11_DEVS0=`echo $X11_DEVS0 | sed "s/\b$ntsdev\b//g"`
- done
-
- for ntsdev in $NTS_DEVS ; do
- NTS_EXCLUDES="$(echo \"$JBIG2_DEVS{[@]:0}\" | grep -o $ntsdev) $NTS_EXCLUDES"
- JBIG2_DEVS=`echo $JBIG2_DEVS | sed "s/\b$ntsdev\b//g"`
- done
-
- NTS_EXCLUDES=`echo "$NTS_EXCLUDES" | tr " " "\n" | sort | uniq | tr "\n" " "`
-fi # x$enable_threadsafe = xyes
-
noncontribmakefiles=`find $srcdir -name '*.mak' -print | grep -v '/contrib/'`
# No need to include opvp/oprp driver without iconv/libiconv.
@@ -2952,7 +2893,7 @@ AC_ARG_ENABLE([hidden-visibility],
[hide all shared library symbols which are not part of its public API]),
[hide_symbols=yes])
-if test x$hide_symbols = xyes -a $GCC = yes; then
+if test x$hide_symbols = xyes -a x"$GCC" = x"yes"; then
attr_default="__attribute__((visibility(\\\"default\\\")))"
attr_hidden="__attribute__((visibility(\\\"hidden\\\")))"
fi
@@ -2965,7 +2906,7 @@ case $host in
XPS_DYNAMIC_LDFLAGS="-shared -Wl,\$(LD_SET_DT_SONAME)\$(LDFLAGS_SO_PREFIX)\$(XPS_SONAME_MAJOR)"
PDL_DYNAMIC_LDFLAGS="-shared -Wl,\$(LD_SET_DT_SONAME)\$(LDFLAGS_SO_PREFIX)\$(GPDL_SONAME_MAJOR)"
PDF_DYNAMIC_LDFLAGS="-shared -Wl,\$(LD_SET_DT_SONAME)\$(LDFLAGS_SO_PREFIX)\$(PDF_SONAME_MAJOR)"
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
# GCC high level flag
DYNAMIC_LIBS="-rdynamic"
else
@@ -3052,7 +2993,7 @@ case $host in
SO_LIB_EXT=".dylib"
;;
*-sun*|*-solaris*)
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
DYNAMIC_CFLAGS="-fPIC $DYNAMIC_CFLAGS"
else
DYNAMIC_CFLAGS="-KPIC $DYNAMIC_CFLAGS"
@@ -3072,7 +3013,7 @@ case $host in
SO_LIB_EXT=".so"
;;
*-aix*)
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
DYNAMIC_CFLAGS="-fPIC $DYNAMIC_CFLAGS"
GCFLAGS="-Wl,-brtl -D_LARGE_FILES $GCFLAGS"
GS_DYNAMIC_LDFLAGS="-shared -Wl,-brtl,-G -fPIC"
@@ -3094,7 +3035,7 @@ case $host in
esac
if test x$hide_symbols = xyes ; then
- if test $GCC = yes; then
+ if test x"$GCC" = x"yes"; then
DYNAMIC_CFLAGS="$DYNAMIC_CFLAGS -fvisibility=hidden"
fi
DYNAMIC_CFLAGS="$DYNAMIC_CFLAGS -DGSDLLEXPORT=\"$attr_default\""
@@ -3559,7 +3500,7 @@ AC_SUBST(VERSIONED_PATH)
# NOTE: Strict aliasing can cause some parts
# of Ghostscript to malfunction.
# --------------------------------------------------
-if test $GCC = yes; then
+if test x"$GCC" = x"yes"; then
AC_MSG_CHECKING([whether to explicitly disable strict aliasing])
CFLAGS_backup="$CFLAGS"
CFLAGSAUX_backup="$CFLAGSAUX"
@@ -3762,11 +3703,6 @@ if test "x$AFS" = "x1"; then
AC_MSG_WARN([Support for this will be removed in a future release])
fi
-if test "x$NTS_EXCLUDES" != "x" ; then
- AC_MSG_WARN([Due to the --enable-threadsafe option, the following devices have been excluded because they are not threadsafe:])
- echo "$NTS_EXCLUDES"
-fi
-
if test x"$OCR_DEVS_WARNING_LINE1" != x"" ; then
echo ""
AC_MSG_WARN([$OCR_DEVS_WARNING_LINE1])