From fd9c0342503dd70838f2ecc75434d76349304079 Mon Sep 17 00:00:00 2001 From: Ulrich Müller Date: Mon, 29 Apr 2024 18:28:46 +0200 Subject: Fix internal references MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit Internal links referring to sections were broken by the previous "Sentence case devmanual" commit. Signed-off-by: Ulrich Müller --- appendices/common-problems/text.xml | 8 ++++---- appendices/contributors/text.xml | 8 ++++---- appendices/devbook-guide/text.xml | 14 +++++++------- archs/alpha/text.xml | 2 +- archs/amd64/text.xml | 17 +++++++++-------- archs/mips/text.xml | 2 +- archs/sparc/text.xml | 4 ++-- ebuild-maintenance/git/text.xml | 2 +- ebuild-writing/eapi/text.xml | 9 +++++---- ebuild-writing/file-format/text.xml | 4 ++-- ebuild-writing/functions/pkg_nofetch/text.xml | 2 +- .../functions/src_compile/build-environment/text.xml | 2 +- ebuild-writing/functions/src_test/text.xml | 2 +- ebuild-writing/functions/text.xml | 6 +++--- ebuild-writing/misc-files/metadata/text.xml | 4 ++-- ebuild-writing/misc-files/patches/text.xml | 4 ++-- ebuild-writing/use-conditional-code/text.xml | 2 +- ebuild-writing/user-submitted/text.xml | 2 +- ebuild-writing/variables/text.xml | 2 +- eclass-writing/text.xml | 2 +- function-reference/build-functions/text.xml | 2 +- function-reference/query-functions/text.xml | 4 ++-- function-reference/sandbox-functions/text.xml | 2 +- general-concepts/autotools/text.xml | 2 +- general-concepts/dependencies/text.xml | 4 ++-- general-concepts/ebuild-revisions/text.xml | 4 ++-- general-concepts/manifest/text.xml | 2 +- general-concepts/mirrors/text.xml | 3 ++- general-concepts/sandbox/text.xml | 2 +- general-concepts/slotting/text.xml | 4 ++-- general-concepts/tree/text.xml | 2 +- keywording/text.xml | 2 +- profiles/categories/text.xml | 2 +- profiles/use.mask/text.xml | 2 +- quickstart/text.xml | 7 ++++--- tools-reference/bash/text.xml | 2 +- tools-reference/text.xml | 2 +- 37 files changed, 75 insertions(+), 71 deletions(-) diff --git a/appendices/common-problems/text.xml b/appendices/common-problems/text.xml index 84bb610..6ebc098 100644 --- a/appendices/common-problems/text.xml +++ b/appendices/common-problems/text.xml @@ -59,8 +59,8 @@ in use, there are various alternatives: Usually when any of the above are used in global scope, it is to manipulate a version or program name string. These should be avoided in favour of pure bash constructs. The built-in helpers of EAPI 7 are useful here. See - - and . + + and .
has_version, best_version @@ -101,7 +101,7 @@ for security reasons. If this message is shown, you have a couple of options:
  • Use append-ldflags (see - ) + ) to add -Wl,-z,now. This will affect all binaries installed, not just the setXid ones.
  • @@ -131,7 +131,7 @@ inheritance occurring. Most commonly:
  • When working with eclasses in an overlay with a stale cache. See . + link="::general-concepts/overlay/#Overlay and eclasses"/>.
  • When working with a stale Portage cache. diff --git a/appendices/contributors/text.xml b/appendices/contributors/text.xml index 2808df1..da7fe3b 100644 --- a/appendices/contributors/text.xml +++ b/appendices/contributors/text.xml @@ -13,7 +13,7 @@ This page lists the contributions to the Gentoo Development Guide: Main Content - + @@ -23,7 +23,7 @@ This page lists the contributions to the Gentoo Development Guide: , - + @@ -33,7 +33,7 @@ This page lists the contributions to the Gentoo Development Guide: , - + @@ -123,7 +123,7 @@ Misc Search functionality - + , diff --git a/appendices/devbook-guide/text.xml b/appendices/devbook-guide/text.xml index 243017d..5c4aec7 100644 --- a/appendices/devbook-guide/text.xml +++ b/appendices/devbook-guide/text.xml @@ -533,12 +533,12 @@ here syndrome as recommended by the

    DevBook XML makes it really easy to reference other parts of the document using hyperlinks. You can create a link pointing to another chapter, like -Ebuild File Format, by typing -<uri link="::ebuild-writing/file-format/">Ebuild File -Format</uri>, i.e., two colons followed by the relative path from +Ebuild file format, by typing +<uri link="::ebuild-writing/file-format/">Ebuild file +format</uri>, i.e. two colons followed by the relative path from the root node. To refer to a section in another chapter, like -First Ebuild, type -<uri link="::quickstart/#First Ebuild">First Ebuild</uri>. +First ebuild, type +<uri link="::quickstart/#First ebuild">First ebuild</uri>.

    @@ -546,9 +546,9 @@ If the link target's chapter (or section etc.) title is to be used as the link text, an empty <uri> element can be used. As a matter of fact, I could have written the two examples above in more compact form: <uri link="::ebuild-writing/file-format/"/> and -<uri link="::quickstart/#First Ebuild"/> render as +<uri link="::quickstart/#First ebuild"/> render as and -, respectively. +, respectively.

    diff --git a/archs/alpha/text.xml b/archs/alpha/text.xml index f068317..9d0500e 100644 --- a/archs/alpha/text.xml +++ b/archs/alpha/text.xml @@ -87,7 +87,7 @@ which the compiler was built.

    The -mieee flag should always be used unless you have a deep knowledge of the Alpha architecture, so the comments on - are + are really important on Alpha.

    diff --git a/archs/amd64/text.xml b/archs/amd64/text.xml index 4f3b7da..05cce5f 100644 --- a/archs/amd64/text.xml +++ b/archs/amd64/text.xml @@ -123,7 +123,7 @@ or omitting any bit-width option will default to producing 64-bit code. If you've chosen a multilib profile, glibc will be built twice, once 64-bit and once 32-bit. This is because nearly every application links against glibc. To understand how this is done in the ebuild, read -. +.

    @@ -277,9 +277,9 @@ This is what /usr/include/asm/types.h looks like on an AMD64 box: As you can see, this is just a wrapper that decides which file you need depending on the parameter -D given to gcc. You'll probably run into some troubles if you try to compile something by hand and forget to append --D__x86_64__ to your CFLAGS. Of course, this is not necessary when -using Portage. For an explanation, see the -section. +-D__x86_64__ to your CFLAGS. Of course, this is +not necessary when using Portage. For an explanation, see the + section.

    @@ -291,10 +291,11 @@ section.

    Whenever Portage builds something on amd64, it has to decide whether it should -be 32-bit or 64-bit. As stated in -the __i386__ or __x86_64__ respectively, is needed in CDEFINE. -Also, gcc has to know what code it should produce, therefore -m32 or -m64 -must be appended to CFLAGS. This is done via profile.bashrc. All you need to do +be 32-bit or 64-bit. As stated in + the __i386__ or +__x86_64__ respectively, is needed in CDEFINE. Also, gcc has to +know what code it should produce, therefore -m32 or -m64 must be +appended to CFLAGS. This is done via profile.bashrc. All you need to do if you want to build a package 32-bit is to set ABI=x86.

    diff --git a/archs/mips/text.xml b/archs/mips/text.xml index 141664a..9e4ca16 100644 --- a/archs/mips/text.xml +++ b/archs/mips/text.xml @@ -70,7 +70,7 @@ between these, talk to the MIPS team.

    Because CFLAGS are sometimes used to specify ISA and ABI information, it is vital that packages honour this setting. See -. +.

    diff --git a/archs/sparc/text.xml b/archs/sparc/text.xml index fccf53c..c828e83 100644 --- a/archs/sparc/text.xml +++ b/archs/sparc/text.xml @@ -55,7 +55,7 @@ buses. This section is in addition to the guidelines in -. It discusses +. It discusses additional requirements for the SPARC architecture. @@ -116,7 +116,7 @@ code. Depending upon the application, this can be anywhere up to five times slower than v9 code when running on an UltraSparc cryptographic and graphics applications which make heavy use of integer multiplication and division are especially badly hit. For this reason, the comments in - + are especially important on SPARC.

    diff --git a/ebuild-maintenance/git/text.xml b/ebuild-maintenance/git/text.xml index 82967cc..6ad3837 100644 --- a/ebuild-maintenance/git/text.xml +++ b/ebuild-maintenance/git/text.xml @@ -142,7 +142,7 @@ used. The valid uses of git include: Whenever pkgdev is not used to commit, you need to manually verify all packages affected by the commit using pkgcheck scan --commits. Also, when using git manually, you must perform a manual sign-off to the - using + using the -s or --signoff option with your git commit commands. Make sure you have read and understand the actual certificate.

    diff --git a/ebuild-writing/eapi/text.xml b/ebuild-writing/eapi/text.xml index f470676..26795cf 100644 --- a/ebuild-writing/eapi/text.xml +++ b/ebuild-writing/eapi/text.xml @@ -70,9 +70,10 @@ is the best. Using the features of the latest EAPI is encouraged.

    Gentoo policy is to support upgrades for installations at least a year old -with no/little intervention and up to two years old with minor intervention. To -achieve this, developers must avoid using the latest EAPI in ebuilds within -the @system set (see ) +with no/little intervention and up to two years old with minor intervention. +To achieve this, developers must avoid using the latest EAPI in ebuilds within +the @system set +(see ) or its dependencies.

    @@ -603,7 +604,7 @@ installation targets.
  • ver_test compares two versions
  • - See + See for examples of common uses or an in-depth look diff --git a/ebuild-writing/file-format/text.xml b/ebuild-writing/file-format/text.xml index aa7bb72..bca3dad 100644 --- a/ebuild-writing/file-format/text.xml +++ b/ebuild-writing/file-format/text.xml @@ -116,7 +116,7 @@ Overall, this gives us a filename like libfoo-1.2.5b_pre5-r2.ebuild.

    -The +The EAPI 7 version commands may be used to manipulate and extract ebuild version components.

    @@ -146,7 +146,7 @@ for this is $(upcoming-version)_preYYYYMMDD.

    The policy for so-called live ebuilds -(see ) +(see ) is to use 9999 as the version (or as the last version component). For packages with more than 4 digits e.g. YYYYMMDD format, 99999999 is an acceptable alternative. diff --git a/ebuild-writing/functions/pkg_nofetch/text.xml b/ebuild-writing/functions/pkg_nofetch/text.xml index fdf4639..292c447 100644 --- a/ebuild-writing/functions/pkg_nofetch/text.xml +++ b/ebuild-writing/functions/pkg_nofetch/text.xml @@ -68,7 +68,7 @@ be referenced.

    This function is only triggered for packages which have RESTRICT="fetch" -(see ) +(see ) set, and only if one or more components listed in SRC_URI are not already available in the distfiles directory.

    diff --git a/ebuild-writing/functions/src_compile/build-environment/text.xml b/ebuild-writing/functions/src_compile/build-environment/text.xml index a9fc035..de9bea7 100644 --- a/ebuild-writing/functions/src_compile/build-environment/text.xml +++ b/ebuild-writing/functions/src_compile/build-environment/text.xml @@ -18,7 +18,7 @@ Except where otherwise specified, any function which operates on

    Ebuilds must not simply ignore user CFLAGS, CXXFLAGS or LDFLAGS see -. +.

    diff --git a/ebuild-writing/functions/src_test/text.xml b/ebuild-writing/functions/src_test/text.xml index 04d180c..793e99f 100644 --- a/ebuild-writing/functions/src_test/text.xml +++ b/ebuild-writing/functions/src_test/text.xml @@ -72,7 +72,7 @@ to run it. Sometimes the package will need additional dependencies for this, i.e., dependencies that are only required to run the test suite. Such test-only dependencies should be specified in DEPEND or BDEPEND behind a USE flag; often, the test USE flag will be used for this. Please refer to the -section on +section on for more information.

    diff --git a/ebuild-writing/functions/text.xml b/ebuild-writing/functions/text.xml index 0c1fbd6..c5a6cbc 100644 --- a/ebuild-writing/functions/text.xml +++ b/ebuild-writing/functions/text.xml @@ -60,12 +60,12 @@ Downloading a package's source happens before any of these phases, so emerge --fetchonly should perform all the network access you need (unless you're using live ebuilds). Network access outside of this would not be cached locally (e.g. in ${DISTDIR}, see -), +), which makes it hard to have reproducible builds (see -). +). Avoid network access in any phase by using local files, extending SRC_URI (see -), etc. +), etc.

    diff --git a/ebuild-writing/misc-files/metadata/text.xml b/ebuild-writing/misc-files/metadata/text.xml index cde4364..04a4164 100644 --- a/ebuild-writing/misc-files/metadata/text.xml +++ b/ebuild-writing/misc-files/metadata/text.xml @@ -114,7 +114,7 @@ metadata.xml: This tag contains a description for a category or a package. For packages, it is used to augment the - + DESCRIPTION field in the ebuilds themselves. This tag has two optional subtags: <pkg> and <cat>. @@ -302,7 +302,7 @@ There are also some attributes that can be used with these tags: When this attribute is required on the <flag> tag, it simply contains the name of the USE flag. For the <slot> tag, it specifies the - + slot name to which it applies. A slot name of * allows for a single <slot> tag to match all the slots of a package, in which case no other slot tags may be present. diff --git a/ebuild-writing/misc-files/patches/text.xml b/ebuild-writing/misc-files/patches/text.xml index 239fd1b..862910c 100644 --- a/ebuild-writing/misc-files/patches/text.xml +++ b/ebuild-writing/misc-files/patches/text.xml @@ -25,13 +25,13 @@ number in the patch name as a suffix to the version part

    Larger patches should be - + mirrored, preferably on the Gentoo Infrastructure. When mirroring patches, choosing a name that will not cause conflicts is important — the ${P} prefix is highly recommended here. Mirrored patches are often compressed with xz or bzip2. Remember to list these patches in SRC_URI. Please -see +see for more information.

    diff --git a/ebuild-writing/use-conditional-code/text.xml b/ebuild-writing/use-conditional-code/text.xml index 57ea99a..cb818a2 100644 --- a/ebuild-writing/use-conditional-code/text.xml +++ b/ebuild-writing/use-conditional-code/text.xml @@ -21,7 +21,7 @@ occasionally seen in older code must not be used. This is because, since die will not work as expected within a subshell, so code in the form use foo && ( blah ; blah ) should be avoided in favour of a proper if -statement. See . +statement. See . diff --git a/ebuild-writing/user-submitted/text.xml b/ebuild-writing/user-submitted/text.xml index 15576fb..9e2bc1c 100644 --- a/ebuild-writing/user-submitted/text.xml +++ b/ebuild-writing/user-submitted/text.xml @@ -24,7 +24,7 @@ The user-submitted ebuild must not contain custom headers like this: Such information should be included in the git commit message instead. The use of tags such as Suggested-By: or Reported-By: in the commit message, as explained in the - + commit message format section, is highly encouraged. Note that ebuilds received in the form of git patches or pull requests will have the user as the commit author by default, in which case diff --git a/ebuild-writing/variables/text.xml b/ebuild-writing/variables/text.xml index 6b8565b..97e5995 100644 --- a/ebuild-writing/variables/text.xml +++ b/ebuild-writing/variables/text.xml @@ -676,7 +676,7 @@ Finally, to state "at least one of foo, bar, or baz must be set": REQUIRED_USE="|| ( foo bar baz )" -See section +See section for when (and when not) to use REQUIRED_USE. diff --git a/eclass-writing/text.xml b/eclass-writing/text.xml index d93e2b0..8c4c910 100644 --- a/eclass-writing/text.xml +++ b/eclass-writing/text.xml @@ -10,7 +10,7 @@ This section provides a brief introduction to eclass authoring. You should reread the - + and sections before continuing. diff --git a/function-reference/build-functions/text.xml b/function-reference/build-functions/text.xml index 09e6053..5e7b28d 100644 --- a/function-reference/build-functions/text.xml +++ b/function-reference/build-functions/text.xml @@ -34,7 +34,7 @@ during the unpack and compile stages. Wrapper for ./configure. Passes on all args. Will abort (via die) should configure fail. - See + See for details. diff --git a/function-reference/query-functions/text.xml b/function-reference/query-functions/text.xml index ec7e069..529bb77 100644 --- a/function-reference/query-functions/text.xml +++ b/function-reference/query-functions/text.xml @@ -131,8 +131,8 @@ query variables and similar state. True if pkg (can include - and - ) + and + ) is installed. Example: has_version "=app-editors/nano-2.5.3[nls,spell]". (EAPI=7) An option may also be specified to query certain types of dependencies. diff --git a/function-reference/sandbox-functions/text.xml b/function-reference/sandbox-functions/text.xml index 86cf05c..fa68d07 100644 --- a/function-reference/sandbox-functions/text.xml +++ b/function-reference/sandbox-functions/text.xml @@ -63,7 +63,7 @@ recursive, so to allow predicted writes to /foo/bar and /foo/baz,

    See for details on how the sandbox works. -See +See for how to handle sandbox-related build problems.

    diff --git a/general-concepts/autotools/text.xml b/general-concepts/autotools/text.xml index 02a3554..39edb19 100644 --- a/general-concepts/autotools/text.xml +++ b/general-concepts/autotools/text.xml @@ -496,7 +496,7 @@ This is handled via the macro AC_SUBST(VARNAME) in configure.ac.

    Sometimes, badly behaved Makefile.am files will override user variables such as CFLAGS. This must not be allowed see -. +. There are separate special variables which should be used in these situations for setting CFLAGS. for example, a Makefile.am should use AM_CFLAGS so that user preferences are not ignored. diff --git a/general-concepts/dependencies/text.xml b/general-concepts/dependencies/text.xml index 29998cd..3201d91 100644 --- a/general-concepts/dependencies/text.xml +++ b/general-concepts/dependencies/text.xml @@ -74,7 +74,7 @@ distinctions still apply even if it isn't, strictly speaking, cross-compiling.

    Build dependencies are used to specify any dependencies that are required to unpack, patch, compile, test or install the package (but see - for + for exemptions).

    @@ -382,7 +382,7 @@ DEPEND="qt5? ( ~dev-qt/qtcore-5.15.2:5 ) In EAPI=5 and higher, you can use slot operators appended to the package name to declare whether or not your package should be rebuilt after the versions satisfying its runtime dependencies are updated to versions with a different slot -or sub-slot: +or sub-slot:

      diff --git a/general-concepts/ebuild-revisions/text.xml b/general-concepts/ebuild-revisions/text.xml index d363516..2c8531a 100644 --- a/general-concepts/ebuild-revisions/text.xml +++ b/general-concepts/ebuild-revisions/text.xml @@ -7,7 +7,7 @@

      Ebuilds may have a Gentoo revision number associated with them. This is a -rX suffix, where X is an integer see -. +. This component must only be used for Gentoo changes, not upstream releases. An ebuild with no explicit revision number has the implicit -r0 revision. @@ -40,7 +40,7 @@ of thumb could be used as a guideline: as such), then a new revision should be introduced and the old one kept. If the package has stable keywords, the new revision should be dropped to ~arch (see - ). + ). For any such revision bump, the new ebuild should be based on the previous revision to ensure that fixes aren't dropped accidentally. diff --git a/general-concepts/manifest/text.xml b/general-concepts/manifest/text.xml index 11ed7cb..eb0d700 100644 --- a/general-concepts/manifest/text.xml +++ b/general-concepts/manifest/text.xml @@ -70,7 +70,7 @@ longer matches the computed checksum of the fetched distfile.

      Special care is also required with regard to - + mirrors.

      diff --git a/general-concepts/mirrors/text.xml b/general-concepts/mirrors/text.xml index 927a3a6..5bc8f73 100644 --- a/general-concepts/mirrors/text.xml +++ b/general-concepts/mirrors/text.xml @@ -70,7 +70,8 @@ fetch and start distributing the new version.

      Updating an existing distfile is generally cause for concern and must be done -with care, see . +with care, see +.

      diff --git a/general-concepts/sandbox/text.xml b/general-concepts/sandbox/text.xml index 8dcaeb1..06da4d3 100644 --- a/general-concepts/sandbox/text.xml +++ b/general-concepts/sandbox/text.xml @@ -22,7 +22,7 @@ generally not the correct solution.

      See for details on sandbox-related functions. See for suggestions +link="::appendices/common-problems/#Handling access violations"/> for suggestions on fixing sandbox-related build problems.

      diff --git a/general-concepts/slotting/text.xml b/general-concepts/slotting/text.xml index a0fb1e1..f45263f 100644 --- a/general-concepts/slotting/text.xml +++ b/general-concepts/slotting/text.xml @@ -41,7 +41,7 @@ possible that the user may have foo-2.0 installed and no foo-1.x a

      To DEPEND upon a package in a specific slot, refer to -. +.

      @@ -55,7 +55,7 @@ but it's undesirable or inconvenient to allow some of these versions to be insta simultaneously. In EAPI=5 and higher, this situation can be handled by using sub-slots, which are delimited from the regular slot by a / character, as in SLOT="slot/subslot". Packages can -request to be +request to be automatically rebuilt when the subslot of a runtime dependency changes.

      diff --git a/general-concepts/tree/text.xml b/general-concepts/tree/text.xml index e686b54..f1877fd 100644 --- a/general-concepts/tree/text.xml +++ b/general-concepts/tree/text.xml @@ -102,7 +102,7 @@ U+0021 to U+007E (see also GLEP 31). Any characters that have a special meaning in Bash or in SRC_URI should also be avoided. If necessary, upstream files can be -renamed using +renamed using -> syntax.

      diff --git a/keywording/text.xml b/keywording/text.xml index 4174249..4360b49 100644 --- a/keywording/text.xml +++ b/keywording/text.xml @@ -241,7 +241,7 @@ manually removed during the testing process, which is cumbersome. When committing, make sure that you reference any bugs in the commit message. -See for how +See for how to do this. diff --git a/profiles/categories/text.xml b/profiles/categories/text.xml index 70dfe8f..c6bfa49 100644 --- a/profiles/categories/text.xml +++ b/profiles/categories/text.xml @@ -16,7 +16,7 @@ Please consult the gentoo-dev mailing list before adding a new category.

      The categories file is a straight list. For descriptions, see . +link="::ebuild-writing/misc-files/metadata/#Category metadata"/>.

      diff --git a/profiles/use.mask/text.xml b/profiles/use.mask/text.xml index 4de9686..543d439 100644 --- a/profiles/use.mask/text.xml +++ b/profiles/use.mask/text.xml @@ -38,7 +38,7 @@ additions are sorted chronologically, starting at the top of the file

      -See for more discussion. +See for more discussion.

      diff --git a/quickstart/text.xml b/quickstart/text.xml index f311ad9..32e3ede 100644 --- a/quickstart/text.xml +++ b/quickstart/text.xml @@ -195,7 +195,7 @@ failed.

      In the ctags example, we didn't tell Portage about any dependencies. As it happens, that's ok, because ctags only needs a basic toolchain to compile and -run (see +run (see for why we don't need to depend upon those explicitly). However, life is rarely that simple.

      @@ -233,7 +233,7 @@ Again, you can see the ebuild header and the various informational variables. In SRC_URI, ${PN} is used to get the package's name without the version suffix (there are more of these variables see -). +).

      @@ -300,7 +300,8 @@ Note the ${FILESDIR}/${P}-destdir.patch this refers to detox-1.1.0-destdir.patch, which lives in the files/ subdirectory in the Gentoo repository. Larger patch files must go on your developer's space at dev.gentoo.org rather than in files/ or -mirrors see and +mirrors +see and .

      diff --git a/tools-reference/bash/text.xml b/tools-reference/bash/text.xml index 1c2148e..57c3d56 100644 --- a/tools-reference/bash/text.xml +++ b/tools-reference/bash/text.xml @@ -486,7 +486,7 @@ done < some_file

      -See +See for an explanation of why while read < file should be used over cat file | while read.

      diff --git a/tools-reference/text.xml b/tools-reference/text.xml index 781d4af..7ed3ce3 100644 --- a/tools-reference/text.xml +++ b/tools-reference/text.xml @@ -12,7 +12,7 @@ ebuilds.

      Please keep in mind the need for -error handling +error handling when using these tools in ebuilds.

      -- cgit v1.2.3-65-gdbad