summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 79fc95f..86334f6 100644
--- a/Makefile
+++ b/Makefile
@@ -3,15 +3,16 @@ PV = $(shell sed '/^[ \t]*\* .*[Vv]ersion/!d;s/[^0-9.]*\([0-9.]*\).*/\1/;q' \
ChangeLog)
P = $(PN)-$(PV)
-DISTFILE = gentoo-syntax.el
+DISTFILES = gentoo-syntax.el ChangeLog
.PHONY: all dist clean
all:
-dist: $(DISTFILE)
- bzip2 -c $< >$(P).el.bz2
+dist: $(DISTFILES)
+ tar -cjf $(P).tar.bz2 --transform='s%^%$(P)/%' $^
+ tar -tjvf $(P).tar.bz2
clean:
-rm -f *~ *.tmp *.gz *.bz2