summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac7
-rw-r--r--doc/php-fpm.example.init.in.in2
2 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9f8b4eb..ac55443 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,13 @@ AC_ARG_ENABLE(
esac],[apache2=false])
AM_CONDITIONAL([APACHE2], [test x$apache2 = xtrue])
+piddir=${piddir="@LOCALSTATEDIR@"}
+AC_ARG_WITH(piddir, AC_HELP_STRING([--with-piddir=DIR],
+ [where php-fpm PID files are placed [LOCALSTATEDIR]]),
+ if test x$withval != x -a x$withval != xno -a x$withval != xyes; then
+ piddir="$withval"
+ fi)
+AC_SUBST(piddir)
# List of output files.
AC_CONFIG_FILES([Makefile src/php.eselect.in doc/php-fpm.example.init.in])
diff --git a/doc/php-fpm.example.init.in.in b/doc/php-fpm.example.init.in.in
index add56b4..04fb26f 100644
--- a/doc/php-fpm.example.init.in.in
+++ b/doc/php-fpm.example.init.in.in
@@ -23,7 +23,7 @@ fi
PHP_FPM_CONF="@SYSCONFDIR@/php/fpm-${PHP_SLOT}/php-fpm.conf"
command="@LIBDIR@/${PHP_SLOT}/bin/php-fpm"
-pidfile="/run/php-fpm-${PHP_SLOT}.pid"
+pidfile="@piddir@/php-fpm-${PHP_SLOT}.pid"
# Force the daemon into the background and make it use our pid file,
# regardless of what the config file says.