aboutsummaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fc052a83e..d8a75f88c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,11 +2,13 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = \
shared \
- libudev \
+ libudev
+
+PROGRAMS_SUBDIRS = \
udev
# Helper programs
-SUBDIRS += \
+PROGRAMS_SUBDIRS += \
ata_id \
cdrom_id \
collect \
@@ -14,6 +16,10 @@ SUBDIRS += \
v4l_id
if ENABLE_MTD_PROBE
-SUBDIRS += \
+PROGRAMS_SUBDIRS += \
mtd_probe
endif
+
+if ENABLE_PROGRAMS
+SUBDIRS += $(PROGRAMS_SUBDIRS)
+endif