aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-12-21 14:39:04 -0500
committerAnthony G. Basile <blueness@gentoo.org>2013-12-21 14:39:04 -0500
commit9b28180aa87bcb6e005b699df27facce556e67fc (patch)
treed5ff1bf8c5d8bf5a0b7842d44b3d8f43f0bc110a
parentnet-libs/webkit-gtk: fix unbalanced bracket (diff)
downloadhardened-dev-9b28180aa87bcb6e005b699df27facce556e67fc.tar.gz
hardened-dev-9b28180aa87bcb6e005b699df27facce556e67fc.tar.bz2
hardened-dev-9b28180aa87bcb6e005b699df27facce556e67fc.zip
app-arch/lrzip: add missing stdarg.h, bug #492976
Package-Manager: portage-2.2.7 RepoMan-Options: --force Manifest-Sign-Key: 0xF52D4BBA
-rw-r--r--app-arch/lrzip/Manifest4
-rw-r--r--app-arch/lrzip/files/lrzip-add-missing-header.patch11
-rw-r--r--app-arch/lrzip/lrzip-0.616-r99.ebuild34
-rw-r--r--app-arch/lrzip/metadata.xml14
4 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/lrzip/Manifest b/app-arch/lrzip/Manifest
new file mode 100644
index 00000000..43f6629c
--- /dev/null
+++ b/app-arch/lrzip/Manifest
@@ -0,0 +1,4 @@
+AUX lrzip-add-missing-header.patch 260 SHA256 45f56992afe093b3d10999d74bbd0eacd415830b97b3c94abec9dd94b621f09f SHA512 786c4086fa1d69f31e3a460d8ae5c30ea08a0aaceac0e32cfd55285a0b7a2ddc58552fc93745962d072ad6eb7691e864cf6a0e76e24a16a7eebb662053a4682f WHIRLPOOL 350743f4bf69dac4cedee6d9ad195cb6e035232336d8ba57d2b32b4f75c58ec3672133a1742af850dd15c325c5ccecb6f9e4519e0e71c16398d1bdbe484f056f
+DIST lrzip-0.616.tar.bz2 493886 SHA256 982d5a8db4d8bbbced6e33fbbcd589c9b3fc4275110155d7bd71cbeff4a235ae SHA512 f578034fa41c5be6df9b9d8e7efe5014229e1acecdd5d6090c26322e1e46db98e3bc17d780eca96342a0bcb56b8e78b008b3293520b82c1bbbd5a96e423d4b3f WHIRLPOOL bc7b22a579de42657c46f4dad426dfdb5cc37e1f54955cb66722ccbfc9b66d19194eb1f1a4d9f545de7859de7903d57854a1af647ff6c3341907fcc874351d94
+EBUILD lrzip-0.616-r99.ebuild 784 SHA256 06871599d88091bd23ec6fa1a56e15c8cb5444e43777e6d24d1c5b13f023c515 SHA512 edd47cba729cd88fd89b03676cdf02c2c03a04a20e6186a8a9cfb094e16d04b2e17cd5d73e9576736a8dc200c414640c27fce902461e6040a17fa5925d8fe0e4 WHIRLPOOL eafb11f585bc036ca95ff9cc579e6db79b90f4a693e7d9cf76a3bee1bd96a9781428e785db6f62a5b08550a291556dfda4f746331dc6f6b15f9de44024e2711a
+MISC metadata.xml 578 SHA256 6ae85de9ba3a2071f86545caab17fbf315a8aa84cf680c2937d5c26888728e81 SHA512 9f87473190916df0122978136401c8a164b632e3df05794358c69dadf3d027bf72da1dededbee3b37c7af6f629a2a7b03b5cc174493b07731ce009d247b7ea70 WHIRLPOOL a6788d62d42b5c477681048dc886e12f147f51ed0a5c73602a8a008d51c874ed9285d92fe6bc4a02725589fa089ff2a66f29ed7f83d9af241181607eb23208b4
diff --git a/app-arch/lrzip/files/lrzip-add-missing-header.patch b/app-arch/lrzip/files/lrzip-add-missing-header.patch
new file mode 100644
index 00000000..dcc698bd
--- /dev/null
+++ b/app-arch/lrzip/files/lrzip-add-missing-header.patch
@@ -0,0 +1,11 @@
+diff -Naur Lrzip.h.orig Lrzip.h
+--- Lrzip.h.orig 2013-11-30 20:07:27.343086997 +0000
++++ Lrzip.h 2013-11-30 20:07:44.072641056 +0000
+@@ -22,6 +22,7 @@
+
+ #include <stdbool.h>
+ #include <stdio.h>
++#include <stdarg.h>
+ #ifdef _WIN32
+ # include <stddef.h>
+ #else
diff --git a/app-arch/lrzip/lrzip-0.616-r99.ebuild b/app-arch/lrzip/lrzip-0.616-r99.ebuild
new file mode 100644
index 00000000..41a78b9f
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.616-r99.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lrzip/lrzip-0.616.ebuild,v 1.1 2013/10/26 10:22:22 yngwin Exp $
+
+EAPI=5
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="http://ck.kolivas.org/apps/lrzip/README"
+SRC_URI="http://ck.kolivas.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+RDEPEND="dev-libs/lzo
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ virtual/perl-PodParser"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-add-missing-header.patch
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${P}"
+}
+
+src_install() {
+ default
+ rm "${D}/usr/share/doc/${P}/COPYING"
+}
diff --git a/app-arch/lrzip/metadata.xml b/app-arch/lrzip/metadata.xml
new file mode 100644
index 00000000..0d5d78a4
--- /dev/null
+++ b/app-arch/lrzip/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ This is a compression program optimised for large files. The larger the
+ file and the more memory you have, the better the compression advantage
+ this will provide, especially once the files are larger than 100MB.
+ The advantage can be chosen to be either size (much smaller than bzip2)
+ or speed (much faster than bzip2).
+ </longdescription>
+</pkgmetadata>