aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xml/SCAP/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/xml/SCAP/Makefile b/xml/SCAP/Makefile
index 42028e0..93cd449 100644
--- a/xml/SCAP/Makefile
+++ b/xml/SCAP/Makefile
@@ -1,4 +1,4 @@
-all: report-gentoo-xccdf.html guide-gentoo-xccdf.html remediate-gentoo-xccdf.sh guide-gentoo-xccdf.docbook
+all: report-gentoo-xccdf.html guide-gentoo-xccdf.html remediate-gentoo-xccdf.sh guide-gentoo-xccdf.docbook report-gentoo-oval.xml
report-gentoo-xccdf.html: gentoo-cpe.xml gentoo-xccdf.xml gentoo-oval.xml
-oscap xccdf eval --cpe gentoo-cpe.xml --profile xccdf_org.gentoo.dev.swift_profile_default-oval --results ~/tmp/results-gentoo-xccdf.xml --oval-results --report ~/tmp/report-gentoo-xccdf.html gentoo-xccdf.xml
@@ -17,4 +17,7 @@ gentoo-ds.xml:
oscap ds sds-compose gentoo-xccdf.xml ~/tmp/gentoo-ds.xml
oscap ds sds-add gentoo-cpe.xml ~/tmp/gentoo-ds.xml
+report-gentoo-oval.xml:
+ oscap oval eval --report ~/tmp/report-gentoo-oval.html --results ~/tmp/results-gentoo-oval.xml gentoo-oval.xml
+
.PHONY: all