diff options
author | 2008-02-11 22:09:00 +0000 | |
---|---|---|
committer | 2008-02-11 22:09:00 +0000 | |
commit | 7383adfcedafa35f86fe3fd3ed5e3e6ba1eeacb7 (patch) | |
tree | d9f2998383f2e6b12d3b0c6dda1639f9d9a64077 | |
parent | Mixed up the argument order for copy_file. (diff) | |
download | java-config-7383adfcedafa35f86fe3fd3ed5e3e6ba1eeacb7.tar.gz java-config-7383adfcedafa35f86fe3fd3ed5e3e6ba1eeacb7.tar.bz2 java-config-7383adfcedafa35f86fe3fd3ed5e3e6ba1eeacb7.zip |
copy_file is not able to handle --root with relative symbolic links
svn path=/projects/java-config-2/trunk/; revision=6022
-rw-r--r-- | setup.py | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -1,6 +1,8 @@ #!/usr/bin/env python from distutils.command.install_scripts import install_scripts +from distutils import log +import os class my_install_scripts(install_scripts): """Specialized data file install to handle our symlinks""" @@ -19,7 +21,10 @@ class my_install_scripts(install_scripts): install_scripts.run(self) for tool in self.symlink_tools: s = self.install_dir + '/' + tool - self.copy_file('run-java-tool',s,link='sym') + log.info("symbolically linking %s -> %s" % ('run-java-tool',s)) + if not self.dry_run: + #copy_file is not able to handle relative symlinks with --root + os.symlink('run-java-tool',s) from distutils.core import setup from glob import glob |