aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycups/pycups-1.9.63.ebuild')
-rw-r--r--dev-python/pycups/pycups-1.9.63.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pycups/pycups-1.9.63.ebuild b/dev-python/pycups/pycups-1.9.63.ebuild
new file mode 100644
index 0000000000..0b51d57c6d
--- /dev/null
+++ b/dev-python/pycups/pycups-1.9.63.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the CUPS API"
+HOMEPAGE="http://cyberelk.net/tim/software/pycups/"
+SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ net-print/cups
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+"
+
+python_compile_all() {
+ if use doc; then
+ emake doc
+ fi
+}
+
+python_install_all() {
+ if use doc; then
+ dohtml -r html/
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples/
+ fi
+}