summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2005-12-13 17:20:25 +0000
committerDaniel Veillard <veillard@redhat.com>2005-12-13 17:20:25 +0000
commita4de636ade5e66fa0996822b29c6db14e1c8d9a5 (patch)
tree886848e7f37ed94c30755f37bb053910b161e6b3
parent* include/libvir.h src/Makefile.am src/internal.h src/libvir.c (diff)
downloadlibvirt-a4de636ade5e66fa0996822b29c6db14e1c8d9a5.tar.gz
libvirt-a4de636ade5e66fa0996822b29c6db14e1c8d9a5.tar.bz2
libvirt-a4de636ade5e66fa0996822b29c6db14e1c8d9a5.zip
Adding an FAQ about the ro store socket permissions, Daniel
-rw-r--r--docs/FAQ.html7
-rw-r--r--docs/bugs.html5
-rw-r--r--docs/index.html3
-rw-r--r--docs/libvir.html18
-rw-r--r--docs/news.html6
5 files changed, 26 insertions, 13 deletions
diff --git a/docs/FAQ.html b/docs/FAQ.html
index 5819afc98..57723fbae 100644
--- a/docs/FAQ.html
+++ b/docs/FAQ.html
@@ -40,6 +40,13 @@ A:link, A:visited, A:active { text-decoration: underline }
<p>Or from a configured tree with:</p>
<p><code>make rpm</code></p>
</li>
+ <li><em>Failure to use the API for non-root users</em>
+ <p>Large parts of the API are only accessible as root, however the read
+ only access to the xenstore data doesnot have to be forbidden to user, at
+ least for monitoring purposes. If "virsh info" fails to run as an user,
+ change the mode of the xenstore read-only socket with:</p>
+ <p><code>chmod 666 /var/run/xenstored/socket_ro</code></p>
+ </li>
</ol><h3><a name="Compilatio" id="Compilatio">Compilation</a></h3><ol><li><em>What is the process to compile libvir ?</em>
<p>As most UNIX libraries libvir follows the "standard":</p>
<p><code>gunzip -c libvir-xxx.tar.gz | tar xvf -</code></p>
diff --git a/docs/bugs.html b/docs/bugs.html
index e8e6b69f7..e4d4275fe 100644
--- a/docs/bugs.html
+++ b/docs/bugs.html
@@ -11,8 +11,7 @@ A:link, A:visited, A:active { text-decoration: underline }
with an <a href="https://www.redhat.com/archives/libvir-list/">on-line
archive</a>. Please subscribe to this list before posting by visiting the <a href="https://www.redhat.com/mailman/listinfo/libvir-list">associated Web</a>
page and follow the instructions. Patches with explanations and provided as
-attachments are really appreciated and will be discussed on the mailing
-list. If possible generate the patches by using cvs diff -u in a CVS
-checkout.</p><p>We expect to use <a href="https://bugzilla.redhat.com/">Red Hat
+attachments are really appreciated and will be discussed on the mailing list.
+If possible generate the patches by using cvs diff -u in a CVS checkout.</p><p>We expect to use <a href="https://bugzilla.redhat.com/">Red Hat
Bugzilla</a> to track bugs for libvir, though there isn't yet a libvir
software module.</p><p><a href="bugs.html">Daniel Veillard</a></p></td></tr></table></td></tr></table></td></tr></table></td></tr></table></td></tr></table></body></html>
diff --git a/docs/index.html b/docs/index.html
index 98229362f..881894794 100644
--- a/docs/index.html
+++ b/docs/index.html
@@ -1,7 +1,8 @@
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
- <head><meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
+ <head>
+ <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
<link rel="SHORTCUT ICON" href="/favicon.ico" />
<style type="text/css">
TD {font-family: Verdana,Arial,Helvetica}
diff --git a/docs/libvir.html b/docs/libvir.html
index 30ea33783..979222758 100644
--- a/docs/libvir.html
+++ b/docs/libvir.html
@@ -26,9 +26,9 @@ virtualization mechanisms if needed.</p>
<h2><a name="News">Releases</a></h2>
-<p>There is no official release yet, just CVS state and snapshot, contact
-the mailing list and check the <a href="ChangeLog.html">ChangeLog</a> to
-gauge progresses.</p>
+<p>There is no official release yet, just CVS state and snapshot, contact the
+mailing list and check the <a href="ChangeLog.html">ChangeLog</a> to gauge
+progresses.</p>
<ul>
<li>Extending the API</li>
</ul>
@@ -112,6 +112,13 @@ available except commiting to the base.</p>
<p>Or from a configured tree with:</p>
<p><code>make rpm</code></p>
</li>
+ <li><em>Failure to use the API for non-root users</em>
+ <p>Large parts of the API are only accessible as root, however the read
+ only access to the xenstore data doesnot have to be forbidden to user, at
+ least for monitoring purposes. If "virsh info" fails to run as an user,
+ change the mode of the xenstore read-only socket with:</p>
+ <p><code>chmod 666 /var/run/xenstored/socket_ro</code></p>
+ </li>
</ol>
<h3><a name="Compilatio">Compilation</a></h3>
@@ -158,9 +165,8 @@ with an <a href="https://www.redhat.com/archives/libvir-list/">on-line
archive</a>. Please subscribe to this list before posting by visiting the <a
href="https://www.redhat.com/mailman/listinfo/libvir-list">associated Web</a>
page and follow the instructions. Patches with explanations and provided as
-attachments are really appreciated and will be discussed on the mailing
-list. If possible generate the patches by using cvs diff -u in a CVS
-checkout.</p>
+attachments are really appreciated and will be discussed on the mailing list.
+If possible generate the patches by using cvs diff -u in a CVS checkout.</p>
<p>We expect to use <a href="https://bugzilla.redhat.com/">Red Hat
Bugzilla</a> to track bugs for libvir, though there isn't yet a libvir
diff --git a/docs/news.html b/docs/news.html
index 2752083d6..36727360d 100644
--- a/docs/news.html
+++ b/docs/news.html
@@ -7,7 +7,7 @@ H1 {font-family: Verdana,Arial,Helvetica}
H2 {font-family: Verdana,Arial,Helvetica}
H3 {font-family: Verdana,Arial,Helvetica}
A:link, A:visited, A:active { text-decoration: underline }
-</style><title>Releases</title></head><body bgcolor="#8b7765" text="#000000" link="#a06060" vlink="#000000"><table border="0" width="100%" cellpadding="5" cellspacing="0" align="center"><tr><td width="120"><a href="http://www.redhat.com/"><img src="redhat.gif" alt="Red Hat Logo" /></a></td><td><table border="0" width="90%" cellpadding="2" cellspacing="0" align="center" bgcolor="#000000"><tr><td><table width="100%" border="0" cellspacing="1" cellpadding="3" bgcolor="#fffacd"><tr><td align="center"><h1>Libvir the virtualization API</h1><h2>Releases</h2></td></tr></table></td></tr></table></td></tr></table><table border="0" cellpadding="4" cellspacing="0" width="100%" align="center"><tr><td bgcolor="#8b7765"><table border="0" cellspacing="0" cellpadding="2" width="100%"><tr><td valign="top" width="200" bgcolor="#8b7765"><table border="0" cellspacing="0" cellpadding="1" width="100%" bgcolor="#000000"><tr><td><table width="100%" border="0" cellspacing="1" cellpadding="3"><tr><td colspan="1" bgcolor="#eecfa1" align="center"><center><b>Main Menu</b></center></td></tr><tr><td bgcolor="#fffacd"><form action="search.php" enctype="application/x-www-form-urlencoded" method="get"><input name="query" type="text" size="20" value="" /><input name="submit" type="submit" value="Search ..." /></form><ul><li><a href="index.html">Home</a></li><li><a href="news.html">Releases</a></li><li><a href="intro.html">Introduction</a></li><li><a href="downloads.html">Downloads</a></li><li><a href="FAQ.html">FAQ</a></li><li><a href="bugs.html">Reporting bugs and getting help</a></li><li><a style="font-weight:bold" href="html/index.html">API Menu</a></li><li><a href="ChangeLog.html">Recent Changes</a></li></ul></td></tr></table><table width="100%" border="0" cellspacing="1" cellpadding="3"><tr><td colspan="1" bgcolor="#eecfa1" align="center"><center><b>Related links</b></center></td></tr><tr><td bgcolor="#fffacd"><ul><li><a href="https://www.redhat.com/archives/libvir-list/">Mail archive</a></li><li><a href="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html">Xen project</a></li></ul></td></tr></table></td></tr></table><a href="http://xmlsoft.org/"><img src="Libxml2-Logo-90x34.gif" alt="Made with Libxml2 Logo" /></a></td><td valign="top" bgcolor="#8b7765"><table border="0" cellspacing="0" cellpadding="1" width="100%"><tr><td><table border="0" cellspacing="0" cellpadding="1" width="100%" bgcolor="#000000"><tr><td><table border="0" cellpadding="3" cellspacing="1" width="100%"><tr><td bgcolor="#fffacd"><p>There is no official release yet, just CVS state and snapshot, contact
-the mailing list and check the <a href="ChangeLog.html">ChangeLog</a> to
-gauge progresses.</p><ul><li>Extending the API</li>
+</style><title>Releases</title></head><body bgcolor="#8b7765" text="#000000" link="#a06060" vlink="#000000"><table border="0" width="100%" cellpadding="5" cellspacing="0" align="center"><tr><td width="120"><a href="http://www.redhat.com/"><img src="redhat.gif" alt="Red Hat Logo" /></a></td><td><table border="0" width="90%" cellpadding="2" cellspacing="0" align="center" bgcolor="#000000"><tr><td><table width="100%" border="0" cellspacing="1" cellpadding="3" bgcolor="#fffacd"><tr><td align="center"><h1>Libvir the virtualization API</h1><h2>Releases</h2></td></tr></table></td></tr></table></td></tr></table><table border="0" cellpadding="4" cellspacing="0" width="100%" align="center"><tr><td bgcolor="#8b7765"><table border="0" cellspacing="0" cellpadding="2" width="100%"><tr><td valign="top" width="200" bgcolor="#8b7765"><table border="0" cellspacing="0" cellpadding="1" width="100%" bgcolor="#000000"><tr><td><table width="100%" border="0" cellspacing="1" cellpadding="3"><tr><td colspan="1" bgcolor="#eecfa1" align="center"><center><b>Main Menu</b></center></td></tr><tr><td bgcolor="#fffacd"><form action="search.php" enctype="application/x-www-form-urlencoded" method="get"><input name="query" type="text" size="20" value="" /><input name="submit" type="submit" value="Search ..." /></form><ul><li><a href="index.html">Home</a></li><li><a href="news.html">Releases</a></li><li><a href="intro.html">Introduction</a></li><li><a href="downloads.html">Downloads</a></li><li><a href="FAQ.html">FAQ</a></li><li><a href="bugs.html">Reporting bugs and getting help</a></li><li><a style="font-weight:bold" href="html/index.html">API Menu</a></li><li><a href="ChangeLog.html">Recent Changes</a></li></ul></td></tr></table><table width="100%" border="0" cellspacing="1" cellpadding="3"><tr><td colspan="1" bgcolor="#eecfa1" align="center"><center><b>Related links</b></center></td></tr><tr><td bgcolor="#fffacd"><ul><li><a href="https://www.redhat.com/archives/libvir-list/">Mail archive</a></li><li><a href="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html">Xen project</a></li></ul></td></tr></table></td></tr></table><a href="http://xmlsoft.org/"><img src="Libxml2-Logo-90x34.gif" alt="Made with Libxml2 Logo" /></a></td><td valign="top" bgcolor="#8b7765"><table border="0" cellspacing="0" cellpadding="1" width="100%"><tr><td><table border="0" cellspacing="0" cellpadding="1" width="100%" bgcolor="#000000"><tr><td><table border="0" cellpadding="3" cellspacing="1" width="100%"><tr><td bgcolor="#fffacd"><p>There is no official release yet, just CVS state and snapshot, contact the
+mailing list and check the <a href="ChangeLog.html">ChangeLog</a> to gauge
+progresses.</p><ul><li>Extending the API</li>
</ul><p><a href="bugs.html">Daniel Veillard</a></p></td></tr></table></td></tr></table></td></tr></table></td></tr></table></td></tr></table></body></html>