aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-02-24 15:18:51 +0100
committerJim Meyering <meyering@redhat.com>2010-02-25 10:50:18 +0100
commit083b901eb3585e63273fe28214ca5c190fb38f0c (patch)
tree6f50270db890741200705dd0f42355f682972e0a /Makefile.am
parentbuild: avoid non-srcdir "make distcheck" failure (test_conf.sh) (diff)
downloadlibvirt-083b901eb3585e63273fe28214ca5c190fb38f0c.tar.gz
libvirt-083b901eb3585e63273fe28214ca5c190fb38f0c.tar.bz2
libvirt-083b901eb3585e63273fe28214ca5c190fb38f0c.zip
build: avoid non-srcdir "make distcheck" failures (srcdir vs wildcard)
* tests/xencapsdata/Makefile.am: Use $(wildcard in $(srcdir)-aware manner * tests/xmconfigdata/Makefile.am: Likewise. * tests/xml2sexprdata/Makefile.am: Likewise. * tests/sexpr2xmldata/Makefile.am (EXTRA_DIST): Likewise. * Makefile.am (XML_EXAMPLES): Use $(wildcard in $(srcdir)-aware manner.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a02cd2618..09439c834 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,7 +9,9 @@ SUBDIRS = gnulib/lib include src daemon tools proxy docs gnulib/tests \
ACLOCAL_AMFLAGS = -I m4 -I gnulib/m4
-XML_EXAMPLES = $(wildcard examples/xml/test/*.xml) $(wildcard examples/xml/storage/*.xml)
+XML_EXAMPLES = \
+ $(patsubst $(srcdir)/%,%,$(wildcard $(addprefix $(srcdir)/examples/xml/, \
+ test/*.xml storage/*.xml)))
EXTRA_DIST = \
ChangeLog-old \