aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard W.M. Jones <rjones@redhat.com>2008-10-10 11:33:10 +0000
committerRichard W.M. Jones <rjones@redhat.com>2008-10-10 11:33:10 +0000
commit0ae26314b3172a59dc91668dfdd9eac0cb7d4801 (patch)
tree820ab6485d47887bc0a314350d49049516426edc /autobuild.sh
parentvirDomainDefineXML, and a few additional cleanups (diff)
downloadlibvirt-0ae26314b3172a59dc91668dfdd9eac0cb7d4801.tar.gz
libvirt-0ae26314b3172a59dc91668dfdd9eac0cb7d4801.tar.bz2
libvirt-0ae26314b3172a59dc91668dfdd9eac0cb7d4801.zip
Updated MinGW spec file.
* .cvsignore, Makefile.am, autobuild.sh, configure.in, mingw32-libvirt.spec.in: Import the latest MinGW libvirt spec file. Note that the file has been renamed to conform to new Fedora packaging guidelines. * autobuild.sh: Fix a bug in the generation of the $EXTRA_RELEASE field when autobuilding.
Diffstat (limited to 'autobuild.sh')
-rwxr-xr-xautobuild.sh24
1 files changed, 13 insertions, 11 deletions
diff --git a/autobuild.sh b/autobuild.sh
index 50b4e0ce7..e62926c43 100755
--- a/autobuild.sh
+++ b/autobuild.sh
@@ -42,14 +42,14 @@ test -x /usr/bin/lcov && make cov
rm -f *.tar.gz
make dist
-if [ -f /usr/bin/rpmbuild ]; then
- if [ -n "$AUTOBUILD_COUNTER" ]; then
- EXTRA_RELEASE=".auto$AUTOBUILD_COUNTER"
- else
- NOW=`date +"%s"`
- EXTRA_RELEASE=".$USER$NOW"
- fi
+if [ -n "$AUTOBUILD_COUNTER" ]; then
+ EXTRA_RELEASE=".auto$AUTOBUILD_COUNTER"
+else
+ NOW=`date +"%s"`
+ EXTRA_RELEASE=".$USER$NOW"
+fi
+if [ -f /usr/bin/rpmbuild ]; then
rpmbuild --nodeps \
--define "extra_release $EXTRA_RELEASE" \
--define "_sourcedir `pwd`" \
@@ -81,8 +81,10 @@ if [ -x /usr/bin/i686-pc-mingw32-gcc ]; then
#set -o pipefail
#make check 2>&1 | tee "$RESULTS"
- rpmbuild --nodeps \
- --define "extra_release $EXTRA_RELEASE" \
- --define "_sourcedir `pwd`" \
- -ba --clean mingw-libvirt.spec
+ if [ -f /usr/bin/rpmbuild ]; then
+ rpmbuild --nodeps \
+ --define "extra_release $EXTRA_RELEASE" \
+ --define "_sourcedir `pwd`" \
+ -ba --clean mingw32-libvirt.spec
+ fi
fi