diff options
author | Eric Blake <eblake@redhat.com> | 2010-10-05 09:10:31 -0600 |
---|---|---|
committer | Eric Blake <eblake@redhat.com> | 2010-10-05 13:54:39 -0600 |
commit | b0f34a6a1aec26bba4588d04050455f7373cc942 (patch) | |
tree | 14b25e1d650ea18ac78a4ca8594bcc8fac9cf898 /bootstrap | |
parent | xen: Fix bogus error when attaching a device (diff) | |
download | libvirt-b0f34a6a1aec26bba4588d04050455f7373cc942.tar.gz libvirt-b0f34a6a1aec26bba4588d04050455f7373cc942.tar.bz2 libvirt-b0f34a6a1aec26bba4588d04050455f7373cc942.zip |
build: require pkg-config for bootstrap
* .gnulib: Update to latest, for bootstrap fixes.
* bootstrap: Synchronize with upstream.
* bootstrap.conf: Add pkg-config pre-requisite.
* autogen.sh: Tweak wording message.
Reported by Justin Clift, and with feedback from Bruno Haible.
Diffstat (limited to 'bootstrap')
-rwxr-xr-x | bootstrap | 18 |
1 files changed, 10 insertions, 8 deletions
@@ -1,6 +1,6 @@ #! /bin/sh # Print a version string. -scriptversion=2010-09-30.17; # UTC +scriptversion=2010-10-05.15; # UTC # Bootstrap this package from checked-out sources. @@ -351,7 +351,7 @@ check_versions() { app=libtoolize fi # Honor $APP variables ($TAR, $AUTOCONF, etc.) - appvar=`echo $app | tr '[a-z]' '[A-Z]'` + appvar=`echo $app | tr '[a-z]-' '[A-Z]_'` test "$appvar" = TAR && appvar=AMTAR eval "app=\${$appvar-$app}" inst_ver=$(get_version $app) @@ -374,7 +374,7 @@ check_versions() { print_versions() { echo "Program Min_version" echo "----------------------" - printf "$buildreq" + printf %s "$buildreq" echo "----------------------" # can't depend on column -t } @@ -392,10 +392,12 @@ if test $use_libtool = 1; then fi if ! printf "$buildreq" | check_versions; then - test -f README-prereq && - echo "See README-prereq for notes on obtaining these prerequisite programs:" >&2 - echo - print_versions + echo >&2 + if test -f README-prereq; then + echo "See README-prereq for notes on obtaining the prerequisite programs" >&2 + else + echo "Please install the prerequisite programs" >&2 + fi exit 1 fi @@ -800,7 +802,7 @@ grep -E '^[ ]*AC_CONFIG_HEADERS?\>' configure.ac >/dev/null || for command in \ libtool \ - "${ACLOCAL-aclocal} --force -I m4" \ + "${ACLOCAL-aclocal} --force -I m4 $ACLOCAL_FLAGS" \ "${AUTOCONF-autoconf} --force" \ "${AUTOHEADER-autoheader} --force" \ "${AUTOMAKE-automake} --add-missing --copy --force-missing" |