diff options
author | Eric Blake <eblake@redhat.com> | 2012-04-24 21:40:08 -0600 |
---|---|---|
committer | Eric Blake <eblake@redhat.com> | 2012-04-25 16:25:49 -0600 |
commit | bae13129c1283bd9e3d21a76f2d376a0f38b371d (patch) | |
tree | 7dde42d4399705160c0fc62959d27aca297ab2e5 /bootstrap | |
parent | Add new functions to virSocketAddr (diff) | |
download | libvirt-bae13129c1283bd9e3d21a76f2d376a0f38b371d.tar.gz libvirt-bae13129c1283bd9e3d21a76f2d376a0f38b371d.tar.bz2 libvirt-bae13129c1283bd9e3d21a76f2d376a0f38b371d.zip |
build: fix bootstrap on RHEL
Commit 8fe455fd364cd7462e02170084c45a58ee302cc3 tried to work around
a regression introduced in upstream gnulib that requires gettext 0.18
or newer on all projects using bootstrap, by making libvirt require
gettext 0.18. But this fails on RHEL 6.2, which still ships gettext
0.17. Revert that change, and instead, import the latest round of
gnulib updates that fix that problem properly.
If you have already built in the window where libvirt required 0.18,
be aware that incremental updates may run into problems: this is
because 'autopoint --force' will not downgrade m4/po.m4 back to an
older version, but it must be downgraded back to 0.17 levels to work
with this patch. You may either manually remove that file then rerun
bootstrap, or it may prove easier to just clean up all non-git files
to start from a clean slate.
* bootstrap.conf: Revert minimum gettext back to 0.17.
* configure.ac: Likewise.
* .gnulib: Update to latest, for bootstrap fixes.
* bootstrap: Resync from gnulib.
Diffstat (limited to 'bootstrap')
-rwxr-xr-x | bootstrap | 12 |
1 files changed, 10 insertions, 2 deletions
@@ -1,6 +1,6 @@ #! /bin/sh # Print a version string. -scriptversion=2012-04-19.22; # UTC +scriptversion=2012-04-25.17; # UTC # Bootstrap this package from checked-out sources. @@ -873,7 +873,15 @@ if test $with_gettext = yes; then } ' po/Makevars.template >po/Makevars || exit 1 - cat $GNULIB_SRCDIR/build-aux/po/Makefile.in.in > po/Makefile.in.in || exit 1 + # If the 'gettext' module is in use, grab the latest Makefile.in.in. + # If only the 'gettext-h' module is in use, assume autopoint already + # put the correct version of this file into place. + case $gnulib_modules in + *gettext-h*) ;; + *gettext*) + cp $GNULIB_SRCDIR/build-aux/po/Makefile.in.in po/Makefile.in.in || exit 1 + ;; + esac if test -d runtime-po; then # Similarly for runtime-po/Makevars, but not quite the same. |